[Last Call] Learn about multicloud storage options and how to improve your company's cloud strategy. Register Now

x
?
Solved

Load Sharing between Two links

Posted on 2009-05-17
3
Medium Priority
?
272 Views
Last Modified: 2012-05-07
I have a CISCO 6500 with multiple SUP cards( for redundancy) peering with two diffrent ISP for BGP v4.

ISP1  ISP2
 |     |  
 |     |
Router1

I understand i can share the inbound traffic using AS prepnding but how do i make outbound sharing work ?

I need both lines configured for redundancy and increased throughput..

I am getting default routes from both isp's .


0
Comment
Question by:pehalwaan
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
3 Comments
 
LVL 3

Author Comment

by:pehalwaan
ID: 24409208
Is this which is required ?

router bgp 50
neighbor 1.1.1.1 remote-as x
neighbor 1.1.1.1 prefix-list denyall in
neighbor 2.2.2.2 remote-as y
neighbor 2.2.2.2 prefix-list denyall in

ip route 0.0.0.0 0.0.0.0 1.1.1.1
ip route 0.0.0.0 0.0.0.0 2.2.2.2

ip prefix-list denyall 0.0.0.0/0 le 32
0
 
LVL 43

Accepted Solution

by:
JFrederick29 earned 1500 total points
ID: 24411439
Try using this config:

router bgp 50
bgp bestpath as-path multipath-relax
maximum-paths 2
0
 
LVL 8

Expert Comment

by:Brain2000
ID: 24456778
These are both good solutions.  Let me add to them.

pehalwaan's way is good for equal lines and doesn't require BGP.  Just make sure CEF is enabled so it will do per-destination load balancing.  You will also want to make sure you add SLA Tracking onto the "ip route 0.0.0.0" commands or else you'll get a black hole to half your routes if one of the ISP's goes offline.  This method also does not offer you any control over how much it load balances or if the best gateway is used for a particular customer.

JFrederick29's BGP method will work for BGP outgoing.  I would also recommend a higher level of quality control by adding OER into the mix.  It can be configured to use netflow and ICMP pings (passive and active monitoring) and will adjust which gateway is used by injecting new BGP routes.

OER introductory documentation can be found here:

http://www.cisco.com/univercd/cc/td/doc/solution/tdprpdgx.pdf
http://www.cisco.com/en/US/docs/ios/12_4t/oer/configuration/guide/h_oerstr.html

It's a lot of pages, but don't let it get you down.  A final OER configuration usually isn't more than 20-30 lines of config.  Cisco is just very thorough in explaining it.
0

Featured Post

VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It happens many times that access list (ACL) have to be applied to outgoing router interface in order to limit some traffic.This article is about how to test ACL from the router which is not very intuitive for everyone. Below scenario shows simple s…
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
Suggested Courses

650 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question