Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 534
  • Last Modified:

Setup configuration file not valid with Visual Web developer

When installing MS Visual Web developer 2008 express edition, I get the following error:

The Setup configuration file ...\tmp8B.tmp is not valid.  Run Setup again without using a Setup configuration file, or fix the configuration file.

When opening the tmp8b.tmp file I get the following :

<Configuration Product="VisualWebDeveloper">
  <Logging Type="standard" Path="%temp%" Template="SetupExe(*).log" />
  <OptionState Id="WORDFiles" State="absent" Children="force" />
  <OptionState Id="EXCELFiles" State="absent" Children="force" />
  <OptionState Id="PubPrimary" State="absent" Children="force" />
  <OptionState Id="ACCESSFiles" State="absent" Children="force" />
  <OptionState Id="VISIOFiles" State="absent" Children="force" />
  <OptionState Id="BIFiles" State="absent" Children="force" />
  <OptionState Id="FPClientFiles" State="absent" Children="force" />
  <OptionState Id="IGXFiles" State="absent" Children="force" />
  <OptionState Id="OUTLOOKFiles" State="absent" Children="force" />
  <OptionState Id="OneNoteFiles" State="absent" Children="force" />
  <OptionState Id="PPTFiles" State="absent" Children="force" />
  <OptionState Id="PROJECTFiles" State="absent" Children="force" />
  <OptionState Id="RMSFiles" State="absent" Children="force" />
  <OptionState Id="XDOCSFiles" State="absent" Children="force" />
  <OptionState Id="AceFiles" State="absent" Children="force" />
  <OptionState Id="IgxAppFiles" State="absent" Children="force" />
  <OptionState Id="LimeFiles" State="absent" Children="force" />
  <OptionState Id="SubLimeFiles" State="absent" Children="force" />
  <Display Level="none" CompletionNotice="no" SuppressModal="yes" AcceptEula="yes" />
  <AddLanguage Id="en-us" />
</Configuration>

Any idea how I can fix this problem or how do I "Run Setup again without using a Setup configuration file"???


Thank you!!
0
koossa
Asked:
koossa
1 Solution
 
koossaAuthor Commented:
I have found a solution!

Just install Microsoft XML Parser (MSXML) 3.0 Service Pack 7 (SP7) from Microsoft
http://www.microsoft.com/downloads/details.aspx?familyid=28494391-052b-42ff-9674-f752bdca9582&displaylang=en

Had a little problem with one registry key's permission, but just give the administrator full control and remove all the denies and the installation worked!

0

Featured Post

Become an Android App Developer

Ready to kick start your career in 2018? Learn how to build an Android app in January’s Course of the Month and open the door to new opportunities.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now