Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 225
  • Last Modified:

Rpc over http issues

Hi, I am trying to setup an exchange server on a public ip address and trying to use rpc over http to connect. We are not using ssl. But when we try to connect to it with outlook, we connect to a mailbox and outlook asks us for our username and password repetedly, The username and password is correct because we can connect to owa with that account.
0
espoke
Asked:
espoke
1 Solution
 
Rajith EnchiparambilOffice 365 & Exchange ArchitectCommented:

Create a test account in AD with mailbox and run the rpc over http test in the Microsoft test site.
See what it flags and post the error here.

https://www.testexchangeconnectivity.com/

Rajith.
0
 
MesthaCommented:
You cannot setup RPC over HTTPs without SSL, and you cannot do it on an IP address.
You need to use a valid external host name, with a commercial SSL certificate. Anything else will simply cause failures. You can get SSL certificates for US$30/year which will be fine (https://CertificatesForExchange.com/) and if you want do a proof of concept, RapidSSL do 30 day trial certificates.

Simon.
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
espokeAuthor Commented:
Thanks, I might try the 30 day free tial, If that dosnt work i will get back to you.
0
 
espokeAuthor Commented:
I have applied the cert and it is working because i can log onto the owa through https. I have done the test (https://www.testexchangeconnectivity.com/) that you have suggested and all of the tests are succesfull. I have followed this tutorial to connect outlook to exchange over rpc over https. (http://www.petri.co.il/configure_outlook_2003_to_use_rpc_over_http.htm) when it asks for my username and password, I enter the username and password and the dialogue box pops up again. It will not accept the username and password even though it is the same on as i use on owa.
0
 
MesthaCommented:
That is usually down to having anonymous enabled on the rpc virtual directory. Ensure that it is not.

Simon.
0
 
espokeAuthor Commented:
Nope, Only basic security is enabled, and we are using basic security inb outlook. Enable anonymous access in not ticked. Thanks though.
0
 
MesthaCommented:
Is the machine a member of the domain? If so then you can enable integrated authenticated on the virtual directory as well, and use NTLM in Outlook. You shouldn't get any authentication prompts then.

Do ensure that you have setup the client correctly, with all of the names correct, as Outlook cannot cope with a certificate mismatch (certificate issued to foo.example.com, you have entered bar.example.com).

Simon.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

Tackle projects and never again get stuck behind a technical roadblock.
Join Now