Issues setting wallpaper with group policy

I have a Server 2003 domain and I'm trying to set a group policy to force a wallpaper.  I have a GPO and I assigned it to the OU's I want it to be enforced on.  It is a .bmp located in a UNC path.  The wallpaper will not always show up for the users it is supposed to.  It always show up in the preview window if you right click the desktop > properites and the policy shows as applied in rsop.msc.  I've tried every combination of active desktop on/off, only allowing bitmaps, etc and I just can't seem to get this to apply consistently.  The bmp is 4mb and I'm thinking that might be some of the issue.
pscharfAsked:
Who is Participating?
 
PeteJThomasConnect With a Mentor Commented:
I would say that is a little large for a background file! Have you tried simply opening the pic, resaving it as a .jpg (this will massively reduce it's size at the potential cost of quality), set it manually as a background to ensure quality is acceptable, then use that instead?

Anyway, we use a GPO to set a background as well, so thought I'd share exactly how we do it...

Basically we have a combination of a policy setting and a logon script (through the same GPO) to achieve it. The policy setting is 'Prevent Changing of Wallpaper' - Obvious enough.

Then what actually sets the background is a simple batch script containing the info in the attached txt file...

Anyway this method works perfectly for us (around 500 PCs/Laptops), the ONLY problem is that regardless of the 'prevent...' setting, there are work arounds that allow the users to change their background. This is a known issue, where if users right-click an image file and choose 'Set as desktop background' it still works ok...

HTH, any questions about the script itself, just ask...

Pete
Background.txt
0
 
speshalystCommented:
can you try with a different pic file ? just to check if the cause of the problem is this specific .bmp
 
0
 
pscharfAuthor Commented:
I've been able to get it to apply, but only under the following circumstances:

Enable Active Desktop - Enabled
Disable Active Desktop - Disabled
Active Desktop Wallpaper - \\server\share\file.bmp

From my understanding I shouldn't need to use Active Desktop for a bmp.  Also with active desktop on icon text is not transparent.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
PeteJThomasCommented:
To elaborate on the first line in the txt file, the command we use is in the following syntax:

\\<FULL domain name>\SYSVOL\<FULL domain name>\Policies\<policy folder>\User\Scripts\Logon\robocopy (the 'logon' folder contains an executable called robocopy, a free copy utility)

At this point there's a space, so continuing on:

...\robocopy \\<FULL domain name>\SYSVOL\<FULL domain name>\Policies\<policy folder>\User\Scripts\Logon\Background (there is a folder called 'Background' in the same place as the robocopy executable, and this folder simply contains the image file itself)

Another space, so:

...\Background "%userprofile%\local settings" /r:1 /w:1 /np /xf thumbs.db

The switches at the end are robocopy switches, (robocopy has an extensive list of switches) defined as follows:

/r:1 = number of retries on failed copies set to 1
/w:1 = seconds to wait between retries set to 1
/np = no progress (do not show % copied during copy)
and /xf thumbs.db = exclude file thumbs.db in the copy

I know that might look complicated but it's actually extremely simple and effective...
0
 
pscharfAuthor Commented:
Thanks for the script Pete.  I'm trying to avoid doing that because it seems to me that group policy should be able to handle this.  I've already pushed the bitmap to peoples local directories in preparation for not being able to fix GP.

So just to clarify there is no way to have a bitmap with active desktop disabled through group policy?
0
 
PeteJThomasCommented:
I've personally never seen it done without or script or with active desktop - Not saying it can't be done though, just that it's always been done with scripts in the companies I've worked for. Apparently they only 'true' way to lock it down so people can't change it is to use active desktop, but I'd rather settle for letting them be able to change it if they can figure out how... (and the script changes it back again at next log on anyway).

So I've been looking and found this - "In gpedit, the "Active Desktop Wallpaper" setting in User Configuration|Administrative Templates|Desktop|Active Desktop does set the background. Ignore the fact that it's in the Active Desktop section, as it still works with Active Desktop disabled. Active Desktop only needs to be enabled if using JPG or HTML for the background." (from http://www.experts-exchange.com/Operating_Systems/WinXP/Q_21392666.html)

Not sure if that's meant to be .bmp instead of .jpg though? As it would seem to suggest that you should be able to do it the way you want with a bmp?

Did you try using a smaller image by the way?
0
 
pscharfAuthor Commented:
I have tried with a smaller image.  The background will NOT show up unless active desktop is enabled, which for some god forsaken reason when done via GP also adds the funny background text to an icon.  Thank you very much for your help.
0
 
PeteJThomasCommented:
Sorry that didn't help much - If you still wanna keep trying, I would probably convert the image into various formats, and try each one. By the sounds of it you only need active desktop enabled if you're using certain image types, so maybe it's just a case of finding the right image type.

Either way, thanks for the points, and of course if you choose to use the script, any questions just ask.

Good luck,

Pete
0
 
ksiva83Commented:
Hi Pscharf,

As per ur reply...

  • pscharf:
  • I've been able to get it to apply, but only under the following circumstances:
  • Enable Active Desktop - Enabled
  • Disable Active Desktop - Disabled
  • Active Desktop Wallpaper - \\server\share\file.bmp
  • From my understanding I shouldn't need to use Active Desktop for a bmp.  Also with active desktop on icon text is not transparent.
Ill suggest here to change the GP settings for Disable Active Desktop.... It must be ENABLED which will certainly allow you to set .bmp file as background....

Hope this will help you with out any scripts...
0
 
ksiva83Commented:
Hi Pscharf,

As per ur reply...

  • pscharf:
  • I've been able to get it to apply, but only under the following circumstances:
  • Enable Active Desktop - Enabled
  • Disable Active Desktop - Disabled
  • Active Desktop Wallpaper - \\server\share\file.bmp
  • From my understanding I shouldn't need to use Active Desktop for a bmp.  Also with active desktop on icon text is not transparent.
Ill suggest here to change the GP settings for Disable Active Desktop.... It must be ENABLED which will certainly allow you to set .bmp file as background....

Hope this will help you with out any scripts...
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.