Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 250
  • Last Modified:

Using two network cards in XP

Hi - I've got a scenario of five XP Pro workgroup PCs one acting as a server. Broadband router acts as DHCP and DNS server.

We keep losing broadband and the ISP are still trying to resolve, but in the meantime I've added wifi  USB sticks (108Mbps) and cards (54Mbps) to the 5 PCs to piggyback onto nextdoor office's router.

Wifi is on 192.168.1.x  and struggles along at 1 to 2Mb speed but good enough for emails. Wired network is on 192.168.8.x In order to get the internet I have to disable the wired NIC and in order to get a good LAN speed I have to disable the wifi NIC.

How can I get them working well together?

Thanks
0
mikeabc27
Asked:
mikeabc27
  • 19
  • 11
  • 6
  • +2
1 Solution
 
gurutcCommented:
Hi,

In network connections at the top click Advanced Settings.  A window pops up where you can change the order in which your system uses the network connections, giving any adaptor you want the main priority.

Good Luck,
- gurutc
0
 
f-kingIT support technicianCommented:
What you can try is run the add new network wizard on all the computers and configure them with the new configuration ,use lan card to access network and WIFI for internet.
0
 
f-kingIT support technicianCommented:
The wifi speed depends on the signal strenth and how fast the host computers internet is.
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
mikeabc27Author Commented:
qurutc - I've already tried switching the metrics around from auto to 1 and 2, but no difference.
0
 
gurutcCommented:
I was thinking not the default gateway, but the primary interface, you know?

Hope I'm helping.

- gurutc
0
 
mikeabc27Author Commented:
f-king - where is add new network wizard?
0
 
mikeabc27Author Commented:
Sorry gurutc, I misread. How can I point NIC A when I wnat the LAN and NIC B when I want the Internet?
0
 
f-kingIT support technicianCommented:
It's in My Netwok Places (in control Panel or on the Start menu) ,on the left pane you will see an option to create a new network.
0
 
mikeabc27Author Commented:
You mean View Network Connections >  Create a new connection??
0
 
mikeabc27Author Commented:
f-king - tried that but no luck, still doesn't open web pages.
gurutc - current order was wifi then LAN card, but with both enabled web pages don't open.
0
 
gurutcCommented:
hmm, try swapping the order?

hmm

- gurutc
0
 
f-kingIT support technicianCommented:
Does WIFI have to use fixed ip? ,is the router next door configured that way?
Have you entered the WIFI password if it has one?
Try setting your routers DHCP and DNS setting to Auto and see what happens.
0
 
mikeabc27Author Commented:
I will try it, but I'm relaying the information and the lines are busy at the moment, but wouldn't  giving priority to the LAN card make an Internet connection less likely?
0
 
mikeabc27Author Commented:
OK, both cards on each machine uses DHCP and get their settings from the two broadband routers, one of which doesn't have any broadband at the moment.
Broadband on the wired router has been iffy for 15 months, hence, using the second one as back up. Both use the different routers as their gateway and DNS server. Would I be better off putting in fixed DNS server addresses in the wifi card settings like 2.2.2.2 and 4.4.4.4?
0
 
mikeabc27Author Commented:
f-king - both cards on all 5 PCs are set to auto, hence, my last post.
0
 
gurutcCommented:
You would definitely be better off using one of the root DNS servers.  If either router has an issue, then it  could kill your DNS resolution.  Better to get that part of things off the routers.

- gurutc
0
 
gurutcCommented:
And...

There's no reason not to try fixing your adaptor IP settings instead of using DHCP, you know?

Good Luck,
- gurutc
0
 
firemouseCommented:
Okay,

So the only real way you are going to get this to work is to use the WIFI connection for internet always, and the wired connection for LAN access always.  First thing you will need to do is make sure no default gateway is configured on the wired connection, only ONE NIC should have a default gateway, make it your wireless connection.  Pull up a command prompt and use the route command to add all LAN subnets that the wired connection will need access to.  IE: route add 192.168.X.X Mask 255.255.X.X 192.168.8.1(this is the wired router gatway) -p (-p makes it so the settings are saved afetr a reboot)

This will make it so the workstations will know to use the wired connection for the local subnets you added, and use the wireless connection for everything else.

This is the best setup your going to get I think, their is no real way to setup a failover strategy for your broadband connection through your workstations(IE have them using wired connection until ISP gives out, then switch to wireless).
0
 
gurutcCommented:
Hi,

You can also install server on the box 'acting as a server.'  Then you can use the built-in routing and remote access that's part of Windows Server to do a load-balance/fault-tolerant Internet connection over wired and wireless.  Have all the workstations go through the server for their Internet, which'll stay up as a function of the server doing the work finding the working net connection.

Good Luck,

- gurutc
0
 
mikeabc27Author Commented:
So the only real way you are going to get this to work is to use the WIFI connection for internet always, and the wired connection for LAN access always.  
Is there a setting for this?
First thing you will need to do is make sure no default gateway is configured on the wired connection, only ONE NIC should have a default gateway, make it your wireless connection.  
Yes I did think there could only be one gateway.
Pull up a command prompt and use the route command to add all LAN subnets that the wired connection will need access to.  IE: route add 192.168.X.X Mask 255.255.X.X 192.168.8.1(this is the wired router gatway) -p (-p makes it so the settings are saved afetr a reboot)
I'll set all cards (wifi and LAN) to fixed IPs.
Wifi settings on a PC - IP Address: 192.168.1.x, S/M : 255.255.255.0, d/g: 192.168.1.254 (wifi router IP), DNS servers: 2.2.2.2 and 4.4.4.4

LAN settings on a PC - IP Address: 192.168.8.x, S/M : 255.255.255.0, d/g: blank, DNS servers: 192.168.8.1 (LAN router IP)
Add the DOS command: ROUTE ADD 192.168.8.0 MASK 255.255.255.0 192.168.8.1 -P
Is this correct?

This will make it so the workstations will know to use the wired connection for the local subnets you added, and use the wireless connection for everything else.

This is the best setup your going to get I think, their is no real way to setup a failover strategy for your broadband connection through your workstations(IE have them using wired connection until ISP gives out, then switch to wireless).

Thanks for confirming. I would have preferred the wireless only came into play when the Internet on the wired failed, but if it can't work in a peer-to-peer network, then that's it.
0
 
f-kingIT support technicianCommented:
What could be causing the problem could be your router as wired nics think the internet is coming from there but since the ISP is trying to reslove it  replacing it with a switch could resolve it.
The Wireless would get the net from the wireless router.
0
 
mikeabc27Author Commented:
Yeah, I was thinking about putting the wired router to one side and just use a switch with fixed IPs, but my perfect scenario was getting a fast internet connection on the fixed and only use wifi for fallover, retaining the wired for LAN.
0
 
f-kingIT support technicianCommented:
Any luck on getting it to work?
0
 
mikeabc27Author Commented:
I somewhere else today and will out tomorrow. Thanks.
0
 
mikeabc27Author Commented:
I somewhere else today and will CHECK out tomorrow. I should read before clicking SUBMIT
0
 
mikeabc27Author Commented:
I'M somewhere else today and will CHECK out tomorrow. I should read fully before clicking SUBMIT
0
 
f-kingIT support technicianCommented:
Don't enter the spelling bee contest ok lol
0
 
mikeabc27Author Commented:
no way!
0
 
Ahmed ABDEL SALAMCloud Technical Solution ManagerCommented:

In the Network Connections folder, right click and Enable the connection that you want to use for web access. Right click and disable the one that you don't want to use.

If you need to use both connections at once (one for Internet, one for LAN for example ), assign a metric to each connection, giving a lower number to the one that you want to use for Internet access. To assign a metric to a network connection:

1. Open the Network Connections folder.
2. Right click the desired connection.
3. Click Properties | Internet Protocol (TCP/IP).
4. Click Properties | Advanced.
5. Un-check "Automatic metric".
6. Enter a number between 1 and 9999 for the "Interface metric".

0
 
mikeabc27Author Commented:
We have been doing enabling/disabling cards whether on internet or LAN but this is quite cumbersome.
Tried the metric with Wifi on 1 and LAN on 2, and the other way around but this didn't work.
It appears that with both cards enabled LAN works ok, but LAN card needs to be disabled to use wifi.
0
 
f-kingIT support technicianCommented:
0
 
mikeabc27Author Commented:
When a dead gateway is detected by TCP, it can direct IP to switch default gateways to the next gateway in the backup list. (from the MS attachment frm f-king)
This looks about right -I'll check it out to see if it works tomorrow afternoon. Thanks
0
 
mikeabc27Author Commented:
Hi, I thought this was the answer, but I see Enable Dead Gateway Detection is set to on by default.
The Internet on the wired connection has been stable for several days now and when it is working it is much faster than the wifi, so we would prefer the wired Internet connection by default and only have the wifi come into play when the wired gateway dies. So I do need to have the two gateways.
Current gateway metric settings on NIC cards is LAN = 1, Wifi =2
Card Priority - LAN, Wifi, Remote Access connections.
I'm sure the wired broadband connection will be fixed eventually, but I'm not going to hold my breath in the meantime.
0
 
f-kingIT support technicianCommented:
Try Enable Dead Gateway to off  ,Apply and then to on again ,maybe it will reset it.
0
 
f-kingIT support technicianCommented:
Have you tried making a network bridge in Windows?
one for wireless network and one for wired.
0
 
mikeabc27Author Commented:
Hi f-king. I had to give up on this as I couldn't get it working properly. I had to compromise with either wired - both cards enabled. It the Internet goes on the wired disable the wired NIC.
Not what I was looking for, but it works.
0
 
mikeabc27Author Commented:
Many thanks for your ideas, esp. f-king
0
 
f-kingIT support technicianCommented:
One of those times when we couldnt help :(
you can't win them all.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

  • 19
  • 11
  • 6
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now