Solved

Google Toolbar causing "Security Warning" on HTTPS pages

Posted on 2009-05-18
7
529 Views
Last Modified: 2012-08-14
I installed Google Toolbar on Internet Explorer 8 (although I've seen the problem with other IE versions). (I also enabled PageRank, but it might happen without it).

Now when I go to one of my web pages that is secure, I get a security warning.because the Google Toolbar is trying to access a page on Google's servers using HTTP instead of HTTPS. Has anyone else experienced this or know of way to fix it?
0
Comment
Question by:gr8gonzo
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
7 Comments
 
LVL 11

Expert Comment

by:g000se
ID: 24412878
Hello,

What happens if you temporarily disable the Google toolbar when you are accessing your secure webpages?  Does it work then?

How about trying Google Chrome?
0
 
LVL 35

Author Comment

by:gr8gonzo
ID: 24412917
I've narrowed it down to a DHTML menu Javascript library. The HTTPS page loads fine, but once I mouseover the menu and something drops down, an HTTP call goes out to the IP 69.192.12.20 for /js/200/addthis_widget.js.

I've searched the code and I don't see any reference of "addthis" and it doesn't seem to happen if you don't have Google Toolbar installed.
0
 
LVL 11

Expert Comment

by:g000se
ID: 24412982
Strange.  Also, I assume you cleared the temporary internet files too and tried to adjust the security settings.
0
SharePoint Admin?

Enable Your Employees To Focus On The Core With Intuitive Onscreen Guidance That is With You At The Moment of Need.

 
LVL 11

Expert Comment

by:g000se
ID: 24413005
Check out this link- http://www.google.com/toolbar/ie8/
0
 
LVL 35

Author Comment

by:gr8gonzo
ID: 24413233
Yup - I've tried clearing the cache and it's already on IE8. Chrome isn't an option, really.
0
 
LVL 11

Expert Comment

by:g000se
ID: 24413409
Try uninstalling IE 8 and download it with Google toolbar from the link (http://www.google.com/toolbar/ie8/)  that I sent you and see if that works.
0
 
LVL 35

Accepted Solution

by:
gr8gonzo earned 0 total points
ID: 24790774
This turned out to be that there was a hidden iframe that was being filled with a page that contained a link to the insecure content. Fixing that issue solved the problem. I still don't know why Google toolbar changed the behavior, but whatever.
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

When the s#!t hits the fan, you don’t have time to look up who’s on call, draft emails, call collaborators, or send text messages. An instant chat window is definitely the way to go, especially one like HipChat. HipChat is a true business app. An…
When it comes to security, close monitoring is a must. According to WhiteHat Security annual report, a substantial number of all web applications are vulnerable always. Monitis offers a new product - fully-featured Website security monitoring and pr…
The viewer will learn how to count occurrences of each item in an array.
This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.

617 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question