3CSFP91 and 48 port 3Com 4200G not working

We have 2 brand new switches that we are trying to replace 2 old switches with.

We have 2 3CSFP91's that were operational in the original switches, but we cannot get them to function in the new 4200 switches.  

The 3CSFP91's functioned just fine with the old switches and the fiber run between them.  We are using the original fiber run.

If we put the original switches back into place with the 3CSFP91's, everything works.

Any ideas on how to get them to function with the new 4200G's?    I have already gone in and enabled the ports and set the speed and duplex manually, and that has not helped.

Any assistance is greatly appreciated.
Who is Participating?
from_expConnect With a Mentor Commented:
can you check reaction on SFP insertion?
and on copper cable being plugged in? and then connecting fiber line.

Possibly switch will log some information about pluggables being inserted.

So my point of view right now - you should understand if the SFP is visible by device or not.
those switches have combo ports, so you should not populate corresponding copper ports. is that true in your situation?
according to 3com's product support list, 4200G supports 3CSFP91
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

rclevlndAuthor Commented:
No, no copper plugged into the combo ports.

rclevlndAuthor Commented:
The coper ports are disabled at the moment.  Only the one SFP slot is enabled, and it does show the module being inserted and seen as a Gigabit 1000-BaseSX port module (that may not be exactly what it says) and it knows when the module is removed.

Yet there are no lights no the switch to indicate proper operation, even after connected to the fiber.

I have seen on other sites that the Fiber port indicators will not come on until a link is detected on some models.

The old switch lights up even without fiber connected to the module.

the light should come up upon sfp receiving RX flow.
as for disabling ports - I would suggest enabling ports 21-24 because in most cases combo ports are presented as single port within a switch within difference whether it is copper or fiber.

take a look here:
page 121
rclevlndAuthor Commented:
You can't enable them if the corrisponding fiber port is enabled.  The switch will automatically set them to disabled.  If you go in and Enable the coper ports, it automatically disables the fiber ports.

The lights on this model will not turn on until a fiber link is detected.

It turned out to be a bad patch cable.  Something with the old cable worked when plugged into the older switches (higher on the rack) and not work when plugged into the new switch (lower on the rack).  After flexing the cable a little while plugged into the new switch, the light would come on, then go off after you let go of the cable.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.