Exchange IMF not filtering all mailboxes

Hello to all,

I am having a strange problem. I have IMF enabled on our exchange server and it appears to be working correctly on most mailboxes... I do however have one mailbox (publically available email address so gets lots of spam) that is not getting filtered at all. There is absolutely no messages being moved into the Junk Email folder.

I've installed IMF Tune and set it to report the SCL in the message header. This again is being applied for the mailboxes that are being filtered but not the problem box.

I have trend micro worry free business suite installed but have it set to use the junk email integration setting (exchange is responsible for moving the messages to the junk folder and not the trend suite - I have spoken to support personnel at trend to confirm this).

This is quite a problem as we are getting substantial spam not filtered in the box.

any help?
robert_shipleyAsked:
Who is Participating?
 
robert_shipleyAuthor Commented:
Ok Fixed it myself...

I would appear that you need to enable spam filtering on each individual mail box. This is a very hidden setting but can be accessed via Outlook Web Access...

This page describes the method briliantly: http://www.windeveloper.com/imftune/faqs/p03_howto3.htm

Thanks for the help sent from Rajith but no points this time I'm afraid!!
0
 
Rajith EnchiparambilOffice 365 & Exchange ArchitectCommented:
Have you enabled IMF in the smtp virtual server properties? Otherwise, it will not work though it will show the settings.
0
 
robert_shipleyAuthor Commented:
Rajith,

I've enabled it in the delivery options and in the smtp virtual server. As mentioned it's working on several mailboxes but not on the main contact box. I followed the several guides available for setting up IMF on the web... even Microsoft's own lol.

Regards
Rob
0
Ultimate Tool Kit for Technology Solution Provider

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy now.

 
robert_shipleyAuthor Commented:
Slight update...

I've just noticed that the SCL level is being set in the message headers. The ratings I am getting in the inbox are higher than the settings in the IMF console on the server so the message should be moved into the Junk email folder but it's not!
0
 
Rajith EnchiparambilOffice 365 & Exchange ArchitectCommented:
Configure the IMF properly, just enabling it won't do much.

Read http://www.petri.co.il/block_spam_with_exchange_2003_imf.htm

Enable smtp tarpitting http://enchiparambil.com/smtp_tarpitting_for_exchange.aspx

Enable the sender testing as well (can't remember the actual setting). I think it is in sender filtering.
0
 
robert_shipleyAuthor Commented:
Rajith,

I've already read the petri article. It was one of the guides I mentioned that I've followed. I've configured IMF to update via windows update and it has updated recently to the most recent update.

I have this working on several mailboxes so it's configured correctly there just not on our contact email box for some reason.

Rob
0
 
Rajith EnchiparambilOffice 365 & Exchange ArchitectCommented:
"""there just not on our contact email box for some reason."""

Please explain
0
 
robert_shipleyAuthor Commented:
Sorry slight spelling/mis typing.

The spam filtering is working on most mailboxes except for our contact@xxx.com mailbox.
0
 
Rajith EnchiparambilOffice 365 & Exchange ArchitectCommented:
Contact@domain.com will be one of the email addresses that spammers target. So, if you get too many spam emails for this account, that means that IMF OPTIONS are not fully configured to defend spam.

You need to Enable smtp tarpitting as said earlier. That will reduce the spam. http://enchiparambil.com/smtp_tarpitting_for_exchange.aspx

Do you have any other antispam solutions?
0
 
robert_shipleyAuthor Commented:
It's not that there is too many emails not being filtered... it's that the box is not being filtered AT ALL. Not a single email is being moved to the junk email folder. The SCL rating in the headers is higher than the configured level, so should therefore be moved. All emails however are being delivered to the inbox. Not a single email has been moved.

If IMF was working correctly it would remove almost all of our spam from the box and would be an adiquate solution. I appreciate that the tarpitting may help but it's not going to solve the fact that no emails are being moved. I did a test and set the SCL threshold level at the server end to 1 for a short period and everything was still being delivered to the inbox.
0
 
Rajith EnchiparambilOffice 365 & Exchange ArchitectCommented:
Having a value 1 means that "it is not at all a spam" . It's the values from 9,8,7 that needs to be set, with 9 saying it is 99.9% spam
0
 
robert_shipleyAuthor Commented:
Rajith,

I think you have that the wrong way around. http://www.exchangeinbox.com/article.aspx?i=12

It's says on the interface "Move messages with an SCL Rating greater than..."

The SCL's being calculated on the messages are higher than the set value but they are not being moved.
0
 
robert_shipleyAuthor Commented:
Hi all,

Doubled the points on this as it's gone flat with no response.

Thanks
Rob
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.