Solved

Run VMware Tools on OpenSuse 10.3 as system service

Posted on 2009-05-18
15
1,150 Views
Last Modified: 2013-12-05
I have VMware Tools for Linux v3.5.0 installed on an OpenSuSE 10.3 VM. The tools will run if I login as a user and run the following:

vmware-toolbox  &

However when I log out, the tools shutdown. How go I get VMware Tools to run when no user is logged in, or start automatically such as when restarting the Linux server? I've tried various things in the past, but nothing has stuck so far.
0
Comment
Question by:jessc7
  • 9
  • 6
15 Comments
 
LVL 19

Expert Comment

by:vmwarun - Arun
ID: 24414474
Check what daemon is started when you run the command vmware-toolbox & and try to add that service into chkconfig
0
 
LVL 16

Author Comment

by:jessc7
ID: 24414543
Can you walk me through that a little more? Even a link to a good article would be helpful. Thanks!
0
 
LVL 19

Expert Comment

by:vmwarun - Arun
ID: 24414632
Personally I have updated the idea after scratching my brain :)

After executing vmware-toolbox &, run top inside the Virtual machine.

This would show you a list of running daemons or services inside linux.

Run the command ps -aef | grep vmware-toolbox

This would show the associated daemon which you can add to chkconfig and make it autorun everytime Linux VM starts.

I hope this works.
0
Portable, direct connect server access

The ATEN CV211 connects a laptop directly to any server allowing you instant access to perform data maintenance and local operations, for quick troubleshooting, updating, service and repair.

 
LVL 16

Author Comment

by:jessc7
ID: 24415009
When I ran the ps command, I received the following...

root      7659  7624  0 14:27 pts/1    00:00:18 /usr/lib/vmware-tools/bin32/vmware-toolbox-gtk

But looking into chkconfig a little more, I noticed I already had an entry for vmware-tools:

vmware-tools              0:off  1:off  2:on   3:on   4:off  5:on   6:off

I wonder why it is not already running automatically?
0
 
LVL 16

Author Comment

by:jessc7
ID: 24415193
Bumped points since this seems to not be as straightforward as I originally thought.
0
 
LVL 19

Expert Comment

by:vmwarun - Arun
ID: 24415196
What init level does you linux vm start by default ?

This can be checked in the /etc/inittab file by running the command cat /etc/inittab.
0
 
LVL 16

Author Comment

by:jessc7
ID: 24415219
Looks like 5:

id:5:initdefault:
0
 
LVL 19

Expert Comment

by:vmwarun - Arun
ID: 24415297
Try changing the init level to 3 and check whether vmware-tools is starting automatically just for verification sake.
0
 
LVL 16

Author Comment

by:jessc7
ID: 24415359
Ok, restarted with init level 3 as default. At the login screen, I see several of the startup event logs. One of them says:

Failed services in runlevel 3:    vmware-tools
No other services are listed as failed.
0
 
LVL 19

Expert Comment

by:vmwarun - Arun
ID: 24415498
Did you use root credentials to install vmware-tools ?
0
 
LVL 16

Author Comment

by:jessc7
ID: 24415602
Yes. Just to verify (cause it's been since January), when I checked the permissions on files within /user/lib/vmware-tools/, the permissions are assigned to root root.
0
 
LVL 19

Accepted Solution

by:
vmwarun - Arun earned 500 total points
ID: 24415667
This particular VMware KB Article talks about Prevent VMware Tools from starting automatically in a Linux guest - http://kb.vmware.com/selfservice/viewContent.do?externalId=1005715&sliceId=1

Check this out and update the results.

By the way on what VMware Platform are you running this ?

I am assuming that this is an ESX Host v3.5.0
0
 
LVL 16

Author Comment

by:jessc7
ID: 24415709
We are running ESX 3.5 U3. I am not the official VMware admin on the team, but I manage several VMs.

I'll try the KB - thanks!
0
 
LVL 16

Author Comment

by:jessc7
ID: 24415829
Fixed!

After reading the KB, I ran /etc/init.d/vmware-tools status, which returned that vmware-guestd was not running (obviously).

I ran /etc/init.d/vmware-tools start, and received the following:

VMware Tools is installed, but it has not been
(correctly) configured for the running kernel.
To (re-)configure it, invoke the following command:
/usr/bin/vmware-config-tools.pl
I'm fairly certain the Linux kernel was updated in the last couple of months, so that was probably the root of the issue. I ran through configuration again, restarted in run level 5 to verify, and the VMware client is showing the VMware Tools as running. Excellent - thanks arunraju! Your troubleshooting got me there...
0
 
LVL 16

Author Closing Comment

by:jessc7
ID: 31582680
Thanks for your help!
0

Featured Post

PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Will try to explain how to use the VMware feature TAGs in the VMs and create Veeam Backup Jobs using TAGs. Since this article is too long, I will create second article for the Veeam tasks.
Giving access to ESXi shell console is always an issue for IT departments to other Teams, or Projects. We need to find a way so that teams can use ESXTOP for their POCs, or tests without giving them the access to ESXi host shell console with a root …
Teach the user how to install vSphere Update Manager  Console to Windows system:  Install vSphere Update Manager: Configure vSphere Update Manager plug-in in vSphere Client: Verify vSphere Update Manager settings in vSphere Client:
This Micro Tutorial steps you through the configuration steps to configure your ESXi host Management Network settings and test the management network, ensure the host is recognized by the DNS Server, configure a new password, and the troubleshooting…

839 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question