• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 812
  • Last Modified:

Exchange 2007 - Active SyncDeviceID's.

Hello - I am testing device restrictions for ActiveSync and have sucessfully setup device restrictions so well that no none of my phones or ipods will sync with my Ex2k7 server.

This is the device id that is listed under allowed device ids:

ActiveSyncAllowedDeviceIDs            : {XXXXXXXXE36B2B14131CD0SSSSSSSSSS}

The windows event vwr is giving this error message:

A blocked device of user [contoso\user], device id = [XXXXXXXXE36B2B14131CD0SSSSSSSSSS],  is attempting to synchronize with Exchange ActiveSync.

I clearly managed to get this to lock down my account so well that i cannot sync at all, how do i remove this device restriction? I tried removeing the Partner ship and it still lists my device as restriced.

This is the erro that i am getting on the phone:

Your account in Microsoft Exchange does not have permission to sync with your current settings. Error Code 0x85010004.

Please Advise... Thanks,
Robert

0
castellansolutions
Asked:
castellansolutions
  • 5
1 Solution
 
ChristophermageeCommented:
Sounds like it is a bug

http://www.pro-exchange.eu/modules.php?name=News&file=article&sid=120

Apparantly there is a hotfix available but you need to contact MS.
0
 
castellansolutionsAuthor Commented:
i was successfully able to sync the administrators account with the device, so i know that both the device work and the server itselef (Autodiscover) is setup correctly.

0
 
CuteadderCommented:
run this in exchange command shell (obviously make a few changes...)

Set-CASMailbox -Identity <SMTP Address of user> -ActiveSyncEnabled $true
0
What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

 
castellansolutionsAuthor Commented:
i cjecked and my device is set to active enabled - now i am getting this error:

Microsoft ActiveSync. Your device will be re-synchronized at the next sync. Support Code: 80883002

0
 
castellansolutionsAuthor Commented:
I still have this device id listed as the only device that will sync with my account:

 [XXXXXXXXE36B2B14131CD0SSSSSSSSSS],  

I need to remove that restrictin somehow...
activesyncissues.JPG
0
 
castellansolutionsAuthor Commented:
Cuteadder... It looks like that is only for Exchange 2003- but i will keep that link in mind for the future!


0
 
castellansolutionsAuthor Commented:
Here is what i think happened: I made some new ActiveSync Policies that i thnk wxchange wasnt happy with. I could not sync any device to any account.

Once i removed those policies then i was able to sync to the administrators account, but i still couldnt sync to my account. So i posted on EE.

Then i figured that since i could access the WINSVR2\MicrosoftActiveSync whatever directory and login and not get rejected - i guessed correctly so that the issue is with the device.

I just wiped my device (which really does mean remove all data) and was able to resnc my account (finally).

Thanks for all your help... But i still do not know how to how to remove the restriction on active sync devices? After you set one?

Robert
0

Featured Post

Concerto's Cloud Advisory Services

Want to avoid the missteps to gaining all the benefits of the cloud? Learn more about the different assessment options from our Cloud Advisory team.

  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now