Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

DataWindow.ReselectRow() causes crash with error message of pbdwe115.dll

Posted on 2009-05-18
5
Medium Priority
?
1,984 Views
Last Modified: 2013-12-26
Hi,

I'm currently experiencing some problem on one of my application.  It keep crashing when it tried to execute: reselectrow(x) where x is long (see the attached sample of code).  In the error window (see attached), it complains about pbdwe115.dll.  

Efforts tried and failed:
1.  Check the existence of pbdwe115.dll in deployed folder.  DLL exists.
2.  I've deployed every DLLs that PowerBuilder has in deployed folder to eliminate the possibilities of missing DLLs, and problem still exists.

The application is accessing Oracle 10g, it does not run any .NET applications, and it is a Windows application (and not a Web application).

I'm just wondering if anyone can advise me the workaround from using reselectrow method, probably it might solve the problem.

Thanks for your help
long l_row, &
     i = 1, &
	  j, &
	  l_row_array[]
 
...
...
 
do while l_row > 0 
 
	if dw_result.reselectrow(l_row) = -1 then 		
 
		l_row = dw_result.getselectedrow (l_row)
		continue
	end if
...
...

Open in new window

Problem2.JPG
0
Comment
Question by:jjoz
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
5 Comments
 
LVL 18

Assisted Solution

by:diasroshan
diasroshan earned 80 total points
ID: 24419111
Hi,

will dw_result.Retrieve() help instead of doing a reselectrow in a loop

If u can mention what ur trying to achieve in the above code,cud help in providing a work around.

Cheers,
Rosh
0
 
LVL 1

Author Comment

by:jjoz
ID: 24419171
Hi,

Thanks for the response.  What the code tried to achieve is that it want to refresh the grid everytime user clicked any individual row to see further details.

This morning, I've did the walkaround by including direct embedded SQL call.  it did the trick well.

Until now, I couldn''t reconcile on why reselectrow causes pdwe115.dll error.

Anyway, thanks for the help.

Rgrds,
jioz
0
 
LVL 14

Assisted Solution

by:sandeep_patel
sandeep_patel earned 160 total points
ID: 24422770
for testing can you write reselectrow out of loop for any single row and see if that works?

e.g. reselectrow(4)

I am guessing something wrong in a loop.

Regards,
Sandeep
0
 
LVL 1

Accepted Solution

by:
jjoz earned 0 total points
ID: 24427562
Hi Sandeep,

Thanks for the suggestion.  

I've tried it and it fails even when I use reselectrow(1).  According to Sybooks, reselectrow should return -1 if it unable to refresh single row.  It doesn't even return me anything ..... it just crashed before able to return me with any return value.

Rgrds,
jioz

0
 
LVL 14

Assisted Solution

by:sandeep_patel
sandeep_patel earned 160 total points
ID: 24428211
Couldn't find if something related to that reported anywhere. The only option I think is check the latest build of 11.5 available on sybase.com.

create another sample datawindow with one or two column from other table and see if problem still exist. Not sure if any column datatype or record is creating a problem

0

Featured Post

On Demand Webinar - Networking for the Cloud Era

This webinar discusses:
-Common barriers companies experience when moving to the cloud
-How SD-WAN changes the way we look at networks
-Best practices customers should employ moving forward with cloud migration
-What happens behind the scenes of SteelConnect’s one-click button

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Programmer's Notepad is, one of the best free text editing tools available, simply because the developers appear to have second-guessed every weird problem or issue a programmer is likely to run into. One of these problems is selecting and deleti…
How to install Selenium IDE and loops for quick automated testing. Get Selenium IDE from http://seleniumhq.org Go to that link and select download selenium in the right hand column That will then direct you to their download page. From that p…
This tutorial covers a step-by-step guide to install VisualVM launcher in eclipse.
The viewer will learn how to use NetBeans IDE 8.0 for Windows to connect to a MySQL database. Open Services Panel: Create a new connection using New Connection Wizard: Create a test database called eetutorial: Create a new test tabel called ee…

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question