Solved

Host an SqlServer 2005 Database on WIndows XP

Posted on 2009-05-18
10
197 Views
Last Modified: 2012-08-13
Hello,  I have a little program i wrote which connects to a sql databse.  Until now I have just been using localhost in the command line.  I want to try and get it working so I can run my program from another computer (not on the same network).  

Is it possible to do this, if the machine hosting the sql database is Vista Professional?

If it is possible, I must be doing something wron becuase its not working.  
I am using the followin connection string:
connectionString="Data Source=123.123.123.123,1433\SQLEXPRESS;Initial Catalog=myDB;Integrated Security=True"

I have performed the steps listed here: http://support.microsoft.com/kb/914277
0
Comment
Question by:BobBarker_99
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 2
10 Comments
 
LVL 31

Expert Comment

by:RiteshShah
ID: 24418314
port #1433 is default port and dont' need to specify it in connection string
0
 
LVL 31

Expert Comment

by:RiteshShah
ID: 24418320
moreover, are you able to connect your SQL Express from other computer out of your network? I am sure it is not configured correctly....
0
 
LVL 31

Accepted Solution

by:
RiteshShah earned 200 total points
ID: 24418330
moreover, can you please try using sql authentication as your aspnet account may not be authenticated in your sql server. have a look at my article at

http://www.sqlhub.com/2009/04/error-fixed-cannot-open-database-dbname.html
0
U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

 
LVL 41

Assisted Solution

by:ralmada
ralmada earned 300 total points
ID: 24418355


I think you will have to use SQL Authentication, not Windows Authentication. So you will have to replace the "Integrated Security=True" with an SQL user ID and password. Also replace the Datasource with the IP Address and port #
Something like this:

"Data Source=xxx.xxx.xxx.xxx,1433;Initial Catalog=myDatabaseName;User ID=myUsername;Password=myPassword"
0
 
LVL 31

Expert Comment

by:RiteshShah
ID: 24418368
yes, that is what I mentioned in my previous post either go for sql authentication or if it is possible make your ASPNET account trusted (create login) in your SQL express.
0
 
LVL 41

Expert Comment

by:ralmada
ID: 24418373
I know Ritheshsa, I just wanted to explain how to change the connection string since you didn't explained that. :)
0
 

Author Comment

by:BobBarker_99
ID: 24428667
Ok, I have modified my connection string, and enabled sql login.  

When I use:
Data Source=\LOCALHOST;Initial Catalog=TutoringDB;User ID=myid;Password=mypass it works.

But
Data Source=xxx.xxx.xxx.xxx;Initial Catalog=TutoringDB;User ID=myid;Password=mypass
gives me teh following exception:

"An error has occurred while establishing a connection to the server.  When connecting to SQL Server 2005, this failure may be caused by the fact that under the default settings SQL Server does not allow remote connections. (provider: Named Pipes Provider, error: 40 - Could not open a connection to SQL Server)"

Any ideas?
0
 

Author Comment

by:BobBarker_99
ID: 24428741
I tried using tcp instead and got

Network=DBMSSOCN;Data Source=xxx.xxx.xxx.xxx;Initial Catalog=TutoringDB;User ID=myid;Password=mypass

(provider: TCP Provider, error: 0 - No connection could be made because the target machine actively refused it.)"

0
 
LVL 41

Expert Comment

by:ralmada
ID: 24431706
Maybe there's a firewall blocking any connection to port 1433.
Also make sure SQL Browser agent is enabled
0
 
LVL 41

Assisted Solution

by:ralmada
ralmada earned 300 total points
ID: 24434551
0

Featured Post

U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Nowadays, some of developer are too much worried about data. Who is using data, who is updating it etc. etc. Because, data is more costlier in term of money and information. So security of data is focusing concern in days. Lets' understand the Au…
When you hear the word proxy, you may become apprehensive. This article will help you to understand Proxy and when it is useful. Let's talk Proxy for SQL Server. (Not in terms of Internet access.) Typically, you'll run into this type of problem w…
This videos aims to give the viewer a basic demonstration of how a user can query current session information by using the SYS_CONTEXT function
Viewers will learn how to use the INSERT statement to insert data into their tables. It will also introduce the NULL statement, to show them what happens when no value is giving for any given column.

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question