Go Premium for a chance to win a PS4. Enter to Win

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1162
  • Last Modified:

the connection to microsoft exchange is unavailable. outlook must be online to complete this action

Working on an Exchange 2003 setup that was previously only available locally, and making it available externally from the network.

OWA works fine both locally and externally.  Outlook connects fine locally, but I'm unable to connect to the Exchange server externally with my Outlook client.

When I try to signin, I get the following message.

**********
the connection to microsoft exchange is unavailable. outlook must be online to complete this action
**********
0
sanderrob
Asked:
sanderrob
  • 4
  • 3
1 Solution
 
ikshf143Commented:
I believe we are trying to setup RPC over HTTP for Outlook. That would require few modifications on the server, they are as follows
1. Installing the RPC component from Control Panel-->Add remove windows components-->Networking Services-->RPC over HTTP proxy.
2. The authentication on the RPC vdir should be basic.
3. Having Certificate on the Server and make sure that we do not get any certificate error while trying to access OWA from the Client we are trying to configure Outlook.
4. Outlook profile should be enabled for HTTP from account setting-->More Setting-->Connection
   The URL would be the same as on the certificate and make sure you enable on Fast and Slow netoworks. and also the authentication would be basic

Imran
0
 
sanderrobAuthor Commented:
Exchange is currently running in the IIS folder MACHINE > Web Sites > Default Website > Exchange directory.

RPC looks like it's already been configured on the Exchange directory, but not the Default Website Directory.  Do I need to configure it on the Default Website directory as well?
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

 
ikshf143Commented:
Exchange directory is only for OWA and not for RPC over HTTP. For RPC over HTTP we have a different Directory named RPC under the Default Web Site. That is the directory which gets created when you install the RPC component from Control Panel. See if you have any directory named RPC under the Default Web Site, if no then you will have to install this component and follow the steps in the previous post
0
 
sanderrobAuthor Commented:
I see two directories like this.

1 - Rpc
2 - RpcWithCert

My understanding, is that I only have to modify the RpcWithCert directory, and not the Rpc one.  I have Basic Authentication enabled within this directory.
0
 
ikshf143Commented:
You have to modify the RPC directory and not RpcWithCert
0
 
sanderrobAuthor Commented:
I modified the RPC directory, but that has not made any improvement.
0
 
sanderrobAuthor Commented:
Finally realized that this was a Small Business Server, so the Outlook Client configuration needed to be modified slightly.
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now