Solved

SMTP Problem with IIS7, FPSE 2002 and Server 2008

Posted on 2009-05-19
7
398 Views
Last Modified: 2013-12-24
Hello all,

We host numerous school district websites and recently moved a site to a 2008 server running IIS7 and FrontPage server extensions 2002.  The district tech reported an error with a form which was: This form is being created on a Disk-Based web or the FrontPage Server Extensions have not been configured to send email.  
I opened up IIS and went to the Administration portion of this particular website.  I am able to put in the SMTP info, but when I click "Submit" nothing happens.  
I have administrative access to the server, so it would not seem like a permissions issue.  Can anyone point me in the right direction?  Server 2008 is new territory for me.

Thanks,
Melinda
0
Comment
Question by:Melinda-D
  • 3
  • 3
7 Comments
 
LVL 31

Expert Comment

by:James Murrell
ID: 24429215
sorry to ask silly question but is smtp server running on same box?
0
 

Author Comment

by:Melinda-D
ID: 24429784
Yes.  I needed to add it as a role, but after doing so I see it running as a service.
0
 
LVL 22

Expert Comment

by:cj_1969
ID: 24432033
Check out this MS page, it has all the steps for configuring FPSE for sending emails from forms ... http://support.microsoft.com/kb/305675
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:Melinda-D
ID: 24435732
I have seen that link before.  It does not address IIS7.  Thanks, though!
0
 
LVL 22

Assisted Solution

by:cj_1969
cj_1969 earned 20 total points
ID: 24435782
Have you checked the account that the Application pool is using?
Although this is a form submission, to send email and interface with server extension, code is going to have to run.  Try changing the logon ID of the app pool that the site is using to Local Service and see if this resolves the problem.
0
 

Accepted Solution

by:
Melinda-D earned 0 total points
ID: 24451536
The account the Application Pool is using is Administrator.  

I finally tried accessing the Administration page by getting off the server completely, and doing it through the website.  I was actually able to add the SMTP settings there!  I have no idea why this would be, but I'll take it.

Thanks for your input!
0
 
LVL 22

Expert Comment

by:cj_1969
ID: 24451575
I'm glad you got it working.
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

If you don't have the right permissions set for your WordPress location in IIS, you won't be able to perform automatic updates. Here's how to fix the problem.
Preparing an email is something we should all take special care with – especially when the email is for somebody you may not know very well. The pressures of everyday working life stacked with a hectic office environment can make this a real challen…
The purpose of this video is to demonstrate how to Import and export files in WordPress. This will be demonstrated using a Windows 8 PC. Go to your WordPress login page. This will look like the following: mywebsite.com/wp-login.php : Click on Too…
The purpose of this video is to demonstrate how to set up basic WordPress SEO. This will be demonstrated using a Windows 8 PC. The plugin used will be WordPress SEO by Yoast. Go to your WordPress login page. This will look like the following: myw…

860 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question