starting gnome in cygwin

I used
1) ssh -x root@centosserver
2) entered password
3) typed: gnome-session &

The return was Gtk-WARNING **: cannot open display.
rtod2Asked:
Who is Participating?
 
ai_ja_naiConnect With a Mentor Commented:
use -X option, not -x
All UNIX like systems are case sensitive
0
 
rtod2Author Commented:
same error
0
 
ai_ja_naiCommented:
I suppose that root can normally launch a X session on your machine, right?
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

 
rtod2Author Commented:
yes
0
 
ai_ja_naiCommented:
before issuing gnome-session, type

setenv DISPLAY youripaddress:0.0
0
 
ai_ja_naiCommented:
(can you also post the contents of /etc/ssh/sshd_config?)
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.