• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 739
  • Last Modified:

List of Values not Showing up (Crystal 2008)-BOE XI 3.1

I am using Crystal 2008. I created a parameter 'X' and it uses a Prompt Group(PG_1) built in Business View Manager. And the Data Connection's(DC_1) property 'Runtime Prompt Mode' is set to 'Always Prompt'.

Now when I run my report runs in the Crystal Reports 2008, it never asks me for the database user credentials for DC_1. And it asks me for database credentials when I try to schedule the report by giving the parameter values from the INFOVIEW. After enting the database details, it gives me the List of values.

Now that I didn't want to be asked for the credentials everytime, I set the Data Connection's(DC_1) property 'Runtime Prompt Mode' is set to 'Never Prompt'. After I do this, whenever I run the report it doesn't ask me for the database details, which is good. But the issue is now after the property change it does not show the list of values in only in INFOVIEW when prompted. It only shows a text box against the prompt just to enter the value.

Is there any way to show the LOVs after the change in the property for 'Runtime Prompt Mode' to 'Never Prompt'?

Thanks in Advance.
0
nani11
Asked:
nani11
  • 4
  • 3
1 Solution
 
vetaldjCommented:
Did you specify user name and passwor in DC as well?
0
 
nani11Author Commented:
Now it has blankin the Username and Password Properties for Data Connection
0
 
vetaldjCommented:
In order to get LOV without prompt you need to specify both user and password.
0
Cloud Class® Course: CompTIA Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

 
vetaldjCommented:
Sorry, press enter before type all answer...

I had same issue before and in order to get LOV without prompt you need to enter user name and password to appropriate boxes in DC and specify Never Prompt, what you already did.
0
 
nani11Author Commented:
What is "press enter before type all answer..."? ..Could you please explain in detail?
0
 
vetaldjCommented:
It not  related to your question... sorry for confusion...

first line "Sorry, press enter before type all answer..." it was excuse that my previous answer was not in full because I press "Submit" before I typed it.
0
 
nani11Author Commented:
Thanks a lot..That worked...Cheers..
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 4
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now