?
Solved

restoring mailbox from Recovery group - Active Directory account is already deleted

Posted on 2009-05-19
6
Medium Priority
?
487 Views
Last Modified: 2012-05-07
How can I restore a mailbox from the Recovery Group when the AD account has already been deleted?  I have Ex-Merge installed and I connect to the recovery DB, however, the user doesn't appear at first, then, when I browse the active info store group and then go back to the recovery group the user appears, however, it fails when trying to export his mail to a .pst.  I also get a general stating:

An error was encountered with one or more users when retrieving the list of mailboxes...
0
Comment
Question by:gopher_49
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
6 Comments
 

Author Comment

by:gopher_49
ID: 24427278
Also,

Below is the error I'm getting that pertains to this mailbox...

[17:06:54] Error! Cannot identify the user with the msExchMailboxGuid \9C\E2a\23\9C\FF\5FF\AC\B3\F5ieg\F2\AE. The legacyExchangeDN is /O=FIRST ORGANIZATION/OU=FIRST ADMINISTRATIVE GROUP/CN=RECIPIENTS/CN=USERNAME.
[17:06:54] Mailbox '/o=First Organization/ou=First Administrative Group/cn=Recipients/cn=SystemMailbox{F9027737-1648-43E0-86A3-517309034AFB}' will be ignored as its DN contains strings in the ignore list
[17:08:06] Copying data from mailbox 'User Name' ('username') on Server 'server' to file 'T:\username.PST'.
[17:08:06] Error opening message store (MSEMS). Verify that the Microsoft Exchange Information Store service is running and that you have the correct permissions to log on. (0x8004011d)
[17:08:06] Errors encountered. Copy process aborted for mailbox 'User Name' ('username').
[17:08:07] Number of items copied from the source store for all mailboxes processed: 0
[17:08:07] Total number of folders processed in the source store: 0
[17:08:07] 0 mailboxes successfully processed. 1 mailboxes were not successfully processed. 0 non-fatal errors encountered.
[17:08:07] Process completion time: 00:00:00

0
 
LVL 13

Accepted Solution

by:
FearNoMore earned 2000 total points
ID: 24428517
The reason why you are getting this error is because the msexchmailboxguid attribute cannot be associated with a mailbox since the AD account and mailbox have been purged
To overcome this there are 2 approaches
1. Convert the RSG to a production SG by modifying the msexchrestore attribute using ADSIedit and then reconect the mailbox to a "test" ad account tnad then use exmerge again
Stepo by step instructions here
http://forums.msexchange.org/m_200058200/mpage_1/key_/tm.htm#200058210
 2.Use the exisitng mailboxguid attribute...convert it to the hex value and link it with a new AD account
The post below talks about the same issue you are experiencing
http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_24312799.html
 
0
 

Author Comment

by:gopher_49
ID: 24432043
I created a user account with the same name.  I changed the ExchangeMailbox GUID and now it reads his mailbox perfectly fine, however, I get an error when extracting.  Below is what the log reads...

[09:06:19] Using attribute 'PR_MESSAGE_DELIVERY_TIME' for date operations.
[09:06:19] Merging data into target store. The program will copy only those messages that do not exist in the target store.
[09:06:19] Associated folder data will NOT be copied to the target store.
[09:06:19] Using 'English (US)' (0x409) as the default locale (Code page 1252)
[09:06:19] All mailboxes will be processed, regardless of locale
[09:06:19] Using last logon locale for all mailboxes, if possible
[09:06:19] Initializing worker thread (Thread0)
[09:06:19] Copying data from mailbox 'User Name' ('USERNAME') on Server 'SERVER_3' to file 'O:\USERNAME.PST'.
[09:06:20] Error opening message store (MSEMS). Verify that the Microsoft Exchange Information Store service is running and that you have the correct permissions to log on. (0x8004011d)
[09:06:20] Errors encountered. Copy process aborted for mailbox 'User Name' ('USERNAME').
[09:06:20] Number of items copied from the source store for all mailboxes processed: 0
[09:06:20] Total number of folders processed in the source store: 0
[09:06:20] 0 mailboxes successfully processed. 1 mailboxes were not successfully processed. 0 non-fatal errors encountered.
[09:06:20] Process completion time: 00:00:00
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 

Author Comment

by:gopher_49
ID: 24432113
Never mind... I close ExMerge and re-opened it..  I then pointed the .PST file to be saved to the server's local hard disk and it's working... Wow..  What a GREAT website you linked me to..  Changing the GUID was easy and worked perfectly fine.  My only problem seemed to be something goofy in ExMerge once I changed the GUID.  This is AMAZING and really simple to do.  Sometimes user accounts get deleted on purpose and then later (after the retention policy) have to be re-created and old emails restored.  Now, I can always use the GFI Mail Archiver bulk export tool and it will grab emails that where even deleted prior to the version on the tape (restore), however, in this particular mailbox I made a TON of subfolders based on company names and it took me about 3 hours to do... So...  By restoring this current version of the mailbox I saved a ton of time.. Anyway..  awsome link.

Thanks!
0
 

Author Comment

by:gopher_49
ID: 24432119
BTW - I used the lnk:

2.Use the exisitng mailboxguid attribute...convert it to the hex value and link it with a new AD account

The post below talks about the same issue you are experiencing

http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_24312799.html


AWSOME.
0
 

Author Closing Comment

by:gopher_49
ID: 31583279
Amazing link.. I used option #2.
0

Featured Post

 [eBook] Windows Nano Server

Download this FREE eBook and learn all you need to get started with Windows Nano Server, including deployment options, remote management
and troubleshooting tips and tricks

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article will help to fix the below error for MS Exchange server 2010 I. Out Of office not working II. Certificate error "name on the security certificate is invalid or does not match the name of the site" III. Make Internal URLs and External…
Check out this step-by-step guide for using the newly updated Experts Exchange mobile app—released on May 30.
To add imagery to an HTML email signature, you have two options available to you. You can either add a logo/image by embedding it directly into the signature or hosting it externally and linking to it. The vast majority of email clients display l…
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
Suggested Courses

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question