Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Share A Folder with vsftpd on Ubuntu Server 7.04

Posted on 2009-05-19
9
Medium Priority
?
792 Views
Last Modified: 2013-12-06
I am pulling data off of one server and giving it to someone else in my office. I am running mediawiki on a server that is on a closed network. I need to move the images folder off of that server to a local file store so I can transfer it somewhere else to be imported into our new wiki server.

I thought I'd use Samba, but why not just use FTP, should work.

I have vsftpd setup and running stand alone. I can connect to it locally via remote terminal and I can connect to it via FileZilla FTP client. I can only see the empty user directory that I set up according to the vsftpd INSTALL doc. I want to be able to use the FTP client to navigate to the directory that I need and transfer files. I have reviewed dozens of posts in forums and on this site and nothing works.

How can I get the FTP server to allow my login to see the folder structure of the server. I'm not on an open system or on the web, I just need to transfer some files and then the server is getting turned off.

 Is it a CHMOD command? an apache configuration? can I just simlink the directory that I want to transfer to the empty directory assigned to /var/ftp user? What's missing? Any ideas?

My vsftpd.conf is below
# Standalone mode
listen=YES
max_clients=200
max_per_ip=4
# Access rights
anonymous_enable=YES
local_enable=NO
write_enable=NO
anon_upload_enable=NO
anon_mkdir_write_enable=NO
anon_other_write_enable=NO
# Security
anon_world_readable_only=YES
connect_from_port_20=YES
hide_ids=YES
pasv_min_port=50000
pasv_max_port=60000
# Features
xferlog_enable=YES
ls_recurse_enable=NO
ascii_download_enable=NO
async_abor_enable=YES
# Performance
one_process_model=YES
idle_session_timeout=120
data_connection_timeout=300
accept_timeout=60
connect_timeout=60
anon_max_rate=50000

Open in new window

0
Comment
Question by:alcratin_42
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 3
  • 2
9 Comments
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 24429550
Hi,
how about local_enable=YES  ?
Take care not to use chroot_local_user=YES

wmp
 
0
 
LVL 40

Expert Comment

by:omarfarid
ID: 24432546
if the below option is in your conf file (which I don't see), then comment it

chroot_local_user=YES
0
 

Author Comment

by:alcratin_42
ID: 24433972
I made the change to enable_local=YES and still the same result.
0
Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

 
LVL 40

Expert Comment

by:omarfarid
ID: 24433988
did you restart the vsftpd server?
0
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 24434149
... it's 'local_enable', afaik. Typo?
0
 

Author Comment

by:alcratin_42
ID: 24435074
Yes, I goofed on my posting earlier. I changed it to

local_enable=YES

When I installed this, I did not do it from apt-get. I had to manually download it and run it. So the binary is not in init.d, it is in /usr/local/sbin. When I want to restart it, I have to use a killall vsftpd command to stop it and then use
/usr/local/sbin/vsftpd &
to restart
0
 
LVL 68

Expert Comment

by:woolmilkporc
ID: 24435137
OK, why not?
0
 

Author Comment

by:alcratin_42
ID: 24437100
Allow to clarify.

I made the change as you requested. I responded with a typo.

My solution was to create a simlink to a folder in a users directory and then login as that user instead of logging in as anonymous. Then I was able to get the files I needed.
0
 
LVL 68

Accepted Solution

by:
woolmilkporc earned 1000 total points
ID: 24437177
Er .... you never told us that you were logging in as anonymous. Anonymous ftp is always chrooted, so what you described in your Q is fully normal behaviour!
Had you told us about the 'anonymous' thing, we would have responded: "Login as local user, and take care that it's allowed to do so by setting local_enable, and that's all!"

0

Featured Post

Enterprise Mobility and BYOD For Dummies

Like “For Dummies” books, you can read this in whatever order you choose and learn about mobility and BYOD; and how to put a competitive mobile infrastructure in place. Developed for SMBs and large enterprises alike, you will find helpful use cases, planning, and implementation.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

1. Introduction As many people are interested in Linux but not as many are interested or knowledgeable (enough) to install Linux on their system, here is a safe way to try out Linux on your existing (Windows) system. The idea is that you insta…
The purpose of this article is to demonstrate how we can upgrade Python from version 2.7.6 to Python 2.7.10 on the Linux Mint operating system. I am using an Oracle Virtual Box where I have installed Linux Mint operating system version 17.2. Once yo…
Michael from AdRem Software outlines event notifications and Automatic Corrective Actions in network monitoring. Automatic Corrective Actions are scripts, which can automatically run upon discovery of a certain undesirable condition in your network.…
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …
Suggested Courses

722 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question