Solved

Cisco Catalyst 2960 PoE Switch - Amber NIC Status

Posted on 2009-05-19
11
4,620 Views
Last Modified: 2012-05-07
Just finished setting up said device.

All ports belong to VLAN 400 other than GigabitEthernet0/4 which belongs to VLAN 400, the management network. That port works fine, and the NIC status LED is green.

I tried plugging a laptop into FastEthernet0/1, and also an uplink to a non-PoE 2960 in GigabitEthernet0/1 but both the NIC status LED lights are amber... they blink too.

I also notice, though I upgraded to firmware 12.5 and this is confirmed when booting, that the running config shows version 12.2.
!

version 12.2

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname host

!

boot-start-marker

boot-end-marker

!

enable secret 5 XXXXX

enable password XXXXX

!

username root privilege 15 password 0 XXXXX

aaa new-model

!

!

aaa authentication login default local

aaa authorization exec default local 

!

!

!

aaa session-id common

system mtu routing 1500

ip subnet-zero

!

!

ip domain-name domain.local

!

!

crypto pki trustpoint TP-self-signed-XXXXX

 enrollment selfsigned

 subject-name cn=IOS-Self-Signed-Certificate-XXXXX

 revocation-check none

 rsakeypair TP-self-signed-XXXXX

!

!

crypto pki certificate chain TP-self-signed-XXXXXX

 certificate self-signed 01

  XXXXX

  quit

!

!

!

!

!

spanning-tree mode pvst

spanning-tree etherchannel guard misconfig

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

ip ssh version 1

!

!

interface FastEthernet0/1

 switchport access vlan 401

 switchport mode access

 duplex full

!

interface FastEthernet0/2

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/3

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/4

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/5

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/6

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/7

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/8

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/9

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/10

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/11

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/12

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/13

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/14

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/15

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/16

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/17

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/18

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/19

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/20

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/21

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/22

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/23

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/24

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/25

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/26

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/27

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/28

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/29

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/30

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/31

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/32

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/33

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/34

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/35

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/36

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/37

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/38

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/39

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/40

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/41

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/42

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/43

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/44

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/45

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/46

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/47

 switchport access vlan 401

 switchport mode access

!

interface FastEthernet0/48

 description Management

 switchport access vlan 401

 switchport mode access

!

interface GigabitEthernet0/1

 description uplink

 switchport access vlan 401

 switchport mode access

!

interface GigabitEthernet0/2

 switchport access vlan 401

 switchport mode access

!

interface GigabitEthernet0/3

 switchport access vlan 401

 switchport mode access

!

interface GigabitEthernet0/4

 description MGMT

 switchport access vlan 400

 switchport mode access

!

interface Vlan1

 no ip address

 no ip route-cache

 shutdown

!

interface Vlan400

 ip address 192.168.1.218 255.255.255.0

 no ip route-cache

!

interface Vlan401

 no ip address

 no ip route-cache

!

ip default-gateway 192.168.1.1

ip http server

ip http secure-server

!

control-plane

!

!

line con 0

line vty 0 4

 password XXXXX

line vty 5 15

 password XXXXX

!

end

Open in new window

0
Comment
Question by:Tercestisi
11 Comments
 
LVL 6

Expert Comment

by:nettek0300
Comment Utility
According to Cisco, a blinking amber light means the port is blocked by STP and is not sending or receiving packets.  What port are you plugging the laptop into?  I would leave all ports set to auto duplex until you get the switch running.  I have seen that cause problems on the network where it will bring the speed of the network to a screeching halt if not conifgured properly.

Another thing you might want to verify is that you are getting a DHCP address, or assign a static IP address to the laptop so that you can verify connectivity to the switch.  Cisco's website has a lot of good support documents that may be of help to you.
0
 
LVL 8

Expert Comment

by:ludo_friend
Comment Utility
catalyst isn't up to 12.5, 12.2 is latest... 12.2(50) is the latest of the 12.2 ios  (so if you've gone between 12.2 versions, it won't change the config version)

can you please post a
show interface status (while the port is flashing amber)

and show logging

thanks.


it could well be a port security violation of some kind (or bdpuguard or something similar), and the show logging will probably reveal the cause.
I'm assumign you have no connectivity on port fe0/1 ?


0
 

Author Comment

by:Tercestisi
Comment Utility
I was wondering if STP is setting it to blocked... but I don't see how a loop is possible as I even hooked up just FE0/1 to the laptop (which has a static IP) and the situation is the same: no connectivity and the amber blinking light. I had it on auto duplex, and only tried to change it to full to see if that was the problem.

Other than that, the other port I did have hooked up (and do again) is GE0/3 which is the port I have connected to the other non-PoE Catalyst.


                                                                                

Port      Name               Status       Vlan       Duplex  Speed Type         

Fa0/1                        connected    401          full  a-100 10/100BaseTX 

Fa0/2                        notconnect   401          auto   auto 10/100BaseTX 

Fa0/3                        notconnect   401          auto   auto 10/100BaseTX 

Fa0/4                        notconnect   401          auto   auto 10/100BaseTX 

Fa0/5                        notconnect   401          auto   auto 10/100BaseTX 

Fa0/6                        notconnect   401          auto   auto 10/100BaseTX 

Fa0/7                        notconnect   401          auto   auto 10/100BaseTX 

Fa0/8                        notconnect   401          auto   auto 10/100BaseTX 

Fa0/9                        notconnect   401          auto   auto 10/100BaseTX 

Fa0/10                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/11                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/12                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/13                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/14                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/15                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/16                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/17                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/18                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/19                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/20                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/21                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/22                       notconnect   401          auto   auto 10/100BaseTX 

                                                                                

Port      Name               Status       Vlan       Duplex  Speed Type         

Fa0/23                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/24                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/25                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/26                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/27                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/28                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/29                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/30                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/31                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/32                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/33                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/34                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/35                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/36                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/37                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/38                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/39                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/40                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/41                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/42                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/43                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/44                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/45                       notconnect   401          auto   auto 10/100BaseTX 

                                                                                

Port      Name               Status       Vlan       Duplex  Speed Type         

Fa0/46                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/47                       notconnect   401          auto   auto 10/100BaseTX 

Fa0/48                       notconnect   401          auto   auto 10/100BaseTX 

Gi0/1                        notconnect   401          auto   auto Not Present  

Gi0/2                        notconnect   401          auto   auto Not Present  

Gi0/3     uplink             notconnect   401          auto   auto 10/100/1000Ba

seTX                                                                            

Gi0/4     MGMT               connected    400        a-full a-1000 10/100/1000Ba

seTX 

Open in new window

0
 

Author Comment

by:Tercestisi
Comment Utility

Syslog logging: enabled (0 messages dropped, 0 messages rate-limited, 0 flushes,

 0 overruns, xml disabled, filtering disabled)                                  

                                                                                

No Active Message Discriminator.                                                

                                                                                

                                                                                

                                                                                

No Inactive Message Discriminator.                                              

                                                                                

                                                                                

    Console logging: level debugging, 76 messages logged, xml disabled,         

                     filtering disabled                                         

    Monitor logging: level debugging, 0 messages logged, xml disabled,          

                     filtering disabled                                         

    Buffer logging:  level debugging, 76 messages logged, xml disabled,         

                     filtering disabled                                         

    Exception Logging: size (4096 bytes)                                        

    Count and timestamp logging messages: disabled                              

    File logging: disabled                                                      

    Persistent logging: disabled                                                

                                                                                

No active filter modules.                                                       

                                                                                

    Trap logging: level informational, 68 message lines logged                  

                                                                                

Log Buffer (4096 bytes):                                                        

e FastEthernet0/1, changed state to up                                          

*Mar  1 00:34:19.755: % Multiple self signed certificates in config             

    certificate for trust point TP-self-signed-2208675328 ignored               

                                                                                

*Mar  1 00:34:21.810: %SYS-5-CONFIG_I: Configured from tftp://192.168.1.145/192.

168.1.218_481718.cfg by root on vty0 (192.168.1.145)                            

*Mar  1 00:35:57.122: %SYS-5-CONFIG_I: Configured from console by root on vty0 (

192.168.1.145)                                                                  

*Mar  1 00:39:30.494: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthern

et0/1, changed state to down                                                    

*Mar  1 00:39:32.491: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state t

o down                                                                          

*Mar  1 00:39:34.244: %SYS-5-CONFIG_I: Configured from console by root on vty0 (

192.168.1.145)                                                                  

*Mar  1 00:39:34.831: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state t

o up                                                                            

*Mar  1 00:39:34.840: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthern

et0/1, changed state to up                                                      

*Mar  1 00:40:21.489: %SYS-5-CONFIG_I: Configured from console by root on vty0 (

192.168.1.145)                                                                  

*Mar  1 00:41:22.751: % Multiple self signed certificates in config             

    certificate for trust point TP-self-signed-2208675328 ignored               

                                                                                

*Mar  1 00:41:24.504: %SYS-5-CONFIG_I: Configured from tftp://192.168.1.145/192.

168.1.218_254618.cfg by root on vty1 (192.168.1.145)                            

*Mar  1 00:47:23.754: % Multiple self signed certificates in config             

    certificate for trust point TP-self-signed-2208675328 ignored               

                                                                                

*Mar  1 00:47:25.768: %SYS-5-CONFIG_I: Configured from tftp://192.168.1.145/192.

168.1.218_13449.cfg by root on vty1 (192.168.1.145)                             

*Mar  1 01:06:40.594: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEth

ernet0/3, changed state to down                                                 

*Mar  1 01:06:42.590: %LINK-3-UPDOWN: Interface GigabitEthernet0/3, changed stat

e to down                                                                       

*Mar  1 01:07:00.693: %LINK-3-UPDOWN: Interface GigabitEthernet0/3, changed stat

e to up                                                                         

*Mar  1 01:07:00.701: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEth

ernet0/3, changed state to up                                                   

*Mar  1 01:07:28.711: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEth

ernet0/3, changed state to down                                                 

*Mar  1 01:07:30.716: %LINK-3-UPDOWN: Interface GigabitEthernet0/3, changed stat

e to down                                                                       

*Mar  1 01:07:42.837: %LINK-3-UPDOWN: Interface GigabitEthernet0/3, changed stat

e to up                                                                         

*Mar  1 01:07:42.846: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEth

ernet0/3, changed state to up                                                   

*Mar  1 01:08:59.853: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEth

ernet0/3, changed state to down                                                 

*Mar  1 01:09:01.623: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthern

et0/1, changed state to down                                                    

*Mar  1 01:09:01.849: %LINK-3-UPDOWN: Interface GigabitEthernet0/3, changed stat

e to down                                                                       

*Mar  1 01:09:03.619: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state t

o down                                                                          

*Mar  1 01:09:05.549: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state t

o up                                                                            

*Mar  1 01:09:05.557: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthern

et0/3, changed state to up                                                      

*Mar  1 01:46:15.551: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthern

et0/3, changed state to down                                                    

*Mar  1 01:46:17.548: %LINK-3-UPDOWN: Interface FastEthernet0/3, changed state t

o down                                                                          

*Mar  1 01:46:21.356: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state t

o up                                                                            

*Mar  1 01:46:21.364: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthern

et0/1, changed state to up                                                      

*Mar  1 01:47:08.785: % Multiple self signed certificates in config             

    certificate for trust point TP-self-signed-2208675328 ignored               

                                                                                

*Mar  1 01:47:10.589: %PARSER-4-BADCFG: Unexpected end of configuration file.   

                                                                                

*Mar  1 01:47:10.589: %SYS-5-CONFIG_I: Configured from tftp://192.168.1.145/192.

168.1.218_363483.cfg by root on vty1 (192.168.1.145)                            

*Mar  1 01:50:56.788: % Multiple self signed certificates in config             

    certificate for trust point TP-self-signed-2208675328 ignored               

                                                                                

*Mar  1 01:50:58.616: %SYS-5-CONFIG_I: Configured from tftp://192.168.1.145/192.

168.1.218_79919.cfg by root on vty1 (192.168.1.145)                             

*Mar  1 01:52:18.476: %SYS-5-CONFIG_I: Configured from console by root on vty0 (

192.168.1.145)                                                                  

*Mar  1 01:52:40.328: %SYS-5-CONFIG_I: Configured from console by root on vty0 (

192.168.1.145) 

Open in new window

0
 
LVL 8

Expert Comment

by:ludo_friend
Comment Utility
*Mar  1 01:46:21.356: %LINK-3-UPDOWN: Interface FastEthernet0/1, changed state to up                                                                            
*Mar  1 01:46:21.364: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
 
the connection is up and the interface status is connected. do you have connectivity?

if you're laptop is having the same issue that wouldn't be an stp issue.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:Tercestisi
Comment Utility
The laptop shows as up... I just cannot ping anything and the amber light is still on FE0/1.
0
 

Author Comment

by:Tercestisi
Comment Utility
If I unplug the cable from FE0/1 and plug it into the non-PoE switch I can ping the gateway just fine, so the laptop NIC is working fine.
0
 

Author Comment

by:Tercestisi
Comment Utility
Well, I opened the box for our other Catalyst 2960 PoE switch and did nothing but let it boot; I plugged in the laptop and after 30 seconds the NIC went green... so something is wrong with the other switch.

As at test, I set boot system to the original lan-base image but the NIC status is still amber on that one.

Something in the config file?  I'm going to attempt to put the config back to the starting config by mimicking certain aspects of the config on the working switch.

Any ideas?
0
 

Author Comment

by:Tercestisi
Comment Utility
Interesting...

I cleaned up the config to mirror the other one in certain areas (other than encryption keys, unique data, etc.), but still nothing.

But... as soon as I issued:

interface FastEthernet0/1
no switchport access vlan 401
no switchport mode access
shutdown
end
interface FastEthernet0/1
no shutdown

the status for the interface went green!

Now what's going on here?
0
 

Accepted Solution

by:
Tercestisi earned 0 total points
Comment Utility
Got it to work... simply recreated everything plus I enabled GE0/3 as a trunk.
0
 
LVL 5

Expert Comment

by:devangshroff
Comment Utility
pls chek the port and enduser speed
0

Featured Post

How your wiki can always stay up-to-date

Quip doubles as a “living” wiki and a project management tool that evolves with your organization. As you finish projects in Quip, the work remains, easily accessible to all team members, new and old.
- Increase transparency
- Onboard new hires faster
- Access from mobile/offline

Join & Write a Comment

Suggested Solutions

The worst thing when starting a new job is when the previous Network Administrator left behind no documentation. How do you get into the devices? If you've been in this situation or just accidently mistyped your password, this article will hopefully…
Cisco Pix/ASA hairpinning The term, hairpinning, comes from the fact that the traffic comes from one source into a router or similar device, makes a U-turn, and goes back the same way it came. Visualize this and you will see something that looks …
Sending a Secure fax is easy with eFax Corporate (http://www.enterprise.efax.com). First, Just open a new email message.  In the To field, type your recipient's fax number @efaxsend.com. You can even send a secure international fax — just include t…
This video discusses moving either the default database or any database to a new volume.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now