• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2528
  • Last Modified:

Microsoft SQL Server Error: 233

Hi all,
I'm in the proces of migrating a MSSQL2000 Standard Edition database in a shared hosting to environment, over to a dedicated server, MSSQL2008 Web Edition database.

I've done the following:

1. Fully exported the database from MSSQL2000 - my hosting company provided me with this.
2. Imported it into MSSQL2008
3. The database seems to import fine, with all table and the users and so on/

4. Checked for" orphaned" users on MSSQL2008 - none seem to be returned with the following script - whilst connect to the required database as sa.
EXEC sp_change_users_login 'Report';

5. Manually create the user login onto the MSSQL2008 database - and ran:
EXEC sp_change_users_login 'Report';
Still no errors.

However, then I try to connect to the database, I get the following error?!?
Any ideas as to the problem - I'm getting desperate!

Regards

Jamie


MSSQLError.jpg
0
Jamie
Asked:
Jamie
  • 6
  • 5
1 Solution
 
JamieAuthor Commented:
Hi All,
I've been using the following to help me through the process, but still getting the attached error:
http://www.dell.com/downloads/global/solutions/public/white_papers/SQL_2000_SQL_2008_Migration_Guide.pdf
thanks
JamWales
0
 
St3veMaxCommented:
On the server; In the SQL Network Configuration; Turn off Named Pipes and Turn On TCP/IP; then restart SQL Service and give it another go.

HTH
0
 
JamieAuthor Commented:
Hi St3veMax,
Sorry, I forgot to say - I'm trying to logon, whilst on the actual MSSQL server itself. That said, to be certain I have checked, and named pipes are already disabled, and tcpip enabled.
Thanks
JamWales
MSSQL-Network.jpg
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
St3veMaxCommented:
OK, WHat you see is identical to our clustered environment.

What happens it you try and connect to SQL from the locally installed management studio ?

Cheers
0
 
JamieAuthor Commented:
Hi St3veMax,

The errors I described above are from the locally installed management studio - until this works I have not looked at trying to connect from a remote location. I'm using remote desktop to access the server directly.
Regards
JamWales
0
 
St3veMaxCommented:
OK, With you. Disable Shared Memory, Restart SQL Server and try again.
0
 
JamieAuthor Commented:
Hi St3veMax,
Tried that and the orginal error has gone - only to be replaced with another one?!

I set the default database to the one that was restored from MSSQL2000  in the login connection properties on Management Studio - plus this has also been set in the login properties on the user (security settings) in the database itself.

 I very much appreciatre the time and help you are giving me - I'm out of my depth with this one!

Regards
JamWales
MSSQL-Error4064.jpg
0
 
St3veMaxCommented:
No Worries Jam.

Set your default database to 'Master' and try again.

You will then need to link your login back to the record in teh old db as it will have been orphaned.

EXEC sp_update_users_login 'report'

then

EXEC sp_change_users_login 'update_one', 'yourusername', 'yourusername'

HTH

0
 
St3veMaxCommented:
also; You should then be able to change your default database back once you've tested the above.
0
 
JamieAuthor Commented:
YAHOOOOOOOOO - It's Works!!!!!!!!!!!!!!!!!!!!!!! Many thanks for your help, saves me drinking 20 cans of Red Bull a day!
JamWales
0
 
St3veMaxCommented:
Glad to help...BTW Relentless is better ;o)
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 6
  • 5
Tackle projects and never again get stuck behind a technical roadblock.
Join Now