Solved

Where am I going to put these codes in Apache/2.2.9 (Debian)

Posted on 2009-05-20
3
273 Views
Last Modified: 2013-12-06
Need urgent help as I'm still at work and it's already 9:00pm.
we transfer our site to a new webserver with the new debian apache2 package.
now, with the debian apache2 package, everything is modularized and took me time to know where to set the virtualhosts. now with the htaccess or security settings as posted below.

thanks
#MYWEBSITE1

<Directory "/var/www/mywebsite1">

AllowOverride All

Options +FollowSymLinks Indexes

Order deny,allow

</Directory>
 

#MYWEBSITE2

<Directory "/var/www/mywebsite2">

AllowOverride All

Options +FollowSymLinks Indexes

Order deny,allow

</Directory>

Open in new window

0
Comment
Question by:Raleigh
  • 3
3 Comments
 
LVL 8

Accepted Solution

by:
yfastud earned 500 total points
ID: 24431593
you should put them in httpd-vhosts.conf if already enable this file in main config file httpd.conf as below; also make sure to create folder logs in each appropriate folder to make it work

NameVirtualHost *:80
 

#MYWEBSITE1

<VirtualHost *:80>

ServerName www.mywebsite1.com

ServerAlias mywebsite1.com mywebsite1

DocumentRoot /var/www/mywebsite1

ErrorLog /var/www/mywebsite1/logs/error.log

CustomLog /var/www/mywebsite1/logs/access.log common

<Directory "/var/www/mywebsite1">

AllowOverride All

Options +FollowSymLinks Indexes

Order deny,allow

</Directory>

</VirtualHost>
 

#MYWEBSITE2

<VirtualHost *:80>

ServerName www.mywebsite2.com

ServerAlias mywebsite2.com mywebsite2

DocumentRoot /var/www/mywebsite2

ErrorLog /var/www/mywebsite2/logs/error.log

CustomLog /var/www/mywebsite2/logs/access.log common

<Directory "/var/www/mywebsite2">

AllowOverride All

Options +FollowSymLinks Indexes

Order deny,allow

</Directory>

</VirtualHost>

Open in new window

0
 
LVL 8

Assisted Solution

by:yfastud
yfastud earned 500 total points
ID: 24431786
btw, I've copied and pasted, and after posted, I've recognized you had little mistake in your script which should includes some permission after "Order deny,allow"; for example

Order deny,allow

deny from all

allow from xxx.xxx.xxx.xxx

Open in new window

0
 
LVL 8

Assisted Solution

by:yfastud
yfastud earned 500 total points
ID: 24431982
btw, httpd.conf file should be in apache2 dir and httpd-vhosts.conf file should be in apache2/extra dir
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

In my business, I use the LTS (Long Term Support) versions of Linux. My workstations do real work, and so I rarely have the patience to deal with silly problems caused by an upgraded kernel that had experimental software on it to begin with from a r…
If your site has a few sections that need to be secure when data is transmitted between the server and local computer, such as a /order/ section for ordering or /customer/ which contains customer data, etc it would of course be recommended to secure…
It is a freely distributed piece of software for such tasks as photo retouching, image composition and image authoring. It works on many operating systems, in many languages.
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…

758 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now