Solved

Cisco 857w configuration

Posted on 2009-05-20
6
1,474 Views
Last Modified: 2013-12-14
Hi All

Attached is the configuration my ADSL2+ service provider (Australian provider 'Internode') sent me for my Cisco 857w ADSL modem/router. Needless to say as I am posting on Experts-Exchange, I cannot get it to work!

I've swapped out <...> for the correct details. The only commands the router hold me up on are the ip nat commands, for which I receive:

%NAT: Error activating CNBAR on the interface Vlan1
%NAT: Error activating CNBAR on the interface Dialer0

Those errors aside though, I thought I would at least get an IP address from the service provider.

When I do a show dsl int atm 0 all i get is:

Line has not yet been activated. No information available.

Please let me know if any more information is needed. Any help would be greatly appreciated!

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname <hostname>

!

boot-start-marker

boot-end-marker

!

logging buffered 65535 debugging

logging console informational

enable secret <password>

!

no aaa new-model

!

resource policy

!

clock timezone ACST 9 30

clock summer-time ACST recurring last Sun Oct 2:00 last Sun Mar 2:00

ip subnet-zero 

no ip source-route 

ip cef 

no ip dhcp use vrf connected 

ip dhcp excluded-address 192.168.0.0 192.168.0.10

 !

ip dhcp pool lan

   network 192.168.0.0 255.255.255.0

   default-router 192.168.0.1

   dns-server 192.231.203.132 192.231.203.3

   lease infinite

!

!

no ip bootp server

ip domain name internode.on.net

ip name-server 192.231.203.132

ip name-server 192.231.203.3

ip ssh time-out 90

ip ssh authentication-retries 2

!

!

!

username admin

password <password>

!

!

!

!

!

interface ATM0

 description --- Internode ADSL ---

 no shutdown

 no ip address

 no atm ilmi-keepalive

 pvc 8/35

  tx-ring-limit 3

  encapsulation aal5snap

  protocol ppp dialer

  dialer pool-member 1

 !

 dsl operating-mode auto

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Vlan1

 description --- Ethernet LAN ---

 ip address 192.168.0.1 255.255.255.0

 ip nat inside

 ip virtual-reassembly

 ip tcp adjust-mss 1420

!

interface Dialer0

 description --- Internode ADSL ---

 ip address negotiated

 ip mtu 1460

 ip tcp adjust-mss 1420

 ip nat outside

 ip virtual-reassembly

 encapsulation ppp

 dialer pool 1

 dialer-group 1

 ppp chap hostname <username>@internode.on.net 

 ppp chap password <password>

!!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

!

no ip http server

no ip http secure-server

ip nat inside source list 101 interface Dialer0 overload !

access-list 1 permit 192.83.231.0 0.0.0.255 

access-list 1 permit 203.26.95.0 0.0.0.255 

access-list 1 permit 192.168.0.0 0.0.0.255 

access-list 101 permit ip 192.168.0.0 0.0.0.255 any no cdp run !

control-plane

!

!

line con 0

 login local

 no modem enable

line aux 0

line vty 0 4

 access-class 1 in

 login local

!

scheduler max-task-time 5000

sntp server 192.231.203.132

end

Open in new window

0
Comment
Question by:Elthamtech
  • 3
  • 3
6 Comments
 
LVL 16

Accepted Solution

by:
BBRazz earned 500 total points
ID: 24441116
Looking at a previous post, it looks like it maybe a firmware issue.

I suggest checking the Cisco site for an upto date firmware.

http://www.experts-exchange.com/Hardware/Networking_Hardware/Q_22765355.html

-BBRazz
0
 

Author Comment

by:Elthamtech
ID: 24442570
Ah huh! Thanks for the great idea BBRazz! I now have a connection when I do a show dsl int atm 0. I didn't even think of firmware upgrades, I had only looked at the IOS. So thats fixed my DSL not connecting at all but I'm still getting the NAT errors:

%NAT: Error activating CNBAR on the interface Vlan1
%NAT: Error activating CNBAR on the interface

I'm assuming this is stopping everything else from working??
0
 
LVL 16

Expert Comment

by:BBRazz
ID: 24442917
I get the same errors on some of my config's but it causes no issue. You could look at the IOS version.

Below is the details of a Device that has the same notifications, but works fine in operation.



manchester#sh ver

Cisco IOS Software, C850 Software (C850-ADVSECURITYK9-M), Version 12.4(15)T5, RELEASE SOFTWARE (fc4)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2008 by Cisco Systems, Inc.

Compiled Thu 01-May-08 02:07 by prod_rel_team
 

ROM: System Bootstrap, Version 12.3(8r)YI4, RELEASE SOFTWARE
 

manchester uptime is 2 weeks, 4 days, 14 hours, 50 minutes

System returned to ROM by power-on

System image file is "flash:c850-advsecurityk9-mz.124-15.T5.bin"

Open in new window

0
VMware Disaster Recovery and Data Protection

In this expert guide, you’ll learn about the components of a Modern Data Center. You will use cases for the value-added capabilities of Veeam®, including combining backup and replication for VMware disaster recovery and using replication for data center migration.

 

Author Comment

by:Elthamtech
ID: 24446935
That mustn't be my problem then! Any other ideas as to why I still have no connectivity? atm0 is up, dialer0 is up and everything seems OK...
0
 

Author Comment

by:Elthamtech
ID: 24449082
Thanks so much BBRaz, that firmwire was the only problem! I just wasn't thinking straight when I tried it late last night! Very much appreciated...500 points to you!
0
 
LVL 16

Expert Comment

by:BBRazz
ID: 24449110
Glad you're running again!
0

Featured Post

Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Port forwarding 14 117
NSD FAIL 2 97
BGP routing on Windows 2016 7 40
The purpose of using BGP 33 72
The Cisco RV042 router is a popular small network interfacing device that is often used as an internet gateway. Network administrators need to get at the management interface to make settings, change passwords, etc. This access is generally done usi…
Tired of waiting for your show or movie to load?  Are buffering issues a constant problem with your internet connection?  Check this article out to see if these simple adjustments are the solution for you.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

910 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now