• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 509
  • Last Modified:

Can't access owa externally

I have installed SBS 2008. I have an A record pointing to remote.mydomain.com and remote desktop is working fine. I can access owa internally fine using https://remote.mydoamin.com/owa but when I try externally I dont get anything (the page just says loading) I think I am currently using the default certificate but am not sure. Do I need to purchase a certificate for owa to work externally. Also is my rdp setting clashing with owa. On the router port 443 is opened and redirected to the sbs server.
Anyones help would be appreciated.
0
Boschie
Asked:
Boschie
  • 8
  • 7
  • 2
1 Solution
 
Rajith EnchiparambilOffice 365 & Exchange ArchitectCommented:
Though it is ideal to use a commercial cert, OWA will work with self generated cert.
Is your owa url pointing to your firewall and does the firewall route all 443 traffic to sbs?
0
 
BoschieAuthor Commented:
yes firewall does route all traffic to sbs.
how do I check owa url is pointing to firewall?
0
 
Rajith EnchiparambilOffice 365 & Exchange ArchitectCommented:
nslookup
0
Problems using Powershell and Active Directory?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

 
2PiFLCommented:

You need to open udp port 1755.  If you are doing a port 80 redirect to 443 you'll need to open port 80 also.
0
 
BoschieAuthor Commented:
i have opened port 1755 - it has made no difference and both 80 and 443 are opened and pointing to the sbs server
0
 
2PiFLCommented:

what firewall are you using?
0
 
BoschieAuthor Commented:
Draytek Vigor 2700
0
 
2PiFLCommented:
What happens if you try to access owa using the ip address?
0
 
BoschieAuthor Commented:
after a few minutes firefox says failed to connect
0
 
2PiFLCommented:
Is IIS configured to accept external connections?

Do you have any way to monitor traffic through the firewall?
0
 
BoschieAuthor Commented:
Where would you find out if it was?
No IIS Settings have been modified - surely it would be enabled by default if OWA was enabled on exchange
0
 
2PiFLCommented:
In IIS Services Manager, Right Click the website, Click Properties, Click the Web Site tab and make sure the IP address box say (All unassigned).
0
 
BoschieAuthor Commented:
I put a tick in the manage remote connections. it was set to all unassigned port 8172. I restarted management service and I still cannot connect remotely via owa
0
 
2PiFLCommented:
Is port 8172 open on the firewall?
0
 
BoschieAuthor Commented:
yes it is now and there is still no external owa access
0
 
2PiFLCommented:

Can you look at the firewall log to see where the connection is getting rejected?
0
 
BoschieAuthor Commented:
Thanks I checked the router and noticed that the remote management on https was set to port 443 so I changed that and now I can get access.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

  • 8
  • 7
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now