Solved

Isn't MSCONFIG supposed to have a BOOT.INI option ?

Posted on 2009-05-20
19
644 Views
Last Modified: 2012-05-07
I remember getting a "boot.ini" tab in msconfig.
I am not getting that option when I run it.
Could there be a setting someplace that's supressing it ?
msconfigimg.bmp
0
Comment
Question by:ccbon
  • 9
  • 7
  • 2
  • +1
19 Comments
 
LVL 5

Expert Comment

by:Michaelj42
ID: 24432329
Perhaps this will help.

http://windowsxp.mvps.org/bootini.htm
0
 
LVL 70

Expert Comment

by:KCTS
ID: 24432330
To get to Boot.ini right click "my Computer", selectm Properties and then on the Advanced Tab, select Start Up and recovery settings and click EDIT to edit the boot.ini file
0
 

Author Comment

by:ccbon
ID: 24432958
Thanks Michaelj42 and KCTS.
I tried everything that was suggested by the link you provided, but neither of the two areas they said to check was a problem;  one was to check for a possible permissions problem, but I was able to START/RUN/ boot.ini without a problem so that wasn't it.  The other was a possible registry entry but mine didn't have the problem entry.
KCTS, when I rightclick on MY COMPUTER, then PROPERTIES, I don't get an  startup and recovery settings when I choose ADVANCED.  What I get instead is the standard advanced options for the shortcut (e.g., run with different credentials, run in separate memory space).  

I do know how to get at boot.ini - it isn't that I want to access it and can't, but rather I want to know why it doesn't appear in msconfig like it's supposed to.
0
 
LVL 8

Expert Comment

by:eXpeLLeD_4RM_heLL
ID: 24433965
Open Regedit and navigate to:  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\MSConfig. In the right-pane, delete the value named Boot.ini  (if found).
0
 

Author Comment

by:ccbon
ID: 24437745
hi, thanks eXpeLLeD4, I did that, and there's no 'boot.ini' there.
0
 
LVL 5

Expert Comment

by:Michaelj42
ID: 24437813
ccbon, you need to add boot.ini to HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\MSConfig\state so it should look like the picture below.

http://www.techimo.com/forum/applications-operating-systems/172381-boot-ini-doesnt-show-up-msconfig.html

reg.jpg
0
 

Author Comment

by:ccbon
ID: 24438026
Michaelj42, thanks - I made that change but it didn't work.
I also tried it with a value of '2' for bootini and that didn't do it either.
I did reboot after each change.
0
 
LVL 5

Expert Comment

by:Michaelj42
ID: 24438139
Could you post the contents of your boot.ini file? I'm wondering if rebuilding the boot.ini might fix this.
0
 

Author Comment

by:ccbon
ID: 24440154
Sure. Attaching a copy of the boot.ini file.
bootinicopy.txt
0
Backup Your Microsoft Windows Server®

Backup all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

 

Author Comment

by:ccbon
ID: 24440183
PS !!  I want to add "noguiboot" to it, but I'm afraid that will truncate the line, and I don't know the correct syntax for continuing a line on the next one !!!!
That's one of the reasons I really want to get to it via msconfig, because when it's working right, msconfig lets you just check off a box for 'noguiboot'  and I don't have to worry about making an error editing the file.
0
 
LVL 5

Expert Comment

by:Michaelj42
ID: 24441112
Just open boot.ini in notepad and add the /noguiboot on the end of the boot option you want to modify. If word wrap is on in notepad (although it makes no difference) you can turn it off so it appears all on one line.

I'm coming up dry on why it will not open in msconfig, one thing I didn't ask is whether you boot from C: drive. If boot.ini is not on C then it will not show up in msconfig.
0
 
LVL 5

Expert Comment

by:Michaelj42
ID: 24441147
You'd do it like below.
[boot loader]

timeout=1

default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS

[operating systems]

multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect /noguiboot

Open in new window

0
 
LVL 8

Expert Comment

by:eXpeLLeD_4RM_heLL
ID: 24442345
0
 

Author Comment

by:ccbon
ID: 24452498
My root directory is I:, not C: - only because I bought this as a bare-bone system and put it together myself, when I plugged in the hard drive I used the socket on the motherboard at the end - the WRONG end.  

I will try the couple of solutions suggested.

0
 
LVL 5

Accepted Solution

by:
Michaelj42 earned 500 total points
ID: 24453163
OK, that's the problem then, I've read that msconfig looks for boot.ini on your C drive. If it isn't here, no boot.ini tab.
0
 

Author Comment

by:ccbon
ID: 24455286
What a stupid default.  I can't be the only one that doesn't use drive letter 'c' for the hard drive.  
0
 
LVL 5

Expert Comment

by:Michaelj42
ID: 24457484
Yes, a bit odd. Here's another source saying the same thing, be sure to read page two.

http://forums.techguy.org/windows-nt-2000-xp/631026-solved-boot-ini-tab-missing.html
0
 

Author Comment

by:ccbon
ID: 24495224
Hi.  I thought I'd accepted and closed this question 2 days ago.  I must have screwed up somehow.  My apologies.

Thanks so much for all the replies.

I accepted Michaelj42's solution telling me the cause is my non-standard drive letter assignments.  It's a satisfactory solution because it makes sense, and if I couldn't fix it, I at least wanted to understand why.

Thank you .
0
 

Author Closing Comment

by:ccbon
ID: 31583538
A good, concise answer.  Much appreciated.
0

Featured Post

Is Your Active Directory as Secure as You Think?

More than 75% of all records are compromised because of the loss or theft of a privileged credential. Experts have been exploring Active Directory infrastructure to identify key threats and establish best practices for keeping data safe. Attend this month’s webinar to learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Creating an XP virtual machine 38 166
Clone HDD in RAID1 10 120
windows seems to be corrupt 10 69
Which browser works with XP 16 101
There are 2 things you must have in order to connect to the internet behind a router, The "Gateway IP" of the router, which is usually something like 192.168.xxx.1, I've seen routers with default values of: 192.168.0.1, 192.168.1.1, 192.168.11.1, …
If you have done a reformat of your hard drive and proceeded to do a successful Windows XP installation, you may notice that a choice between two operating systems when you start up the machine. Here is how to get rid of this: Click Start Clic…
Need to grow your business through quality cloud solutions? With everything required to build a cloud platform and solution, you may feel like the distance between you and the cloud is quite long. Help is here. Spend some time learning about the Con…
With Secure Portal Encryption, the recipient is sent a link to their email address directing them to the email laundry delivery page. From there, the recipient will be required to enter a user name and password to enter the page. Once the recipient …

932 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

12 Experts available now in Live!

Get 1:1 Help Now