Want to win a PS4? Go Premium and enter to win our High-Tech Treats giveaway. Enter to Win

x
?
Solved

Database Logon - The report you requested requires further information.

Posted on 2009-05-20
11
Medium Priority
?
2,077 Views
Last Modified: 2012-05-07
I am trying to run a report with CR Server XI that pulls from an Access Database on another machine.

I have setup other reports that pull from other (non-Access) databases with no problem.

But with the Acces DB, I get a prompt:

"The report you requested requires further information."

Database Logon

G:\HED2000\HDS_DTA.MDB - G:\HED2000\HDS_DTA.MDB  G:\HED2000\HDS_DTA.MDB - G:\HED2000\HDS_DTA.MDB
Server Name G:\HED2000\HDS_DTA.MDB
Database Name G:\HED2000\HDS_DTA.MDB
User ID  
Password  


* Notes *

*There is no password on the database.

*The report runs fine manually from Crystal Reports 10

*The report runs fine if I copy the Database to the local machine CR Server is on.

*If I switch the option from " Prompt the user for database logon" to  "Use same database logon as when report is run", I get the error "The database logon information for this report is either incomplete or incorrect."
0
Comment
Question by:CenStates
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 2
  • +1
11 Comments
 
LVL 101

Expert Comment

by:mlmcc
ID: 24433498
Try using
User - ADMIN
No password

How are you running the report

mlmcc
0
 

Author Comment

by:CenStates
ID: 24433571
Thank you, for your help.

I have tried ADMIN with no password.  I have also tried adding a password to the database.  This must be something real simple, but it has me stumped.

Also note, that if I move the database to the CR Server machine, the report runs.  It also runs with just crystal reports professional on both the server machine and other workstations.
0
 
LVL 38

Expert Comment

by:Jim P.
ID: 24433664
The issue is the "G:\HED2000\" -- do you have a G: on the local machine?
Is it a mapped drive?

Try changing the G:\HED2000\HDS_DTA.MDB to \\MySerrverName\MyShare\HED2000\HDS_DTA.MDB in all locations.
0
Fill in the form and get your FREE NFR key NOW!

Veeam® is happy to provide a FREE NFR server license to certified engineers, trainers, and bloggers.  It allows for the non‑production use of Veeam Agent for Microsoft Windows. This license is valid for five workstations and two servers.

 

Author Comment

by:CenStates
ID: 24434256
no luck

G:\is a mapped drive.  I also tried using the UNC path \\maerchandsining\all\hed2000\hds_dta.mdb
Then I tried creating an ODBC connection. Connections all work, but when report is run, the same error.

Why does it run from Crystal standalone, but not from server?
0
 
LVL 38

Accepted Solution

by:
Jim P. earned 500 total points
ID: 24434502
What is the Log On As column of the Crystal Server service say? If LocalSystem right click --> Properties and change it to a different domain login id.
SQL-Server-Login-Properties.jpg
0
 
LVL 101

Expert Comment

by:mlmcc
ID: 24434928
When you changed to the UNC did you use the SET DATABASE LOCATION in the report?  The report maintains the original connection and will try to use it.

mlmcc
0
 

Author Comment

by:CenStates
ID: 24435825
Yes, I changed the data source in the report.

Error
The database logon information for this report is either incomplete or incorrect.

All non Access reports run fine on the CR Server over the network.
0
 
LVL 38

Assisted Solution

by:Jim P.
Jim P. earned 500 total points
ID: 24436478
>> The database logon information for this report is either incomplete or incorrect.

That was after you changed the id on the Crystal Reports Server service and restarted?

The reason that I ask, if you are using the Local System (LS) for the service, the LS id essentially can't see much outside of the box that it is running on. Even if you are logged in as a Domain Admin -- the LS and are restricted. It also doesn't see mapped drives.  So when CR Service is running it can't find the G: drive because that is tied to the user who is logged in. If it is LS then when it says to \\maerchandsining -- "Hey I'm \\ThisMachine\LSid"; \\maerchandsining says "who the heck is that and I'm not going to give you data."

We run into it all the time with various services.
0
 

Author Comment

by:CenStates
ID: 24440741
Changed logon for all CR services from "Local System" to "Administrator"  

IT WORKED!!!

Thank for all the help!
0
 
LVL 38

Expert Comment

by:Jim P.
ID: 24440842
Glad to be of assistance. May all your days get brighter and brighter.
0
 

Expert Comment

by:hongclub
ID: 34885551
How you changed logon for all CR services from "Local System" to "Administrator"

in my case, i am making a crystal report with excel as import resource ... but still ask me that stupid login, any suggestion?

tommy
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Access custom database properties are useful for storing miscellaneous bits of information in a format that persists through database closing and reopening.  This article shows how to create and use them.
Did you know that more than 4 billion data records have been recorded as lost or stolen since 2013? It was a staggering number brought to our attention during last week’s ManageEngine webinar, where attendees received a comprehensive look at the ma…
In Microsoft Access, learn how to use Dlookup and other domain aggregate functions and one method of specifying a string value within a string. Specify the first argument, which is the expression to be returned: Specify the second argument, which …
With Microsoft Access, learn how to specify relationships between tables and set various options on the relationship. Add the tables: Create the relationship: Decide if you’re going to set referential integrity: Decide if you want cascade upda…

610 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question