Solved

Database Logon - The report you requested requires further information.

Posted on 2009-05-20
11
2,067 Views
Last Modified: 2012-05-07
I am trying to run a report with CR Server XI that pulls from an Access Database on another machine.

I have setup other reports that pull from other (non-Access) databases with no problem.

But with the Acces DB, I get a prompt:

"The report you requested requires further information."

Database Logon

G:\HED2000\HDS_DTA.MDB - G:\HED2000\HDS_DTA.MDB  G:\HED2000\HDS_DTA.MDB - G:\HED2000\HDS_DTA.MDB
Server Name G:\HED2000\HDS_DTA.MDB
Database Name G:\HED2000\HDS_DTA.MDB
User ID  
Password  


* Notes *

*There is no password on the database.

*The report runs fine manually from Crystal Reports 10

*The report runs fine if I copy the Database to the local machine CR Server is on.

*If I switch the option from " Prompt the user for database logon" to  "Use same database logon as when report is run", I get the error "The database logon information for this report is either incomplete or incorrect."
0
Comment
Question by:CenStates
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
  • 2
  • +1
11 Comments
 
LVL 101

Expert Comment

by:mlmcc
ID: 24433498
Try using
User - ADMIN
No password

How are you running the report

mlmcc
0
 

Author Comment

by:CenStates
ID: 24433571
Thank you, for your help.

I have tried ADMIN with no password.  I have also tried adding a password to the database.  This must be something real simple, but it has me stumped.

Also note, that if I move the database to the CR Server machine, the report runs.  It also runs with just crystal reports professional on both the server machine and other workstations.
0
 
LVL 38

Expert Comment

by:Jim P.
ID: 24433664
The issue is the "G:\HED2000\" -- do you have a G: on the local machine?
Is it a mapped drive?

Try changing the G:\HED2000\HDS_DTA.MDB to \\MySerrverName\MyShare\HED2000\HDS_DTA.MDB in all locations.
0
Creating Instructional Tutorials  

For Any Use & On Any Platform

Contextual Guidance at the moment of need helps your employees/users adopt software o& achieve even the most complex tasks instantly. Boost knowledge retention, software adoption & employee engagement with easy solution.

 

Author Comment

by:CenStates
ID: 24434256
no luck

G:\is a mapped drive.  I also tried using the UNC path \\maerchandsining\all\hed2000\hds_dta.mdb
Then I tried creating an ODBC connection. Connections all work, but when report is run, the same error.

Why does it run from Crystal standalone, but not from server?
0
 
LVL 38

Accepted Solution

by:
Jim P. earned 125 total points
ID: 24434502
What is the Log On As column of the Crystal Server service say? If LocalSystem right click --> Properties and change it to a different domain login id.
SQL-Server-Login-Properties.jpg
0
 
LVL 101

Expert Comment

by:mlmcc
ID: 24434928
When you changed to the UNC did you use the SET DATABASE LOCATION in the report?  The report maintains the original connection and will try to use it.

mlmcc
0
 

Author Comment

by:CenStates
ID: 24435825
Yes, I changed the data source in the report.

Error
The database logon information for this report is either incomplete or incorrect.

All non Access reports run fine on the CR Server over the network.
0
 
LVL 38

Assisted Solution

by:Jim P.
Jim P. earned 125 total points
ID: 24436478
>> The database logon information for this report is either incomplete or incorrect.

That was after you changed the id on the Crystal Reports Server service and restarted?

The reason that I ask, if you are using the Local System (LS) for the service, the LS id essentially can't see much outside of the box that it is running on. Even if you are logged in as a Domain Admin -- the LS and are restricted. It also doesn't see mapped drives.  So when CR Service is running it can't find the G: drive because that is tied to the user who is logged in. If it is LS then when it says to \\maerchandsining -- "Hey I'm \\ThisMachine\LSid"; \\maerchandsining says "who the heck is that and I'm not going to give you data."

We run into it all the time with various services.
0
 

Author Comment

by:CenStates
ID: 24440741
Changed logon for all CR services from "Local System" to "Administrator"  

IT WORKED!!!

Thank for all the help!
0
 
LVL 38

Expert Comment

by:Jim P.
ID: 24440842
Glad to be of assistance. May all your days get brighter and brighter.
0
 

Expert Comment

by:hongclub
ID: 34885551
How you changed logon for all CR services from "Local System" to "Administrator"

in my case, i am making a crystal report with excel as import resource ... but still ask me that stupid login, any suggestion?

tommy
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Describes a method of obtaining an object variable to an already running instance of Microsoft Access so that it can be controlled via automation.
You need to know the location of the Office templates folder, so that when you create new templates, they are saved to that location, and thus are available for selection when creating new documents.  The steps to find the Templates folder path are …
Show developers how to use a criteria form to limit the data that appears on an Access report. It is a common requirement that users can specify the criteria for a report at runtime. The easiest way to accomplish this is using a criteria form that a…
In Microsoft Access, learn the trick to repeating sub-report headings at the top of each page. The problem with sub-reports and headings: Add a dummy group to the sub report using the expression =1: Set the “Repeat Section” property of the dummy…

724 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question