Solved

Centos Instal Disks - Implant iso md5 from vista

Posted on 2009-05-20
13
1,239 Views
Last Modified: 2013-12-15
HI,

I downloaded the iso files from centos. I created the discs using a burner on my acer vista. I can successfully install the first disk but the other disks fail when tested and they are not recognized.

This page states something about implanting the md5 into the isos:
Finally, you'll need to implant the MD5 into the isos. Forgetting to do this could cause the ISOs to fail the media check, with an error saying "Unable to read the disc checksum from the primary volume descriptor".

http://wings.buffalo.edu/computing/ublinux/HOWTO-isos.php

That's great but I have a vista and I'm just trying to create a linux box. So how do I implant the md5 into the isos for the disks 2, 3, 4, 5, 6, 7?

Much thanks,
vkimura
0
Comment
Question by:Victor Kimura
  • 6
  • 4
  • 2
  • +1
13 Comments
 
LVL 5

Expert Comment

by:random_ru
Comment Utility
vikimura,

First you have to make sure the ISOs downloaded are in good shape - install Accuhash from http://www.accuhash.com/ (link at the bottom of the page) and compare it to md5sum.txt files located on the download servers (assuming you downloaded CentOS 5 i386: http://www.cyberuse.com/centos/5.3/isos/i386/)
- Try another CD-Rom drive if available
- Try burning another disk, and try that.
- Check the md5sum for the first ISO, if checks out - reburn it
- Reset the BIOS defaults
- Flash the BIOS
- Try the textmode install
- Try installing the most basic set of programs

That should get you started, let me know how that went and good luck!

***Forget about MD5 implantation, seems as the article talks about UBLinux, which sounds like the University of Buffalo distribution, with building procedures.
0
 

Author Comment

by:Victor Kimura
Comment Utility
Hi random_ru,

I checked the md5 and it matches.

I tried several disk 2s and none of them work. I don't have an extra cd rom. The media is a good brand "Imation" and I tried burning at a low rate 16x too.

All the disks when I check the media with linux mediacheck fail other than disk 1. It states:

"unable to read disk checksum from primary volume descriptor." and then the message states that the disk should be created with checksum. Which sounds like the problem of the buffalo.edu page is mentioning. I've goolged and others seem to have a similar problem and the resolution seems to be this implantmd5iso into the disk. But all of solutions (to implantmd5iso into the disk) are for linux systems. I have vista until I can install the centos.

Did you manage to successfully burn from a vista machine and then install linux from these cds? Was it really that simple?

I can try the text mode though because I haven't tried that. But for some reason I think it will fail because the disks (in graphical mode) stated "it was the incorrect disk" when I inserted disk 2. I tried several burns as mentioned.

Any suggestions?

I downloaded the netinstall and the mediacheck fails on this one too. I tried several burns of the netinstall.

I also downloaded the DVD one. I have to go buy some DVDs now. Should I be burning to DVD+R? random_ru, do you know if I need to do this implant md5 into the iso for the DVDs too? I know you said ignore it but I just want to make sure before I start creating more wasted disks and time.

Much thanks for your help,
vkimura
0
 
LVL 5

Expert Comment

by:random_ru
Comment Utility
You never really have to implant the md5sum unless it is a corrupted iso or burn... thus, you should have never really had this problem. Let me look into the issue real quick, but go ahead and try the dvd, depending on the speed of your download, I would also try redownloading the iso from another server.
0
 

Author Comment

by:Victor Kimura
Comment Utility
Hi random_ru,

Thank you for looking into this. Just fyi, I tried downloading disk 2 from another mirror. Same problem. I checked the md5 on this other mirror too for disk 2. It would be odd that it would be corrupted this many times though.

I'll let you know what happens with the dvd burn. I'm just going to pick up some dvd+r media now.

Thanks for you help,
vkimura
0
 
LVL 12

Expert Comment

by:rionroc
Comment Utility
Hello

The problem of your installation is the DISK 1, it is corrupted, that's why he keeps on messaging disk 2 error.

Download DISK 1 in good bytes shape, and if disk2 shape is good, then continue.


Cheers!
0
 
LVL 5

Expert Comment

by:random_ru
Comment Utility
Have you had a chance to try a DVD?
Also consider "- Check the md5sum for the first ISO, if checks out - reburn it" from the first post.
0
How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

 

Author Comment

by:Victor Kimura
Comment Utility
Hi randam_ru,

I purchased DVD+R media discs and I found out just now that the dvd iso is a bit larger than 4.7 GB so I need the DL discs. So I'm going to pick up some of those discs. I may have to purchase a new dvd optical drive to read the dl media. I have an older Acer DVP 1640A model dvd rom/cd rom drive. I tried looking for the specs to see if it will read the dl media. I couldn't find the info.

Anyway, I posted this to my centos question too on what I've tried thus far. I'm really confounded on why this is so difficult. Another person had this exact same problem (posted in 2006) which I mention below (http://www.techsupportforum.com/alternative-computing/linux-support/106029-how-make-cd-fedora-core-5-iso-images.html).

I'm thinking I should go purchase some but I have to wait for the discs and pay for them. I only have a few more options though. I'll be trying the dvd dl media. I pray this works. If not then I may end up purchasing the discs themselves. But if you think of something else then please let me know. I think this will help others too that my encounter this problem. Thanks for your support and help, random_ru.

I haven't tried setting up a virtual machine yet but I will if this is what I need to get centos installed. I tried two different download mirrors. I checked the md5 on both and they match on my vista machine. I first tried using Acer's burn tool and the first disk was fine. Installed without any problems. It's only the other disks that have this problem. When it asks for the second disk the centos error message is "Incorrect disk inserted" or something similar to this message. When I tested the disk 2, 3, 4, 5, 6, 7 using the linux mediacheck the message is "Unable to read disc checksum for primary volume descriptor." And then the message states that I should create a disc with checksums.

I then tried using daemon tools and copied the iso file to the virtual drive and then downloaded nero (trial) to copy that image. Same error.

I downloaded the dvd iso but the centos machine only has a dvd reader and I don't know if it will read dvd-dl media discs. This may be my last option other than create a virtual machine and check the checksums. However, I've already checked the md5 checksums on my vista laptop. So if ended creating a virtual machine to check the discs then I can't see why the results would be different.

I'm really at my wits end on this matter. I don't know why this is so difficult. I've wasted around 10 cds trying to download from different mirrors, tried the netinstall version and this fails too (same problem), copied the iso file to a virtual drive using daemon tools and then used nero, tried with acer's burning software (which worked only for disc 1 but not for rest of the discs).

Any other possible solutions?

I have this exact same problem as this other fellow:
http://www.techsupportforum.com/alternative-computing/linux-support/106029-how-make-cd-fedora-core-5-iso-images.html (posted back in 2006)

There was no reply to this post. I don't know why this is so difficult. It's so odd that I'm running into this one huge hurdle.

Any help is appreciated though,
vkimura
0
 

Author Comment

by:Victor Kimura
Comment Utility
I just intalled a new LG dvd rewriter in the linux box. I burned the dvd iso using nero as the minimum speed. I checksumed the md5 of the dvd iso on vista and it matched. I burned the dvd iso on some quality dvd media (verbatim).

I then proceeded to boot from with this new dvd dl media and the system hangs at "Boot from CD/DVD".

Thus far, I could only get the disc 1 to work and boot and install correctly. Every single other media is failing in the centos system. I'm thinking if it was hardware then why would the first cd disc 1 work and every other one fail. The media passes using md5 checksum on my vista laptop. I'm almost about to give up on centos and I've spent a bit of money just to try and resolve this. This should not be this difficult to install. I may just use fedora or some other linux brand and go with that. If anyone has a clue then please let me know.

Cordially,
vkimura
0
 
LVL 35

Expert Comment

by:torimar
Comment Utility
vkimura2007,

I do not know where you got your DVD iso from, but it must be a wrong one. You never have to use double-layer disks for bootable Linux media. The iso always fits a normal DVD.

Here's the links to the CentOS 5.3 DVDs:

32-bit (3,787 Mb): http://centos.weepee.org/5.3/isos/i386/CentOS-5.3-i386-bin-DVD.iso

64-bit (4,346 Mb): ftp://mirrors.kernel.org/centos/5.3/isos/x86_64/CentOS-5.3-x86_64-bin-DVD.iso

Unless you need to develop for 64bit computing, I suggest you download the first one.
0
 

Author Comment

by:Victor Kimura
Comment Utility
Hi torimar,

The dvd iso I downloaded was 4.45 GB so I can't see why the burning software was saying that it couldn't burn it on to a normal dvd. Please read my other post in response to your suggestions as I believe it has something to do with the iso file that seems to be burning along with the other files and folders when I burn the iso file. The snapshots show some single iso file that is burned as well but when I compare that to the virtual drive contents using daemon they don't match. The virtual drive only shows the contents and no single iso file.

So the questions now are:
What are the options that I should be selecting on nero?
What are the options that I should be selecting on imgburn? I'll download it and try it later.

Even though I installed ubuntu I may try and load centos via grub just to test it out.

Much thanks for your help, torimar.

vkimura
0
 
LVL 5

Assisted Solution

by:random_ru
random_ru earned 150 total points
Comment Utility
ImgBurn is a good one, I use it and I like it. Right when you run it, it will have a few large buttons, choose the one with write ISO to DVD or CD. It is pretty self-explanatory. I am just going off of my memory now...

I was just about to ask what you used to burn and your exact steps, however, go ahead and try ImgBurn and let us know what happened.
0
 
LVL 35

Accepted Solution

by:
torimar earned 350 total points
Comment Utility
vkimura,

I answered those two questions in your other thread.

Th fact that you did not burn the iso correctly as an image, but as data with additional files, will very well explain why it was too large for a normal DVD.

0
 

Author Closing Comment

by:Victor Kimura
Comment Utility
Thank you, random_ru and torimar.

Torimar, I thanked you in the other post but I really wanted to thank you because you were a really huge help.
0

Featured Post

Top 6 Sources for Identifying Threat Actor TTPs

Understanding your enemy is essential. These six sources will help you identify the most popular threat actor tactics, techniques, and procedures (TTPs).

Join & Write a Comment

This document is written for Red Hat Enterprise Linux AS release 4 and ORACLE 10g.  Earlier releases can be installed using this document as well however there are some additional steps for packages to be installed see Metalink. Disclaimer: I hav…
The purpose of this article is to demonstrate how we can use conditional statements using Python.
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now