Solved

Centos DVD install disk - How to create it in Vista

Posted on 2009-05-20
15
2,131 Views
Last Modified: 2013-12-15
Hi,

I downloaded the DVD install for Centos. I tried the CD ones and only CD disk 1 works. So I thought I may try the DVD one. Should I be purchasing DVD+R media rather than DVD-R?

How would I create this disk? Do I need to implant the md5 into the iso like I do with the CD-Rs? If so, how would I do this in Vista?

Any help is appreciated.

vkimura
0
Comment
Question by:Victor Kimura
15 Comments
 
LVL 40

Expert Comment

by:omarfarid
ID: 24434543
just get the dvd iso file and burn the dvd
0
 

Author Comment

by:Victor Kimura
ID: 24434708
Hi omarfarid,

Thanks for the quick reply. So I just want to make sure that I don't waste my time and a DVD+R media:

Do I need to implant a md5 into the iso to make it work?

This page states that an implant of an md5 into the iso is needed but it may only apply for CDs:
http://wings.buffalo.edu/computing/ublinux/HOWTO-isos.php

This is what he states:
Finally, you'll need to implant the MD5 into the isos. Forgetting to do this could cause the ISOs to fail the media check, with an error saying "Unable to read the disc checksum from the primary volume descriptor".

I had this problem with the CD disks 2,3,4,5,6 and 7. But disk 1 was fine for some reason.

I just want to make sure that I don't need this extra step for the single DVD that I burn.

The other question is should I be using DVD+R media?

Thanks,
vkimura
0
 
LVL 2

Expert Comment

by:AbdAlmumin
ID: 24446021
vkimura,

You don't need to add the MD5 to the disk to burn the DVD. I never did and have never had a problem. I just installed a few servers the other day. You best bet is to make sure that the .iso is without a problem by checking it in a VM (virtual machine) Use VirtualBox www.virtualbox.org or vmware. Create a virtual machine. Do a disk check and if there are no problems, burn it and rock on.
0
 
LVL 35

Expert Comment

by:torimar
ID: 24446091
There is never a need to implant a md5 *into* an iso file. That's not what they are there for. You use them for verifying the downloaded file before burning, but that is merely optional.
(What you have read in the source you quote counts only for the distro it was written for: UBLinux - the distro of the University of Buffalo, as it seems).

If you wish to check before burning, use one of those two tools:
www.quicksfv.org
www.md5summer.org

For burning, there is the free tool ImgBurn: www.imgburn.com. It supports Vista.

As for the media, I'm not sure whether +R or -R are better. I usually don't care. As long as they work fine for your burner and your system, any should be fine.
Just make sure they are no low-cost nonames, no rewritables, and also make sure you use a very low burning speed.
If it should not work at first attempt, try a different brand. This is nothing specific to CentOs: you need to find out anyway which media work flawless on your hardware setup.
0
 

Author Comment

by:Victor Kimura
ID: 24446881
Hi AbdAlmumin and torimar,

I haven't tried setting up a virtual machine yet but I will if this is what I need to get centos installed. I tried two different download mirrors. I checked the md5 on both and they match on my vista machine. I first tried using Acer's burn tool and the first disk was fine. Installed without any problems. It's only the other disks that have this problem. When it asks for the second disk the centos error message is "Incorrect disk inserted" or something similar to this message. When I tested the disk 2, 3, 4, 5, 6, 7 using the linux mediacheck the message is "Unable to read disc checksum for primary volume descriptor." And then the message states that I should create a disc with checksums.

I then tried using daemon tools and copied the iso file to the virtual drive and then downloaded nero (trial) to copy that image. Same error.

I downloaded the dvd iso but the centos machine only has a dvd reader and I don't know if it will read dvd-dl media discs. This may be my last option other than create a virtual machine and check the checksums. However, I've already checked the md5 checksums on my vista laptop. So if ended creating a virtual machine to check the discs then I can't see why the results would be different.

I'm really at my wits end on this matter. I don't know why this is so difficult. I've wasted around 10 cds trying to download from different mirrors, tried the netinstall version and this fails too (same problem), copied the iso file to a virtual drive using daemon tools and then used nero, tried with acer's burning software (which worked only for disc 1 but not for rest of the discs).

Any other possible solutions?

I have this exact same problem as this other fellow:
http://www.techsupportforum.com/alternative-computing/linux-support/106029-how-make-cd-fedora-core-5-iso-images.html (posted back in 2006)

There was no reply to this post. I don't know why this is so difficult. It's so odd that I'm running into this one huge hurdle.

Any help is appreciated though,
vkimura
0
 
LVL 35

Expert Comment

by:torimar
ID: 24446954
1. Try to install without using the "Test disk" option (it is optional anyway).
2. Try the DVD version
(If this is the first time you burn DVDs - or at least bootable DVDs - then you may have - in the worst of cases -  to buy and try a couple from different manufacturers)
3. Follow the steps I posted above.

Please report back if it still won't work after performing those steps.
0
 

Author Comment

by:Victor Kimura
ID: 24447063
Hi torimar,

I tried without testing the disc. But the error I received when centos asks for disc 2 is "Incorrect disc inserted" or some similar message.

Just fyi: The netinstall fails like the other discs and just hangs the computer when I try to boot from it. The checksum passes though for the netinstall disc on my vista. But when I tested it with the linux mediacheck if fails for the reason stated earlier "Unable to read disc checksum..."

I will be trying the dvd install. I'm going now to pick up a new dvd dl writer (as the old may not read dl discs) and some dl media discs.

I pray I won't have to purchase different media. What a process this is. I'll try to buy a good brand name of dvd dl media then. Will let you know though.

Thanks for your help, torimar, and everyone else.

vkimura

0
Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

 

Author Comment

by:Victor Kimura
ID: 24447412
I just intalled a new LG dvd rewriter in the linux box. I burned the dvd iso using nero as the minimum speed. I checksumed the md5 of the dvd iso on vista and it matched. I burned the dvd iso on some quality dvd media (verbatim).

I then proceeded to boot from with this new dvd dl media and the system hangs at "Boot from CD/DVD".

Thus far, I could only get the disc 1 to work and boot and install correctly. Every single other media is failing in the centos system. I'm thinking if it was hardware then why would the first cd disc 1 work and every other one fail. The media passes using md5 checksum on my vista laptop. I'm almost about to give up on centos and I've spent a bit of money just to try and resolve this. This should not be this difficult to install. I may just use fedora or some other linux brand and go with that. If anyone has a clue then please let me know.

Cordially,
vkimura
0
 
LVL 35

Expert Comment

by:torimar
ID: 24447565
Have you tried the CentOS Live CD yet?
You will find it here: http://mirrors.kernel.org/centos/5.2/isos/i386/CentOS-5.2-i386-LiveCD.iso

If it works, then you may be certain that CentOS has no conflicts of any kind with your system hardware. And, as far as I remember, there is also an option to install rightaway from the Live CD: just check the links presented on its desktop.
0
 
LVL 35

Expert Comment

by:torimar
ID: 24450668
Just a quickshot:

How did you burn the DVD? In Nero, did you select Recorder > Burn image, then point it to the iso file?

Iso files have to be burnt as images (that's why I suggested to use ImgBurn in my post above, because in Nero this feature is hidden), otherwise they will not be bootable.

You can check whether a bootable Linux disk is correctly burnt by opening it on any Windows system; if you see files and folders, it is correctly burnt, if you see only an iso file as contents, it is not.
0
 

Author Comment

by:Victor Kimura
ID: 24451298
Hi torimar,

I missed that point on using ImgBurn. However, Here is the snapshot of the contents of the dvd file:
http://tutorialref.com/images/centos-dvd-contents-iso.png

There is a folder and files; however, I see there is an iso file as well. Don't know if that's correct.

As for Nero, I didn't see an option for Recorder>Burn Image. Just an option for Data Burning. It seems to have correctly burned though viewing the snapshot above.
http://tutorialref.com/images/nero-data-burning.png

Oddly, I did notice that when I mounted the dvd iso file on to the virtual drive with the daemon tool the contents are different than the burnt dvd dl media:
http://tutorialref.com/images/dvd-iso-centos-virtual-drive.png

So perhaps this is the reason why disc 2 and the other discs are not reading properly. Even though I already installed ubuntu I wouldn't mind knowing how to install centos if I later on choose to install it via grub.

I'll try installing imgburn as you suggested; however, what is the option that I need to look for in Nero? What is the option I should look for in imgburn? The other thing to note is that when I burned the ubuntu iso file I used the exact same procedure as I did with burning the iso disc 2 and the dvd iso for centos. So why would the centos dvd burn "differently" than the ubuntu disc when both are the same file format?

Here is the snapshot of the file contents of the ubuntu disc:
http://tutorialref.com/images/ubuntu-iso-file-burned.png

vkimura


0
 
LVL 35

Accepted Solution

by:
torimar earned 500 total points
ID: 24451697
This is definitely not burnt correctly. You do not burn an image as data, and the contents of your DVD does not look like it should: it should look exactly like the mounted iso in Daemon Tools.

In ImgBurn, you need to select "Write Image to Disk".
In Nero, you need to switch to the "classical view"; it will look more or less like on the image attached. Unfortunately, I cannot tell you how to select this view.

I realize there is a "CentOS" folder on your Ubuntu disk as well. That for sure does not belong there.

ps:
You seem to have installed Ubuntu server edition. Are you sure this is what you wanted? Because it comes without a GUI and desktop, so for a beginner it is much harder to work with.
The Ubuntu version naming is somewhat misleading, but you ought to know that you can run all kinds of server software on the Ubuntu desktop as well without any problem.


nero1.gif
0
 

Author Comment

by:Victor Kimura
ID: 24451908
HI torimar,

I just successfully installed ubuntu server edition and realized that it doesn't come with the gui. LOL. Yes, I'd rather have the gui and so is there a way to upgrade with the desktop or should I download another version with the desktop version?

Here is the snapshot burning with imgburn using Write Img to Disc:
http://tutorialref.com/images/write-image-file-to-disc-imgburn.png

Here is content of the disc (disc 2 of 7) of centos:
http://tutorialref.com/images/centos-disc-2-imgburn.png

That looks correct - I think. No iso file lingering around.

I installed grub with ubuntu server so I assume it's possible to install ubuntu desktop and centos for testing. I'll post this question later though.
0
 
LVL 35

Expert Comment

by:torimar
ID: 24452053
You can add the GUI by typing:

sudo apt-get update
sudo apt-get install ubuntu-desktop


Since you are a beginner, I'd suggest, however, that you redownload and replace the Server by a normal Desktop version. I guess this will make it easier to solve further problems.

The snapshot of disk 2 seems to look correct indeed.
0
 

Author Closing Comment

by:Victor Kimura
ID: 31583625
Thanks so much for your help, torimar.

I posted another questions regarding multi-boot.
http://www.experts-exchange.com/OS/Linux/Q_24431531.html

Thank you very much for all your help!
0

Featured Post

IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

Join & Write a Comment

Little introduction about CP: CP is a command on linux that use to copy files and folder from one location to another location. Example usage of CP as follow: cp /myfoder /pathto/destination/folder/ cp abc.tar.gz /pathto/destination/folder/ab…
It’s 2016. Password authentication should be dead — or at least close to dying. But, unfortunately, it has not traversed Quagga stage yet. Using password authentication is like laundering hotel guest linens with a washboard — it’s Passé.
Learn how to navigate the file tree with the shell. Use pwd to print the current working directory: Use ls to list a directory's contents: Use cd to change to a new directory: Use wildcards instead of typing out long directory names: Use ../ to move…
Get a first impression of how PRTG looks and learn how it works.   This video is a short introduction to PRTG, as an initial overview or as a quick start for new PRTG users.

707 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now