Offline Files Synchronization - Best Practices

In the scenario below, we have all Server 2003 Standard servers in an Active Directory domain environment.  All users run XP Pro with at least SP2.

Each branch at our organization has a Server 2003 Standard Edition server that the users store their 'My Documents' on.  Each users' home directory is mapped to a drive letter (in our example, we'll use H:\), and that drive letter is the location that the 'My Documents' folder points to.  The laptop users have 'Offline Files' enabled, and the files sync when the user logs on and off the computer.  According to Microsoft KB275461 (http://support.microsoft.com/kb/275461), the best solution is to provide all users with at least READ access to the root directory of the users' shared folder (ie \\SERVER\USERS\).  However, if we do this, that means Joe Smith (a user with very little rights on the network) can read all the files located in Jane Doe's user directory (\\SERVER\USERS\JDOE\).  What is the best practices to use in order for each user to have a home directory located on \\SERVER\USERS\ that will allow laptop users to successfully sync their files as well as not let any other users access another user's files.

I hope I've explained myself well, and I apologize if I did not.

To summarize, we have a shared directory on the server called \\SERVER\USERS.  Each user has his/her own directory under that root directory.  Currently, we are experiencing issues with laptop users that are getting "Access Denied" error (as seen in Microsoft KB275461) and we need a solution without giving all users the access to read another user's files.

Thanks!
olinccuAsked:
Who is Participating?
 
DonConnect With a Mentor Network AdministratorCommented:
I believe that if you grant Read permissions on just the Parent folder, you'd then be ok.
accessbased.bmp
0
 
DonNetwork AdministratorCommented:
You should download, install and enable ABE(access based enumeration)
http://technet.microsoft.com/en-us/library/cc784710(WS.10).aspx
 
Then the users will only see their own folder and nobody elses
0
 
olinccuAuthor Commented:
That is definitely an awesome feature.  However, I do not believe that would fix my issue.  Following the KB article from Microsoft that says to give ALL USERS at least READ access to the root share folder, that would then give users access to read all files in that folder.  So that, to me, will not be solved by the ABE feature.  Even if it no longer listed the folder when they're browsing the network folders, they could still get to it via UNC, which is still a security risk that we cannot take.
0
Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
olinccuAuthor Commented:
So, to clarify, I would give READ access to all domain users on the root directory \\SERVER\USERS only.  Then, let's say I have a user named Jane Doe.  I would then make sure her permissions only give her (and appropriate administrative users) rights to her directory and the domain users would not be a part of her permissions.  Is that correct?  That definitely makes sense as far as keeping things secure.  Thanks for your input so far!
0
 
Don S.Commented:
Here are the MS recommended permissions that I have used extensively and work correctly:

Redirected Folders Parent:

Creator Owner = Full Control, Subfolders and Files Only
Domain Users = List Folder/Read Data, Create Folders/Append Data - This Folder Only
System =  Full Control, This Folder, Subfolders and Files
Admistrators =  Full Control, This Folder, Subfolders and Files
0
 
DonNetwork AdministratorCommented:
Yes, the way that it is set up here as shown above, users get access denied if trying to browse to other users folders.
0
 
olinccuAuthor Commented:
I was hoping this would be the solution (or something similar).  But posting the question and having responses (and proof) that solidifies the answer is why I'm glad I've joined EE.  Thanks!!
0
 
DonNetwork AdministratorCommented:
You're welcome!!!
 
And welcome to EE
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.