Solved

Why can't I connect my Outlook 2007 client to our Exchange 2007 server?

Posted on 2009-05-20
10
677 Views
Last Modified: 2012-05-07
I have an SBS 2008 server running Exchange 2007. I am trying to connect an Outlook 2007 client to it. I use this procedure:
1. Go to Control Panel - Mail
2. Click on "Add" to create a new profile and enter "Exchange" as the profile name.
3. The new E-mail Account box opens up and my information appears automatically. (The correct information is entered, I'm assuming, from the Exchange server?)
4. I click on next, which gives me the "configuring" screen. It establishes a network connection, searches for the server settings, then gives me a username/password box called "Connect to server.mydomain.local".  I enter my servername\username and password but it just pops up again.

Any ideas on why this error is occuring? I can access shares on the server and print from it's printers so I am definitely logged in. I was wondering if someone could explain exactly how Outlook 2007 connects to Exchange 2007. Is there something I need to explicitly configure? Does Outlook 2007 require SSL to connect to Exchange? Thank you in advance for any help!
0
Comment
Question by:knowprob
10 Comments
 
LVL 1

Expert Comment

by:preshomes
ID: 24435744
It may be an autodiscover issue. Instead of letting it autodiscover your settings try manually entering in your email server and user mailbox settings into outlook and see if you have the same issues that you are describing above
0
 
LVL 18

Expert Comment

by:flyingsky
ID: 24435754
don't use "servername\username", you should use "domain name\username"
0
 

Author Comment

by:knowprob
ID: 24435969
I tried to enter the settings manually but it still asked for my username and password.
I did not try to enter the credentials the way flyingsky suggested, I just rebooted my computer.
Once I logged back into the network, I made sure there were no profiles in Outlook. With no profiles created, I clicked on Outlook. It gave me the "Outlook 2007 Startup Wizard". I clicked on "Yes" to configure an e-mail account, then it automatically found my name and e-mail address. It went through configuring e-mail server settings, it did NOT prompt me for a UN/PW, but said it was successfully configured to use Microsoft Exchange. I clicked on Finish and it just hung at the Outlook 2007 splash screen. After about a minute or so, I get the username/password box again. No matter how I enter my un/pw, it does not take it and the box pops up again.
0
 
LVL 1

Expert Comment

by:preshomes
ID: 24436044
I would try removing the PC that you are on from the domain back to a workgroup, reboot the computer, and rejoin the computer to the domain and see if your problem persists.
0
 

Author Comment

by:knowprob
ID: 24436201
I just removed the PC from the domain, rebooted into a workgroup, rejoined the domain, tried again after the reboot and am getting the same "enter un/pw" message. If I end up clicking "cancel" on the un/pw box, it gives me an error saying "Cannot open your default e-mail folders. You must connect to Microsoft Exchange with the current profile before you can synchronize your folders with your offline folder file".

Do you know if maybe there is something on the server that needs configured for me to connect to Exchange using Outlook? I thought it was pretty automatic. Does it require SSL? And if so, doesn't Server create it's own self-signed certificate?
0
Control application downtime with dependency maps

Visualize the interdependencies between application components better with Applications Manager's automated application discovery and dependency mapping feature. Resolve performance issues faster by quickly isolating problematic components.

 
LVL 1

Expert Comment

by:preshomes
ID: 24436252
In Outlook  > File > Data File Mgmt
For your account choose settings and then then on the advanced tab uncheck the cached mode setting and then save , exit outlook, and reopen outlook.

What happens?
0
 

Author Comment

by:knowprob
ID: 24437688
I actually already disabled caching mode. No change in the error.
0
 
LVL 6

Expert Comment

by:ikshf143
ID: 24438402
Hi,

As yousaid you have an SBS 2008 server, I would say you disable the Kernal Mode Authentication on Autodiscover, EWS and OAB Virtual Directories. To do that do the following Go to Properties of the Virtual Directory-->Authentication-->Windows Authentication then click edit on the right hand side and uncheck the Kernal Mode Authentication. Then restart the IIS service.

Also you can try disabling the IPv6 from the Network Card and also commenting it out from the Host file.

-
Imran
0
 
LVL 1

Expert Comment

by:preshomes
ID: 24440040
You might also consider running the Microsoft Exchange Best Practices Analyzer found under Tools in the EMC and see if it might lead you to the reason why.
0
 

Accepted Solution

by:
knowprob earned 0 total points
ID: 24529565
I found the solution to this. It was a simple fix that I overlooked. The Windows Firewall was enabled in Group Policy on the server. I disabled it in the many places it is configured and everything passes through just fine now. Outlook clients can connect and e-mail is being received by the server. Thanks for all your help!
0

Featured Post

[Webinar] Disaster Recovery and Cloud Management

Learn from Unigma and CloudBerry industry veterans which providers are best for certain use cases and how to lower cloud costs, how to grow your Managed Services practice in IaaS clouds, and how to utilize public cloud for Disaster Recovery

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

We are happy to announce a brand new addition to our line of acclaimed email signature management products – CodeTwo Email Signatures for Office 365.
MS Outlook is a world-class email client application that is mainly used for e-communication globally.  In this article, we will discuss the basic idea about MS Outlook, its advanced features, and types of MS Outlook File formats.
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
This video discusses moving either the default database or any database to a new volume.

920 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

17 Experts available now in Live!

Get 1:1 Help Now