Can not SSH into a switch

I have a cisco 3750 switch that has SSH capabilities. SSH v1.99 is enabled. When I open SSH from my desktop, I get the password prompt. When I enter the user password, it does not accept it. I do not get an error message, it just will not connect.

I have used the enable password, the user password, and no password. I created a new user password and removed the service password encryption. when I removed the password encryption, the passwords did not show up any differently.  I made sure that the switch has a host  name and ip domain name. I made sure that the aaa new-model was on it. We are not using a radius server host, we are using local login. I have set the VTY line to privilege level 15 and transport input SSH. The crypto key (general purpose) has been generated.

Any and all help/Ideas appreciated
LVL 1
David-SGCAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

KevinCovertCommented:
With running crypto IOS you have to configure an domain-name for the switch:
ip domain-name yourdomain.tld

generate a rsa key:
crypto key generate rsa

enabling ssh version 2:
ip ssh version 2

add a local user :
username cisco privilege 15 password password

configure vty lines:
line vty 0 15
login local
transport input ssh

The above code will remove telnet access to your switch, which I recommend, the link below will show you how to keep telnet access.

source

http://supportwiki.cisco.com/ViewWiki/index.php/How_to_configure_SSH_(Secure_Shell)_on_Catalyst_switches
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
KevinCovertCommented:
I am using ssh v2, not v1.99, try that first.

What I typically do is make the above changes, then go in and add the users I want with the network assistant tool (I know I should use the CLI)

This has always worked for me.  But it sounds like if its not prompting you for a username it may not be using the 'login local' check that.

KMC
0
geek1000101Commented:
KevinCovert covered it very well the only thing i would add to  your configuration on the AAA part is:

aaa authentication login default local
aaa authentication enable default enable

This will make the AAA look to the local DB for AAA

Make sure you have an account created with priv 15  that way you can get to enable mode and so on.
0
David-SGCAuthor Commented:
I appologize for the length of time it has taken me to get back to this.  Some family issues have kept me away from work for awhile.  I know the issue was fixed, just not sure what the actual fix was.  I will consult with my co-worker and try to post/accept later today.

Thanks
0
David-SGCAuthor Commented:
Again sorry it took so long to get back on this.  Things have been really busy here for the past month.

Thanks again.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SSH / Telnet Software

From novice to tech pro — start learning today.