ultravnc failed to connect to server

I have just download and installed ULTRAvnc on my computer and a partner's computer. Mine is XP, his is Vista. We've pretty much left all default config settings. He is on a DSL cable modem, no router. I have a router on my DSL modem. I've determined his IP address by having him access a website where I can see the access log. He runs the server, I try to connect via the view.

I have verified that our respective firewalls permit this program and permit ports 5800 and 5900. Even so, I've tried shutting off the firewall on both ends. I've configure my route to forward port 5900 to my IP.

I get Failed to connect to server. Can any one give me a clue?
Who is Participating?
KevinCovertConnect With a Mentor Commented:
What does his IP start with 192.x.x.x 10.x.x.x 172.x.x.x?  A lot of ISPs are NATing their customers due to the cost and lack of need to have public IP addresses.  

Also, it is very unwise to have a PC on the internet (even NATed by the ISP) without a firewall (software or hardware, while I recommend hardware).

I would recommend hamachi, it is a free tool that you can install on both PC's create a secure connection between the two pc's (or more if you like) and then you can allow the ultraVNC traffic as you wish over the hamachi connection.  Hamachi does not need ports forwarded in you firewall, its pretty slick in my book.  Keep in mind that there will be some lag, just try it out, I think you'll see it suits your needs.



So, I would urge your friend to get a hardware firewall urgently

Hope that helps
jmarkfoleyAuthor Commented:
Well, I disabled the firewalls temporarily, just to test. They're back in place now. Our setups are just PC laptop connected from our home offices to  an ISP's router in my case, and DSL modem in his case.  I've set my router to port-forward 5900, but we can't that that on his end. Also, we're trying to get something set up for a trade show next week.

The thing is, the "public" IP on my end is the IP of the router/modem. My computer is on this side of the modem. The IP I see for him is also the IP of his modem. I don't know how to connect between the machines without port forwarding or a VPN.

I'll check out hamachi. Will the hamachi tool give me the "hostname", IP or whatever of the remote machine so I can connect?
Hamachi will give you a 5.x.x.x IP address once connected that you will use.  It will create a virtual network interface instead of the physical that you are currently using.

Hamachi is like a VPN, you will not need to setup port forwarding.

Remember to shut down unused open ports on your firewall after all this work.

jmarkfoleyAuthor Commented:
Hamachi did the trick. I connected fine and used UltraVNC, no problem (now I just have to speed things up a bit!)

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.