Year Delay after PC restart

I have a problem with some PCs and Laptops which are under Win XP Pro Service Pack 2, Everytime I Restart the Computer or logoff the year changes to 2007 or Somtimes 2006 but the date and time remain the same.
I Scanned the machines with my Symantec antivirus but can not find any Virus.

I also chekd CMOS battaries and they have no problem but the error still exists.
Event When i change the year in the setup and save,I faced the same problem.

P.S all the machines are connected to the same Network.
Thank in advance.
Who is Participating?
pln1146Connect With a Mentor Commented:
Check settings for NTP Client.  RUN  mgpedit.msc  Computer Configuration/Administrative Templates/System/Windows Time Service       These settings are disabled in a stand alone pc.  How they are setup depends on your particular NTP Client configuration.  
Are you certain that there are no settings so that when the computer is turned on it goes back to a saves state? Some computers such as library computers do this so as to avoid damage to computers.
Are the computers members of a domain, and are they synching their time with a network time server that has the wrong time?  What are they set to synch to?
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Hi there.

Check login scrips and startup applications.
Maybe someone had some strange ideas about changing year in system date at login.
Kamran ArshadIT AssociateCommented:

Usually HijackThis can help you with your system settings;

Then you can analyze the results using the below site;
mostabdoAuthor Commented:
Well...these computers are memebrs of a Domainmbut the DC dat and Time are correct and i can see this from the login screen but still the Windows date and time changes the Year !!!
 (Other computers also connected to the donain and not facing this problem !!).
I used HijackThis and everything was safe with no problem.
Kamran ArshadIT AssociateCommented:
Thanks for the update. Have you checked the startup items in the msconfig?
Open time and date properties right side of taskbar.  Click Internet Time.  Choose  Also check box to automtically syncronize with an internet time server.  
mostabdoAuthor Commented:
I checked the aratup there anything specific you want me to check about ?
You can see my startup items in the attached file.Waiting for your help

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.