Microsoft Exchange Server 2003 Active Sync .. Able to Send Mail, not able to Download Email

Hi Guys,

This is a peculiar problem. We are able to send email via mobile devices configured to use Microsoft ActiveSync but we are not able to download. when I do a manual syncronization from my CellPhone it successfully connects but doesn't download any email. This is happening to all users.
Nothing in the eventlog. ActivSync is working from browser, OMA is also working fine.

Any Clues ??
LVL 12
Hilal1924Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hilal1924Author Commented:
Just an Update:

We are Getting couple of intermittent 3005 EventIDs HTTP 503 errors.
Event Type:	Error
Event Source:	Server ActiveSync
Event Category:	None
Event ID:	3005
Date:		5/21/2009
Time:		4:18:57 AM
User:		xyz\abc
Computer:	EXCHANGE
Description:
Unexpected Exchange mailbox Server error: Server: [exchange.abc.com] User: [xyz@ac.com] HTTP status code: [503]. Verify that the Exchange mailbox Server is working correctly. 
 
For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Open in new window

0
shadowlesssCommented:
I use this site to help me solve problems with ActiveSync

https://www.testexchangeconnectivity.com/

0
Hilal1924Author Commented:
All Tests Came out OK
Test-Result.jpg
0
Making Bulk Changes to Active Directory

Watch this video to see how easy it is to make mass changes to Active Directory from an external text file without using complicated scripts.

shadowlesssCommented:
Did you check the box to "Synchronize All Items in Inbox folder"?
0
Hilal1924Author Commented:
Hmm Still No luck:

Items Syncronized =0, Estimate Messages =5,
Everything is ging fine, just the messges are not getting downloaded.

Test2.jpg
0
shadowlesssCommented:
I believe that the next step you should take is to recreate the activesync virtual directory.  Here is a link on how to accomplish this...

http://support.microsoft.com/?kbid=883380
0
Hilal1924Author Commented:
Nothing even after recreatingthe VD's. But one interesting thing happened- I rebooted the server and mail got downloaded to the cellphone immediately. But after than I couldn't download the mail again. So it worked only when I rebooted. Now it is not working again.
0
Hilal1924Author Commented:
Just some more Info: I justnticed Couple of 3033 event ID warnings in he evetviewer.
0
shadowlesssCommented:
Check to make sure have correct settings for ActveSync


Note The virtual directories that are used by ActiveSync may still have incorrect settings even after you have recreated the virtual directories.

To make sure that the virtual directory settings are correct, follow these steps:
Start the Internet Information Services (IIS) Microsoft Management Server (MMS) snap-in on the Windows SBS 2003-based computer.
Expand Server_Name\Web Sites\Default Web Site.
Right-click Exchange-OMA, and then follow these steps:
Verify the following settings on the Virtual Directory tab:
The following check boxes are selected:
Script source access
Read
Write
Directory browsing
Log visits
Index this resource
Application name is unavailable, and Default Application is listed.
The Execute permissions setting is None.
The Application pool setting is unavailable, and ExchangeApplicationPool is listed.
Verify the following settings on the Directory Security tab:
The Enable anonymous access check box is not selected.
The Integrated Windows authentication check box is selected.
The Basic authentication check box is selected.
The Require secure channel (SSL) check box is not selected.
Close the Exchange-OMA Properties dialog box.
Right-click OMA, and then follow these steps:
Verify the following settings on the Virtual Directory tab:
The following check boxes are selected:
Read
Log visits
Index this resource
The Application name setting is /LM/W3SVC/1/root/OMA.
The Execute permissions setting is Scripts only.
The Application pool setting is ExchangeMobileBrowseApplicationPool.
Verify the following settings on the Directory Security tab:
The Enable anonymous access check box is not selected.
The Integrated Windows authentication check box is not selected.
The Basic authentication check box is selected.
The Require secure channel (SSL) check box is not selected.
Close the OMA Properties dialog box.
Right-click Microsoft-Server-ActiveSync, and then follow these steps:
Verify the following settings on the Virtual Directory tab:
The following check boxes are selected:
Log visits
Index this resource
The Application name setting is /LM/W3SVC/1/root/Microsoft-Server-ActiveSync.
The Execute permissions setting is Scripts and Executables.
The Application pool setting is ExchangeApplicationPool.
Verify the following settings on the Directory Security tab:
The Enable anonymous access check box is not selected.
The Integrated Windows authentication check box is not selected.
The Basic authentication check box is selected.
The Require secure channel (SSL) check box is not selected.
Run the iisreset /noforce computer_name command to restart IIS on the Windows SBS 2003-based computer.

Reference - http://support.microsoft.com/default.aspx?scid=kb;en-us;937635
0
Hilal1924Author Commented:
Already followed that thing
0
Hilal1924Author Commented:
And it didn't work
0
shadowlesssCommented:
Read the article  (Troubleshooting Exchange ActiveSync
A free tool and these tips can help solve Exchange 2003 mobile messaging problems ) and use the tool to see if you can find the answer to your issue.

http://windowsitpro.com/article/articleid/99421/troubleshooting-exchange-activesync.html

AUTDTroubleShooter Download - http://www.microsoft.com/downloads/details.aspx?familyid=7718A338-A9F5-43D6-9E20-141189283C82&displaylang=en
0
Hilal1924Author Commented:
Hi Shadowless,

It was kind of hard to figure out but I finally found it out :)

The /OMA directory was using .Net Framework 2.0 instead of 1.1, Once I rectified it and restarted System Attendant Service all was Cool .

Thanks for staying with me on this one. btw I am level 6 certified Exchange Server Professional, but could not figure it out initially.

Hilal
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Hilal1924Author Commented:
Well All is well now that I figured it out :)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.