Pix 501 VPN Can't See Traffic between Sites

Posted on 2009-05-21
Medium Priority
Last Modified: 2012-05-07
I have a Pix 501 at a Remote Site connecting through a Sonicwall 3060 at the corp site. I have around 50 different sites and all are configured for the most part the same. I've compared this one to a few of my other sites and there is no difference except I can't get traffic to pass through the VPN Tunnel.

From the Pix, I can ping anything on its local network. I can ping the outside address of the pix. I can ping the Modem Gateway (xx.xx.xx.57) and I can ping the external address of Sonicwall (yy.yyy.yy.74) but I can't ping or get to anything on network.

I've got to be missing something extremely obvious. Maybe another pair of eyes will be able to spot the problem.
PIX Version 6.3(4)
interface ethernet0 100full
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxxxxxxxxxxxxxx encrypted
passwd xxxxxxxxxxxxx encrypted
hostname pixfirewall30
domain-name xxxxxxxxxx.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
access-list pixtosnwl permit ip
access-list NONAT permit ip
pager lines 150
logging on
icmp permit any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside xx.xxx.xx.58
ip address inside
ip audit info action alarm
ip audit attack action alarm
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list NONAT
nat (inside) 1 0 0
route outside xx.xxx.xx.57 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set strong esp-3des esp-sha-hmac
crypto map tosnwl 20 ipsec-isakmp
crypto map tosnwl 20 match address pixtosnwl
crypto map tosnwl 20 set peer yy.yyy.yy.74
crypto map tosnwl 20 set transform-set strong
crypto map tosnwl interface outside
isakmp enable outside
isakmp key ******** address yy.yyy.yy.74 netmask no-xauth no-config-mode
isakmp identity address
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash sha
isakmp policy 20 group 2
isakmp policy 20 lifetime 28400
telnet inside
telnet timeout 5
ssh outside
ssh yy.yyy.yy.74 outside
ssh timeout 5
management-access inside
console timeout 0
terminal width 200

Open in new window

Question by:RidcoDoIT
LVL 30

Expert Comment

by:Britt Thompson
ID: 24442380
The only difference I can see between your site-site and mine is the "map"...mine are as follows. It may be irrelevant.

crypto dynamic-map tosnwl 20 match address pixtosnwl
crypto dynamic-map tosnwl 20 set transform-set ESP-3DES-MD5

Accepted Solution

RidcoDoIT earned 0 total points
ID: 24442587
I don't know what happened but I changed the Network Object for this connection from LAN to VPN Type on my SonicWall and lost my connection to the outside address of the PIX. I changed it back to LAN and that connection along with the internal connection started working.

Strange. Thanks for your help though renazonse.

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

There are two basic ways to configure a static route for Cisco IOS devices. I've written this article to highlight a case study comparing the configuration of a static route using the next-hop IP and the configuration of a static route using an outg…
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

621 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question