Cisco 1841 load balance

Hi,

I am trying to configure load balancing across to adsl on a 1841 router, I have attached my current config as it stands,

The problem I have is with the natting, I can only add one entry at a time
 ip nat inside source list 100 interface Dialer0 overload

when i add the 2nd the 1st one vanishes from the config,

I think the way forward it route maps but they always confuse me can anyone help

version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname xxx
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
enable secret xxx
!
no aaa new-model
dot11 syslog
ip source-route
!
!
!
!
ip cef
ip inspect name firewall tcp
ip inspect name firewall udp
ip inspect name firewall icmp
no ipv6 cef
!
multilink bundle-name authenticated
!
!
archive
 log config
  hidekeys
!
interface FastEthernet0/0
 ip address xxx xxx
 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface ATM0/0/0
 no ip address
 no ip mroute-cache
 no atm ilmi-keepalive
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface ATM0/1/0
 no ip address
 no ip mroute-cache
 no atm ilmi-keepalive
 pvc 0/38
  encapsulation aal5mux ppp dialer
  dialer pool-member 2
 !
!
interface Dialer0
 ip address xxx xxx
 ip access-group 101 in
 ip nat outside
 ip inspect firewall out
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname xxx
 ppp chap password xxx
!
interface Dialer1
 ip address xxx xxx
 ip access-group 101 in
 ip nat outside
 ip inspect firewall out
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 2
 dialer-group 1
 ppp authentication chap callin
 ppp chap hostname xxx
 ppp chap password xxx
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0 200
ip route 0.0.0.0 0.0.0.0 Dialer1 200
no ip http server
no ip http secure-server
!
!
ip nat inside source list 100 interface Dialer1 overload
!
access-list 100 permit ip 192.168.1.0 0.0.0.255 any
dialer-list 1 protocol ip permit
!

Open in new window

webleyaxsorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

JFrederick29Commented:
Add this config to NAT based on which "outside" interface is being used.

conf t
route-map isp1 permit 10
 match ip address 100
 match interface Dialer0

route-map isp2 permit 10
 match ip address 100
 match interface Dialer1

no ip nat inside source list 100 interface Dialer1 overload
ip nat inside source route-map isp1 interface Dialer0 overload
ip nat inside source route-map isp2 interface Dialer1 overload
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
webleyaxsorAuthor Commented:
Thankyou , worked a treat,
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Routers

From novice to tech pro — start learning today.