server not finishing bootup

Hi all

my server has problems. Garygutri was helping me with it. The server boots up normally asking me to login. After logging in, nothing loads. The screen is blue, no taskbar, nothing but a blank windows background blue.

I can access the taskbar, launch stuff through running them. Explorer.exe is launched, so why isn't my desktop showing? I can't get my IIS services up. I left it as is for now since most critical applications are running. I have to work on this this evening, please help. Suggestions on what to do?

the attacherd picture shows a new message I get as it boots up to the ctrl alt delete screen.

smex.exe is trend micro related. We have a mail scan program so I think that's what it's for.

The gdiplus.dll is the file that windows update requires!!

The cause of these problems is somehow related to SP 2 update. SP2 wasn't fully installed the last time I attempted it. I manually downloaded SP2 so that i could install it. I wanted to run a system backup to get the latest system state, etc... backup utility wouldn't load. So I restarted the machine and now this is where I'm at...
smex.jpg
sonic1394Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MatheusMCommented:
SMEX_Master belongs to Trend Micro Messaging Security Agent.  If you can log into your machine, you can either uninstall or disable the messaging security agent and see if that solves the boot error.  If it does, a reinstall of the Messaging Security Agent should solve the issue permanently.
0
sonic1394Author Commented:
I think a  large chunk of data is corrupt. Aside from the micro trend error, the event log shows MSExchange MU and MSexchangeSA errors. What would the best practice protocol be? Obviously I wanted to backup the system because I know there are errors. Should I be considering moving the entire server onto another set of hard drives? I'm sure there are corrupt sectors, which could also be causing this havoc.
0
MatheusMCommented:
Are you able to log into your server and make a manual backup of the server files and system state?  If you are able to do that, start there.  If not, can you please explain what problem is preventing you from doing so?  After you've backed up your files, you can try to use the system file checker utility to get your system files working.

Try from the command line SFC /SCANNOW

Using that may (probably will) require you to insert your server 2003 install media so that it can replace any corrupted or invalid system files with the files used when you installed the server initially.  
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

sonic1394Author Commented:
I don't have the actual 2003 server cd that was used to install. This is a MPC netframe server. We have about 5 of them. Does it have to be the exact same disc?? I have a 2003 server disc from MPC, but I'm not certain it's the same version, SP, install that was used for this machine.

It's currently reallly slow. Takes 5 min for my computer to show up. Even with task manager open. The only semi weird process is the stwatchdog.exe Almost sounds like something is running without taskmgr noticing, the cpu usage doesn't even reach 50%

I tried launching backup utility twice, didn't launch. I tracked any change in task mgr.. nothing new running. tskmgr images are attached, notice anything weird anybody??

I researched it and it looks like it belongs to the microtrend program.


IMG00223.jpg
image001.jpg
0
sonic1394Author Commented:
This is the 1st half of the tskmgr screen, the 2nd half is above.
fff.jpeg
0
sonic1394Author Commented:
Another thought:

The gdiplus.dll is required for many prgms to run properly. Anyone know if backup utility requires that file? I've been having prblms with tht file. I believe that's the file that didn't allow my windows update automation to work. Thus I manually downloaded the sp2 file.

Should I try installing the SP2 file? maybe it will install the missing dll and correct any registry files associated with it?

OR

should I run the scannow cmd try to use that MPC recovery disc mentioned, and then run SP2 updates...

Eitherway.... I should first run a scandisk from bootup right? checking both file system integrity and physical sector errors? I've been lagging that because as it is, it takes 20 min for server to boot, adding another 20 min to scan is too much downtime for a primary DC.
0
MatheusMCommented:
I would run the SFC command with the /SCANNOW switch using the MPC recovery disk since that should fix the issue with the missing DLL.  
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sonic1394Author Commented:
btw manual backup doesn't look possible neither.. i tried ntbackup and it's either taking forever to launch or it's not going to load...

WHat is weird is that I think it's taking forever to launch, because an 2hrs later after I posted my initial inquiry about the blue screen, the desktop appears...

weird?? Raid is setup on this server... I have no experience with manipulating it, but I will read up on that... do you think maybe 1 disk is messed up? and the other fixes the prblms mentioned, thus making the system really slow?? or is the slow factor related to the messed up dll

this is the 1st time this server gets the missing dll, and the 1st time it doesn't respond right away... t's worrying me, because if it's hard disk failure, I need to be ready.
0
sonic1394Author Commented:
I ran the scan now function... 2 times.. did not repair the gdiplus.dll file that is missing or corrupt..


AND I can't run the SP,!!!! sounds like I have a virus...

I can't run EXEs

this is the error it gives me when trying to run The Microsoft Windows Malicious Software Removal Tool.

and any windows update file.
IMG00225.jpg
0
sonic1394Author Commented:
The gdiplus.dll was on the server, but it wasn't in the windows folder... so I copied it there, then registered it.. got rid of the gdiplus error...

I still have prblms.. MANY.. and I don't know if the cause is MALWARE or RAID degradation.. PLEASE help.. More info on these questions.. Help me fix this and you'll have solved basically 3 questions.

Thanks in advance

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_24434718.html

http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/Q_24444048.html
0
sonic1394Author Commented:
the scannow command worked to an extent.. The server was still missing required dlls..

I moved them to the system 32 folder and registered them..

no more dll errors.. however the current situation is that windows will not let me run exe's.. so I'm screwed in terms of installing anything.. Don't know what to do.. I opened new questions regarding this.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Legacy OS

From novice to tech pro — start learning today.