Cisco 2811 HWIC-AP not connecting

Hello,
i have a test 2811 with an installed HWIC-AP. ihave tried everything and cannot seem to connect or even find the ap from a laptop that i use regularly to connect to other ap's. not sure what i am missing in the configuration, i dont even see the ssid when i search for the ap. you will see in the config ive thrown just about everything at it and still nothing.

Current configuration : 3754 bytes
!
version 12.4
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 2811
!
boot-start-marker
boot system flash c2800nm-adventerprisek9-mz.124-20.YA3.bin
boot-end-marker
!
logging message-counter syslog
no logging buffered
enable secret 5 xxxxxxx
enable password xxxxxx
!
no aaa new-model
!
dot11 syslog
!
dot11 ssid TEST_E
   authentication open
   guest-mode
!
dot11 ssid visitor
   mbssid guest-mode
!
ip source-route
no ip routing
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
no ip cef
ip dhcp excluded-address 10.0.0.1 10.0.0.39
ip dhcp excluded-address 10.0.0.51 10.0.0.254
!
ip dhcp pool 2811_TEST
   import all
   network 10.0.0.0 255.255.255.0
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
voice dsp waitstate 0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
 no dspfarm
!
!
crypto pki trustpoint TP-self-signed-2419415777
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2419415777
 revocation-check none
 rsakeypair TP-self-signed-2419415777
!
!
crypto pki certificate chain TP-self-signed-2419415777
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
  69666963 6174652D 32343139 34313537 3737301E 170D3039 30353231 31353438
  31325A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 34313934
  31353737 3730819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
  8100B349 84619E15 EDA47B83 29F45268 BA47F601 E7975CF7 3DC714C2 1AF85BCC
  2CF2DA70 3B6FA381 6401E66F 85475508 4E69B6B4 82CD764B 8328EB1F 8D63A733
  7E0009D2 138DDA82 CE381BE6 038B67E9 35180AD6 3A6E28CF E630B66E 8D499899
  A2E700F6 7B587958 FADF8A6A FEBB33B4 5EBC87CF BB46A9B0 ACA47301 0452F648
  CFF70203 010001A3 64306230 0F060355 1D130101 FF040530 030101FF 300F0603
  551D1104 08300682 04323831 31301F06 03551D23 04183016 8014885A AA2EA271
  1D44F41C 0BFB2042 B20943CE B21E301D 0603551D 0E041604 14885AAA 2EA2711D
  44F41C0B FB2042B2 0943CEB2 1E300D06 092A8648 86F70D01 01040500 03818100
  72597A41 4A849788 3FC5B079 8909BE67 0CBBD6F5 D0F370D3 182C3B6B 62B0B359
  59E2D964 60CD8916 179A03C6 AF30BE0C CCCA7CBA 51AFA32D 4E3333AC E5C301D7
  5490AFA4 F58B9E74 39696238 34A8F7CA 6E58BF70 983A995B 70E0B11B 2E196827
  E7EE4C04 608F9A2A ECB9A112 AD91C743 A4D79102 89B75E8E 13B01C07 08629911
        quit
!
!
vtp mode client
username xxxxx privilege 15 password 0 xxxxx
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description ETHER0/1
 ip address 10.1.0.2 255.255.255.0
 no ip route-cache
 duplex full
 speed auto
 no cdp enable
 no mop enabled
!
interface FastEthernet0/1
 description ETHER0/1
 ip address 10.0.0.20 255.255.255.0
 no ip route-cache
 duplex auto
 speed auto
 no cdp enable
!
interface Serial0/0/0
 no ip address
 no ip route-cache
 shutdown
 no fair-queue
!
interface Dot11Radio0/2/0
 description ****testing****
 no ip address
 no ip route-cache
 !
 ssid TEST_E
 !
 ssid visitor
 !
 mbssid
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
 54.0
 no preamble-short
 station-role root
 antenna gain 128
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
ccm-manager fax protocol cisco
!
mgcp fax t38 ecm
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 privilege level 15
 password xxxx
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
no process cpu extended
no process cpu autoprofile hog
end
 
2811#

Open in new window

davidummelAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BBRazzCommented:
Try adding the following to see if your SSID gets announced.

-BBRazz

ssid TEST_E
authentication open
guest-mode

Open in new window

0
davidummelAuthor Commented:
I have loaded a new IOS with the T designator ( read elsewhere that this was a requirement for the AP, not sure if this is true but now it responds) I have created a new configuration {shown below} and i can see the ap on the laptop and connect with 'limited' capabilities. i done recieve much from the ap. my goal is to use this ap on the router to connect with the test bench network (on ethernet 0/0/ and 0/1).
so right now i can seem to connect to the ap but not pass thru the router.
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 2811
!
boot-start-marker
boot system flash c2800nm-adventerprisek9-mz.124-22.T1.bin
boot-end-marker
!
logging message-counter syslog
enable secret 5 $1$wHp4$qpCfzUUxxxxxv7iZritDU1
enable password xxxx
!
no aaa new-model
!
dot11 syslog
!
dot11 ssid TEST_E
   authentication open
   guest-mode
!
no ip cef
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
!
!
!
!
username xxxxxx privilege 15 password 0 xxxxxx
archive
 log config
  hidekeys
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 description ETHER0/1
 ip address 10.1.0.2 255.255.255.0
 no ip route-cache
 duplex auto
 speed auto
 no cdp enable
 no mop enabled
 no shut
!
interface FastEthernet0/1
 ip address 10.0.0.20 255.255.255.0
 no ip route-cache
 duplex auto
 speed auto
 no mop enabled
 no shut
!
interface Serial0/0/0
 no ip address
 no ip route-cache
 no shutdown
 no fair-queue
!
interface Dot11Radio0/2/0
 no ip address
 no ip route-cache
 no shutdown
 !
 ssid TEST_E
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
 54.0
 no preamble-short
 station-role root
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
!
!
!
!
!
!
!
!
control-plane
!
!
!
ccm-manager fax protocol cisco
!
mgcp fax t38 ecm
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 privilege level 15
 password xxxxx
 login local
 transport input telnet ssh
!
scheduler allocate 20000 1000
end

Open in new window

0
BBRazzCommented:
Then you'll need to configure a Bridge Interface "BVI" and attach the Eth Interfaces and the Radio interface to it to bind them all.

Then, run DHCP on that Bridge

-BBRazz
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Wireless Networking

From novice to tech pro — start learning today.