Lag when RDPing to new (2008) Server on an Esx Server

I've just set up a brand new Windows Server 2008 Std server on our esxServer and have found that when I RDP into it, I am experiencing really bad lag.  It works fine from the Console, in fact I can take over the RDP session from the Console in the Infrastrusture client and the lag disappears.
I've installed the VMWare tools - and having done some research - the VMWare drivers don't seem to be coming through to the RDP session.  For example, in the console - it uses a VMWare display adapter, but in the RDP it isn't.

I've tried RDPing from Vista and from Server 2003 and using 6.0 and 5.0 RDP programs - both are experiencing the same lag.

What am I missing?
bosshognzAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

vmwarun - ArunCommented:
What is the base NIC which you are using ? (Fast Ethernet or Gigabit Ethernet)
0
CuteadderCommented:
how's the network connection to the esx server? probably at least a gig but are there any other servers eating it up? how are other resources on the esx server?
0
bosshognzAuthor Commented:
It says its connecting at 1GB on the 2008 server - am a bit dubious about that though - as the BGINFO script we run on startup reports back about 7-8 'NIC' speeds, all are at 1GB except for one which is 0GB.  
The ESX box has 7 virtual servers spread over 4 NICs and there are no issues of any kind of lag with other servers on it.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

larstrCommented:
Make sure you disable STP (spanning tree protocol) on the physical switch ports where the ESX nics are connected. STP is enabled by default on many switches and will cause slow networking for your VMs.

Lars
0
davismisbehavisCommented:
Check that your ESX NICS are set to the same speed as your Network Switch,  if it's auto detect on the switch make sure it's autodetect on the host,  same for 1GB Full, 1GB Half, etc

Check that the Hardware acceleration within the display settings -> advanced - > troubleshoot is set to full as this can also cause massive amounts of lag.

It definately sounds like a VMware tools issue though,  re-install until you are getting VMware tools coming through on the system tray within the RDP session.
0
bosshognzAuthor Commented:
larstr and davidmisbehavis - would these not cause speed problems with other virtual servers on the same box?  There are no issues at all with any of the other other servers whether they're on the same ESX box, or on the other ESX box we have, nor with any of the physical servers.

What I didn't mention is that they're all Windows 2003 servers, and this new one I've created is the only 2008 one on the domain.

VMWare Tools are showing up in the task bar both on the console window, and via RDP.  
0
larstrCommented:
If you have no problems on the other VMs and this is the only w2k8 server, I suspect that the problem is related to the change in the ip stack in 2008. What is the client os you're connecting from?

Does it make any difference if you disable TCP Chimney Offload?
netsh int tcp set global chimney=enabled  

Lars
0
bosshognzAuthor Commented:
As I said in the initial message, I've tried connecting off my Vista Business laptop and also from the other 2003 servers.  

Yesterday arvo I got sick of it and totally rebuilt the server.  I'm installing everything one by one, and so far I don't have the lag issues.  Still have Windows updates to do - which I'm going to start on this morning - going through one by one.  It was my initial thought that it was the updates that caused it, but then I had only started RDPing to it after that point also.
0
bosshognzAuthor Commented:
OK.  I spoke too soon.  I started up the server this morning and its been running like a dog ever since.  CPU and Memory performance are low (5-25% CPU, and about 500MB of 2GB of RAM), but its back to being as laggy as it can get.

I tried: netsh int tcp set global chimney=enabled  - made no difference.
I set Hardware Acceleration to Full and then tried None - neither worked.

Am trying to find an updated network driver - I set it up as an E1000 NIC during setup, so the driver is for an Intel(R) Pro/1000 MT Network Connection.
0
larstrCommented:
What version (build #) was this esx system at when you installed the guest? After installing VMware Tools you should get an accelerated virtual nic inside your guest instead of the e1000 nic.

Lars
0
bosshognzAuthor Commented:
3.5.0, b 110268
In the console I see the VMTools NIC, but in the RDP session I see the Intel one.  Have just had a look on one of the other servers (2003) on this box and see the accelerated virtual one.
0
larstrCommented:
Your ESX version is a tad old, so you wouldn't get the accelerated nic per default. I would recommend you to patch your ESX server to U4. Also see here: http://ict-freak.nl/2009/04/01/vmware-adding-the-enhanced-vmxnet-vnic/

The performance of the accelerated nic is better, and the cpu cost for network traffic is less when using it.


Lars
0
bosshognzAuthor Commented:
You say you don't get it by default, but is there a way to get it otherwise without patching to U4?  Is it one of the other choices you can make other than the E1000?
0
larstrCommented:
If you don't want to upgrade to U4 you can use this workaround:
http://kb.vmware.com/kb/1007195

I would still suggest that you patch your system as build 110k is starting to get fairly old now and there have been many improvements since that version.

Lars
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bosshognzAuthor Commented:
Hi,

Thanks for the instructions, its a pity I didn't wait for your answer before removing it and starting again!  I actually selected the vmx adapter last night instead of E1000 to see if it would make any difference.  So, we'll see once I start installing everything again today.

Will take your advice on patching the esx server, we outsource the management of the esx box, so will pass that on to them.  Thanks.
0
bosshognzAuthor Commented:
Changing the NIC from E1000 to vmxnet during setup fixed the problem.  While it doesn't show up as a 'VM Accelerated NIC adapter' like the W2003 servers, it doesn't have the same lag issues it did using the E1000 settings.
0
bosshognzAuthor Commented:
Servers all patched up and running happily now.  Restarted it after the long weekend and its happily plodding along, thanks!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VMware

From novice to tech pro — start learning today.