Remote Desktop/Terminal Services Not Accepting Requests

Hi all,

Having an issue on my network where the XP clients are NOT accepting the connection. As soon as I try to connect to a remote XP PC, I get a pop up box stating "The computer can't connect to the remote computer. Try connecting again. If the problem continues, contact the owner of the remote computer or your network administrator".

I've verified that HKLM\SYSTEM\CurrentControlSet\Control\Terminal Server\fDenyTSConnections is set to 0 (which means RDP is enabled).

I've verified that the Windows firewall is allowing RDP through, and there are no other firewalls on the machine.

Your thoughts/help is appreciated, thanks!

Is there any type of logs or debugging I can check/turn on to see what's going on?
experthelpneededAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

johnny_the_knifeCommented:
Does the user attemting to connect have permision to do so?  You need to set this in the Remote tab of the system properties window (Right click My Computer, select Propoerties)
0
experthelpneededAuthor Commented:
Yes - the user has permissions. Even if the user did not have permissions, you would still get the login screen of the PC opening up, and then it would provide a different error asking for a different set of credentials that has permissions. I am not even getting that far.
0
snusgubbenCommented:
Check if the RDP listener is listening on TCP 3389 on the XP machines:

From your computer's cmd:

telnet <IP_of_XP> 3389

Is it listening av accepting connections on that port? (the cmd window should all turn black)


SG
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

experthelpneededAuthor Commented:
Good test - it is not. I've tested it against a working RDP machine and I do get the black screen. I wonder why it's not listening, even though the registry, as well as the GUI interface says its open. I've even verified the Windows Firewall has the proper port open as welll.

Thank you for your help.
0
snusgubbenCommented:
Can you run the same test on the XP machine you are trying to connect to? (just to make sure it ain't no firewall rules stopping this)

SG
0
experthelpneededAuthor Commented:
Sorry - I meant to say I tried it on a working, and non-working machine. The non-working machine just sitts there and errors out with Telnet, where as the working machine goes to the black screen.
0
snusgubbenCommented:
Did you run these tests on the local host?

Do you have tsadmin (terminal server management consol) installed on the XP machines?


SG
0
experthelpneededAuthor Commented:
yes - I've tried the test to a machine that has RDP enabled and working. I've also tried the test on the machine I'm having problems with. I do not have TSAdmin installed on the XP machiens - is that different from the "Enable Remote Desktop" option?
0
snusgubbenCommented:
It's a MMC where you can control the RDP listener. It's not the same as "Enable Remote Desktop".

If I remember correct you can download the admin pack tool from Microsoft that contain the tsadmin tool.

http://www.microsoft.com/downloadS/details.aspx?FamilyID=c16ae515-c8f4-47ef-a1e4-a8dcbacff8e3&displaylang=en

SG
0
experthelpneededAuthor Commented:
Ok - the problem was apparently Kaspersky has a built in firewall, even though the package was just Kaspersky Anti-Virus 6.0 .....  

So the solution was you had to add a new "zone" in the Anti-Hacker section of the settings to allow the VPN subnet to talk to the LAN subnet.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
snusgubbenCommented:
In comment ID:24451264 I asked him to make sure no FW rules was stopping this. The solution to his problem was a blocking FW... I don't see why my answer should not be accepted.

SG
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.