Cannot access USB drive on Vista

I have a 2GB USB drive that was formated on a Mac. I now want to reformat on 64 bit Vista. The drive does NOT appear when I open up the computer. The drive does appear in Disk Management without a letter. When I try to assign a letter to the drive I get a pop-up that says "The operation failed to complete because the console view is not up-to-date. Refresh the view by using the refresh task. If the problem persists close the Disk Management console, then restart DIsk Management or restart the computer." I've rebooted to no avail. I've tried diskpart.exe. When I list the disks or volumes the USB drive shows up but when I try to format it I get the message "Diskpart has encountered an error: The system cannot find the file specified. See the System Event Log for more information." There is no more information in the event log. This is a cheap 2GB drive and it probably would be quicker to go out and buy a new drive but I'm curious. How do get Vista to recognize this drive?
laiminsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mkriszCommented:
Have you tried using the clean command in diskpart? Select the USB device, clean the drive using this clean command. Then you will have to initialize it and create a partition. After creating the partition and formatting it, you should be able to assign it a drive letter.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
laiminsAuthor Commented:
Thanks for the reply. Well, this helps a little bit. After running the clear command I was able to have the machine recognize that I had a drive. However, when I try to format the drive the I get the message: "Windows was unable to complete the format."

Any more ideas as to what to try?
0
laiminsAuthor Commented:
The drive was from a company called Transcend. I went to their web site and downloaded a USB drive repair tool. This formatted the drive and finally let me use it. I'm giving the points to you because you got me started with the clean command.
0
mkriszCommented:
Am, If I were you, I would try formatting it with a 3rd party tool.
a) If you're lucky, it can format it for you
b) On the other hand, windows doesn't show us the reason (just that it wasn't able to format it). Using other products maybe show us the exact reason of the format faliure.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Storage

From novice to tech pro — start learning today.