binding OWA to port 444 instead of 443, and make it accessable through firewall port forwarding

hello experts,

i'll be glad if anyone can help me with this,

we have windows server 2008 and exchange server 2007, OWA is set and active on https://name.domain/owa internally (from other computers on the network),

please if you can help me with two things:

1- bind OWA to port 444 instead of 443 as i made our firewall forward port 444 to the exchange server (443 is used by firewall) it was working in OWA 2003 but when we upgraded it wouldn't work. i tried to open binding in IIS and added port 444 as https but it doesn't work, and when i change the 443 to 444 OWA doesn't open internally anymore

2- make it the default web site, so that i dont have to use /owa in the URL

so the final OWA internal URL would look like https://name.doman:444

and from outside i mm using a DYNdns URL that used to work as https://name.dyndns.org:444

firewall side everything is set, so it is either IIS or OWA settings that is need to be changed

thank you all
maxi86Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

maxi86Author Commented:
so i conclude from that, that all this needs to be done in the firewall :

static (inside,outside) tcp interface <whatever your outside ip address> 443 <whatever your server LAN ip address is> 443 netmask 255.255.255.255

but my firewall is already ready to forward the port 444 to the server,  port 443 is set for the firewall web access so i do not need to forward port 444 to 443, i need to use the port 444 itself on OWA and IIS.

this is what i need to do "change the SSL port on your Exchange server to 444, and keep it as NAT" as stated in this topic

http://www.experts-exchange.com/Security/Software_Firewalls/Enterprise_Firewalls/Cisco_PIX_Firewall/Q_24014443.html

it was working in exchange 2003 , and i did not change any settings in the firewall , it forwards the port 444 correctly to the exchange server, but in the server itself nothings comes up on this port, i tried binding port 444 in IIS to https but when i do that OWA stop working internally, so i am missing something


thank you for your help though, i appreciate it
0
Rajith EnchiparambilOffice 365 & Exchange ArchitectCommented:
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Creating Active Directory Users from a Text File

If your organization has a need to mass-create AD user accounts, watch this video to see how its done without the need for scripting or other unnecessary complexities.

maxi86Author Commented:
thank you, i will try this on sunday as i wont be in office before that
0
MesthaCommented:
Be aware that Exchange doesn't like using another port. You also will be unable to use Outlook Anywhere or Exchange ActiveSync on the other port, as they are hard coded to port 443. Personally I would be looking to kick the firewall off port 443. What is it doing with that port? If it is just a VPN or something then you can probably use another port.

Simon.
0
maxi86Author Commented:
i am using it for web access, as in opening the firewall web page to change any settings when i am outside the company , i do not use it that much, i will consider this and try to do what is easier,

exchange 2003 was working fine on port 444 though
0
MesthaCommented:
I have seen lots of problems with OWA using other ports. Considering what you are doing with port 443, using a non standard port for firewall config would be a better idea - otherwise users will simply keep hitting your firewall page.

Although it is bad security practise to have the firewall configuration accessible from the internet. Ideally it should be accessible only from inside.

Simon.
0
maxi86Author Commented:
i am trying to change the port, i disabled ssl on the firewall web management but when i want to add a VIP and attach it to port 443 it says it is used for firewall management , we have juniper ssg, i will try again later today as i am in office and very busy
0
maxi86Author Commented:
thank you all , i just enabled the firewall on port 444 on the server and binded port 444 to OWA in IIS, 443 still does not work, ill accept this for now, i might come to this issue later when i do not have many other things to do, second link referred to opening port 444 on the server and mainly that was what i missed
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.