SQLBase ODBC Setup

I am having a hell of a time trying to connect to a sqlbase database from a remote machine.  The software is ADP and this is located locally on the machine.  I need to extract some data, but when I setup my ODBC, I am getting the following error when testing my connection:  "Connection failed with SQL State: "08001"".

In my ODBC setup, I set the DSN name, database name, put in username/password, leave everything default and then config file, I point that to the remote computer that has the ini file as followed:  \\ipaddress\C$\ADP\SQLBase\sql.ini.  Also tried copying the sql.ini file to my Gupta folder and point it there.

When I did my test I get above error with the 08001 number.  Anyone have any idea what I did wrong?
Use this when I point the config file to the remote computer.
 
[dbnt1sv]
servername=server2,sqlapipe
dbname=pay4win,sqlapipe
cache=2000
sortcache=2000
readonly=0
locktimeout=3
dbdir=C:\ADP
 
This is what I use when I copy the config file to my computer.
 
[dbnt1sv]
servername=server2,sqlapipe
dbname=pay4win,sqlapipe
cache=2000
sortcache=2000
readonly=0
locktimeout=3
dbdir=\\ipaddress\C$\ADP

Open in new window

holemaniaAsked:
Who is Participating?

[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
Your are showing the SERVER part of the sql.ini. You need the CLIENT part, starting with [win32client].
0
holemaniaAuthor Commented:
Below is the client part.  This is local on the user's computer and I am trying to create an ODBC from my end to extract some data.  So is there anything that I need to do to the sql.ini file and should I copy this to my machine and point to it from the ODBC setup?
[win32client]
clientname=Win32User
 
[win32client.dll]
comdll=sqlapipe
comdll=sqlodb32
;comdll=sqlapipe
;comdll=sqlspx32
;comdll=sqlws32
;comdll=sqlwsspx
;comdll=sqlntnbi
 
 
[win32client.apipe]
 
[win32client.ntnbi]
;RetryTimeout=10
 
[win32client.ws32]
;serverpath=server1,<TCP-ADDRESS>/pay4win,*
 
[win32client.spx32]
 
[win32client.wsspx]

Open in new window

0
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
You will need at least this for using TCP (Pipes are unreliable). You can use local or remote sql.ini.

[win32client]
;clientname=Win32User
 
[win32client.dll]
;comdll=sqlapipe
;comdll=sqlodb32
comdll=sqlws32
 
[win32client.ws32]
serverpath=server2,<TCP-ADDRESS>/*

Open in new window

0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

holemaniaAuthor Commented:
Tried as you suggested with no luck either.  I commented out what you posted.  Went and to the ODBC setup and point it to the ini file.  Still getting the same error.  
0
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
You changed the <TCP-ADDRESS> for sure?
And you have to change the server file, too, it is using only Pipes:

[dbnt1sv]
servername=server2,sqlws32
dbname=pay4win,sqlws32
cache=2000
sortcache=2000
readonly=0
locktimeout=3
dbdir=C:\ADP

and restart SQLBase.
0
holemaniaAuthor Commented:
Yes, this is changed in the ini file on my computer and had the other person reboot their machine.  Below is what I change on my machine, not sure if this needs to be change on the computer where ADP is located?  I commented out the IP address section, but I did put that in there.

[win32client]
;clientname=Win32User

[win32client.dll]
comdll=sqlws32
;comdll=sqlodb32
;comdll=sqlapipe
;comdll=sqlspx32
;comdll=sqlws32
;comdll=sqlwsspx
;comdll=sqlntnbi


[win32client.apipe]

[win32client.ntnbi]
;RetryTimeout=10

[win32client.ws32]
serverpath=server2,<myip address here>/pay4win,*

[win32client.spx32]

[win32client.wsspx]

[dbnt1sv.comments]
;
; This section is for the 1-User SQLBase Win32 database server.
;

[dbnt1sv]
servername=server2,sqlws32
dbname=pay4win,sqlws32
cache=2000
sortcache=2000
readonly=0
locktimeout=3
dbdir=C:\ADP

[dbnt1sv.dll]
comdll=sqlws32

[dbnt1sv.apipe]
0
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
Let's start from the beginning.

The server needs only the [dbnt1sv*] parts.
If programs on that machine want to access the database, the [win32client*] parts are needed, because the machine is acting as server AND as client.

A client needs the [win32client*] parts.
The serverpath is the path to the server (hence the name). The IP address in that setting is the SERVER IP address.

sqlws32 is the DLL which uses TCP/IP communication. It must appear on both clients and server in sql.ini.

Now, your mistake is that you put the CLIENT IP address in sql.ini. Use the server's IP address.

BTW, after changing server sql.ini you only need to restart the SQLBase service (if used) or the executable for the server (if started manually), the PC needs not be restartet!

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
holemaniaAuthor Commented:
Ah my bad on the IP address comment.  That is the server ip address and not mine.  

Now does the ini file on the server need to be change also?  Note that I am changing the ini file from my machine only so that I don't affect what the user is doing.  So i made the above changes to the ini file on my local machine.  Went to ODBC and put DSN, database name, username/password, and point the config to the one on my computer.  Went to test connection and put in SERVER2 as the server name, but still getting the connection failed error.

Probably missing something I guess.  I will do some more poking around today and update.
0
holemaniaAuthor Commented:
Hmmm still seem to have one hack of a time trying to connect to this standalone ADP.  When I contacted ADP support, they said that they don't support connecting to ADP via ODBC, so I'm kind of dead in the water.

We have an online version that I can connect to fine.  However, my other site has a standalone solely for just that site and I am having a heartache connecting to it.

0
Qlemo"Batchelor", Developer and EE Topic AdvisorCommented:
The only things which can be cause a failure if both sql.ini's are correct is the open/transaction/access mode of ODBC driver.
Or TCP connection is not working at all for SQLBase, because of firewall for example.
0
holemaniaAuthor Commented:
Never thought of firewall.  Might be something I"m missing.  I can connect to the online version that is being shared by 3 people, but this standalone is giving me heartburn.  Will check to see if it's firewall blocking me.
0
holemaniaAuthor Commented:
I can't seem to get this to work, but found a workaround.  Created an automated job that run report smith pulling the info that I need on a nightly basis straight from that machine.  From there, I created a service that would grab the excel file and import this into a temp database where I can do whatever is needed with the report.

Thanks for your assistance.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Databases

From novice to tech pro — start learning today.