Vista VPN access error 806 with a twist

Hi all,

An odd problem this one. All the usual checks etc already done (i.e. web searches etc). Various solutions/settings tried no joy.

I have a windows server 2003 box running as our VPN server. I have a laptop running windows vista with a vpn connection (PPTP) set up to talk to it. Sometimes it'll work fine, other times I'll get the error 806 message about GRE protocol, port 1723 etc.

I also have a desktop with the same vpn connection setup and it proceeds to do the same thing. Oddly enough, when one allows me in, the other won't (I don't try and have both connections open at the same time). However, leaving neither connected for about and hour or so (I haven't done a definitive time delay test), means that the one I can connect using changes.

VPN server is set to allocate IP addresses from a static pool, MS-CHAP2 is set to on ... Firewall on the laptop is off, etc.

What I'd like to know is why does work sometimes but not at others ? and if there is a solution to get it working for both machines without problem ?

thanks in advance

Ben
Tiger65Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

IanThCommented:
have you seen this about the gre protocol error
http://www.howtonetworking.com/vpnissues/error806.htm
0
warturtleCommented:
I am going to suggest that whenever you get that error, open the command prompt and try to ping the VPN server by its IP address:

Start->cmd

ping myvpnserver.company.com

or

ping IPaddressofserver

This will tell you if you can actually reach your server or not.

Hope it helps.
0
Rob WilliamsCommented:
As far as both connecting at the same time, that may not be possible. There are two issues:
1) most routers (site from which you are connecting) support a limited number of simultaneous PPTP pass-through tunnels, and many are limited to one. As an example have a look at the NetGear list:
http://kb.netgear.com/app/answers/detail/a_id/1088
2) the server to which you are connecting sees the two remote connections as having the same public IP. This seems to work sometimes but not always due to requiring NAT-T

As for the sometimes connecting and not others, it sounds as if the local router may be holding the connection open (not dropping). Have you tried using a different router, upgrading the router firmware, or connecting from a different location. Also Vista does have some "issues" with some routers for services such as VPN, RDP, SSL, RWW.
http://www.lan-2-wan.com/RD-FAQ.htm#q1
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
10 Tips to Protect Your Business from Ransomware

Did you know that ransomware is the most widespread, destructive malware in the world today? It accounts for 39% of all security breaches, with ransomware gangsters projected to make $11.5B in profits from online extortion by 2019.

Tiger65Author Commented:
Hi All,

many thanks for the comments. Replies as follows:

IanTh: Been there done that made sure the port was open etc brefore posting.

warturtle: already tried that, in all scenarios I can oing the server by name or ip address.

RobWill: I agree with reson for it sometimes connecting and other times not.

For point 1 I'm beginning to suspect it's the router that's the problem, it's supplied by Sky as part of their package.

Good news on it this though is that the remote worker has managed to get one of the laptops that wouldn't connect to connect using the network connection wizard and IP address of the VPN server, rather than the pre-canned one provided by me (I inherited it from my predecessor here and it works fine for one person using Vista but not the other, although the person it works for is using a different wireless router).

So laptop that doesn't work is copming back to me to play with. Given the hassle I'm getting, I might just install XP on it rather than try and fix the Vista problem.

any other comments welcome though.

cheers

Ben
0
Rob WilliamsCommented:
One other thought is Vista has compatibility issues with some routers. Basic browsing usually works fine but you can have unpredictable results with some specialty services like VPN, RDP, and SSL. Many routers can be 'fixed' with a firmware update, or in some cases by disabling the "autotuninglevel":
http://www.lan-2-wan.com/RD-FAQ.htm
0
Tiger65Author Commented:
After much playing about ... this seems to be resolved. Both laptops are now talking to the VPN server (one from wales and one from a more local external connection).

thanks for all the advice.

Ben
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
VPN

From novice to tech pro — start learning today.