Exchange 2003 - Smarthost and DNS - routing problems between 2 exchange servers.

Issue: I have 2 exchange servers connected via a sonicwall site-to-site VPN (no restrictions), server1's internal IP is 192.168.0.10 Server2's external IP is 192.168.1.15.

The ad domain name is enging in .com so myfqdn.com (is the active directory domain) and therfore we are using split dns.

Here is the problem: I need to use a smart host to forward all the clients email, the smarthost works fine, except when trying to deliver into the domain.

I know that i can fix this with a smartly configured connector and some dns changes, all email is delivered to the clients (dns filter for spam) and all email needs to be sent over the snd spam filters smarthost.

Basically we have this.... MX = Anmtispam provider, Antispam provider sends email to the clients mail server by IP.

How do i configure DNS to properly deliver email internally and still use the smart host to deliver mail externally?

Please advise... THis is of higest importance.

Thanks in advance...

Robert


LVL 6
castellansolutionsAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Hypercat (Deb)Commented:
I don't think this is a DNS issue, but an Exchange issue.  Do you have an SMTP connector set up to send your external email through the smart host?
0
castellansolutionsAuthor Commented:
When i do that i get error 554 - routing all day errors. And i get 10+ emails to user in the LA location sent to the blackberrys - but users in the NY location receive mail just fine.

0
castellansolutionsAuthor Commented:
also when i add the smarthost becuase the companys domain is also a .com domain the smart host tries to deliver any/all email even back into the comapnys own domain which creates a routing loop.

0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

Hypercat (Deb)Commented:
That doesn't make sense. Are both of these sites in the same AD domain and the same Exchange organization?
0
castellansolutionsAuthor Commented:
Here is what i did:

1. I removed the smarthost entry from the smtp virtual server.
2. I added a new connector - * and cost of 1
3. I added the smarthost there -

My question is this, will my external mail now be devlivered using the smarthost and my internal mail (again fqdn.COM) be delivered internally?


Robert
0
Hypercat (Deb)Commented:
OK - that explains the problem. This is what I was trying to get to with my first question about the SMTP connector.  You should not use the smarthost entry at all in the SMTP virtual server. Removing that entry and setting it up to send external email using the SMTP connector to the external smarthost should solve your problem.
0
castellansolutionsAuthor Commented:
I did the above and set the following options:

1st connector address space * cost 10
2nd connector address space fqdn.com cost 1

Is that right, Exchange 2003 help crashes when i try to acces it. (figures).

0
Hypercat (Deb)Commented:
PS - Since you have two Exchange servers, if they are both in the same Exchange organizations, I assume that you are trying to send email out using only one of those servers.  In that case, you want to be sure that the default SMTP virtual server on the bridgehead server (as identified in your SMTP connector) is set to use ONLY the internal IP address of that server.  IOW, set it to send using only that internal IP address rather than the "All Addresses" setting that is usually the default.
0
Hypercat (Deb)Commented:
Again, are both servers in the same organization? If so, then you only need one connector. You don't need an SMTP connector for your internal domain. The only one you need is for the * (which means all external addresses).
0
castellansolutionsAuthor Commented:
yes both are in the same exch org. this server keeps trying to deliver everything thrgouh the smart host! I dont get it. It does not seem to deifferenate between the int and ext domains.


0
castellansolutionsAuthor Commented:
This is my problem, the users domin ends in .com. that is the AD domain name. The users email domain is the same. All i want is the mail for the users (.com) domain to be delivered to the correct server. (internally) and not through the smart host.

0
castellansolutionsAuthor Commented:
Well i removed the smart host and naturally all is working well. I just cant quite seem to get this addressed. When i use the smarthost in any connector all of the mail just queus up.

when i remove the smart host i immediately send out. I can send to everywhere fine except (to my domain) when i use the smart host in any connector.

0
Hypercat (Deb)Commented:
That still does not make sense.  I have many many clients whose email domain is the same as their AD domain - AAMOF this is the most common setup I use.  I have never had a problem with an SMTP connector trying to deliver all the mail, including internal email, through the connector.  However, I have not used an external spam filtering service, so maybe that has something to do with it.
In your first post, you made some reference to "split DNS." How do you have this set up? Normally, even if your AD domain and your public domain are the same, you don't have to use split DNS to get email to work properly.  Your internal server simply resolves everything directed to your domain name.  The only time this would cause a problem would be if you had an external host that was running a web site that used the same domain name.  And in that case it would only be your internal users that would be affected.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
castellansolutionsAuthor Commented:
Ok so i have completely started over. should i do the following:

1. Go to the NY Server and add
1a a connecotre pushng all mail (*) to the smart host?
1b add the bridgehead server for (LA and NY) ?
to the same connecor?

Then would all of my internal mail be delivered normally?


Robert
0
Hypercat (Deb)Commented:
I'm pretty sure you should only need one connector pushing all email to the smart host.  That should work for your entire organization, as long as both locations are in the same site. But I just had a thought - your outgoing mail doesn't really have to go through the external host at all, does it?  Isn't that external host only filtering incoming email for spam?
0
castellansolutionsAuthor Commented:
Correct, But in this case it does have to go through the external host as this client needs "Special Care" - 3x in teh last year they have been blocked becuase of spamlike activity - so with the exernal host scanning for both incoming and outgoing messages, that should them from being blocked.

The external host is a dns spam filter company who setup outbound relaying for us.
0
castellansolutionsAuthor Commented:
am i supposed to add both servers as the "Bridgehead" server in the connector?
0
Hypercat (Deb)Commented:
No, you would just put the one that you want to act as the main send/receive server for external email.  Here's an article about setting up an SMTP connector:
http://support.microsoft.com/kb/265293/en-us
 
0
castellansolutionsAuthor Commented:
Thanks for your help i really appreciate it. I got it working yesterday (actually i had it working about 15 times) but becuase of a lack of patience i kept think it was not wokring. I had a bad exchange day.

The issues i had were as follows:

1. On the LA server the smarthost entry was listed there in the smtp virtual server and it was forwarding email back to the ny server.  

2. I had both servers listed in the birdgehead servers tab.

3. The fqdn for ad and for email being the same also confused me as well.

Once again thanks alot...

Robert
0
castellansolutionsAuthor Commented:
excellent followthough on this issue.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Exchange

From novice to tech pro — start learning today.