• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1294
  • Last Modified:

TSKILL Not working/Pskill Does

I'm trying to use a DOS batch file to kill an application that somettimes get stuck in memory.  I am logged on as Adminstrator on Windows Server 2003 machine.  PSKILL works beautifully, but I don't want to knock everyone else using the application to get kicked out, so I am attempting to use tskill. I think this worked in the past but it is not working now. This is the synax of what I'm using:

c:\windows\system32\tskill.exe "filemaker pro.exe" /ID:0

(and 0 is the correct session - I double checked).  I can't use Process ID because this always changes, etc. and way complicated - just want tskill to use Session ID.  Is there something wrong with my syntax?
1 Solution
tklingmanAuthor Commented:
Figure it out. The "FileMaker Pro.exe" part should NOT include the .exe extension.   Should just be "FileMaker Pro"
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now