Can't ping through my serial interfaces to my ethernet interfaces

I have a lab environment that consists of a Cisco 2600 and Cisco 1720 running frame-relay between the two. I can ping my serial interfaces fine and also the loopbacks on each router but I can't ping eithers ethernet interfaces. I'm have no idea whats hapening at this point. Here are the running configs for both?

Cisco-2600#sh run
Building configuration...

Current configuration : 1123 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco-2600
!
boot-start-marker
boot-end-marker
!
enable password topcat
!
username R2 password 0 cisco
username Cisco-1720 password 0 cisco
no network-clock-participate slot 1
no network-clock-participate wic 0
no aaa new-model
ip subnet-zero
ip cef
!
!
!
!
no ip domain lookup
frame-relay switching
no ftp-server write-enable
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip address 10.110.1.1 255.255.0.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 172.12.123.1 255.255.255.0
 encapsulation frame-relay
 frame-relay map ip 172.12.123.1 121
 no frame-relay inverse-arp
 frame-relay lmi-type cisco
 frame-relay intf-type dce
!
interface Serial0/1
 no ip address
 shutdown
!
router rip
 network 10.0.0.0
 network 172.12.0.0
!
ip default-gateway 172.12.123.2
ip classless
ip route 2.2.2.0 255.255.255.0 172.12.123.2
no ip http server
!
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 password topcat
 login
!
!
end

Cisco-1720#sh run
Building configuration...

Current configuration : 872 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cisco-1720
!
enable password topcat
!
username R1 password 0 cisco
username Cisco-2600 password 0 cisco
!
!
!
!
memory-size iomem 25
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface Serial0
 ip address 172.12.123.2 255.255.255.0
 encapsulation frame-relay
 frame-relay lmi-type cisco
!
interface Serial1
 no ip address
 shutdown
!
interface FastEthernet0
 ip address 10.110.2.2 255.255.0.0
 speed auto
!
router rip
 network 10.0.0.0
 network 172.12.0.0
!
ip default-gateway 172.12.123.1
ip classless
ip route 1.1.1.0 255.255.255.0 172.12.123.1
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
 password topcat
 login
!
no scheduler allocate
end
Kgrimm38Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

mdennis4422Commented:
First make sure that their is something plugged into the ethernet interface of the router.  If not then the interface is down and it will not respond.  Also, you will need to source your ping  from the ethernet interface ip address.  WHy do you have your default gateways setup to point to the other routers?
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
that1guy15Commented:
Are the interfaces connected to another device ?
Of not then the interfce will be down and not pingable

Run a "sh ip int bri" and see if the eth interfaces show up/up
0
Ken BooneNetwork ConsultantCommented:
Your frame relay map statement is wrong.

It should read:

frame-relay map ip 172.12.123.2 121 on the first router.

You map the remote IP address to your DLCI.
Also it would be good to add a frame relay map statement on the other router as well.

Also RIP runs on a classful boundary, and your network statement under RIP reads network 172.12.0.0.

This is saying that any interface that is on a 172.12.0.0 / 24 network will run RIP.  You do not have a 172.12.0.x network.  You have a 172.12.123.0 / 24 network.  Your network statement should read

network 172.12.123.0 on both routers

RIP is probably not working between the routers right now and you can ping the serial IPs because they are directly connected and you can ping the loopback IPs because you have static routes on them.
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

Ken BooneNetwork ConsultantCommented:
Also, like mdennis442 said the Eth interfaces need to be up/up.  If you do not have anything to connect into them you can enter the command "no ip keepalive" and the interface will come up.  Only use this in a lab environment.
0
lrmooreCommented:
You are using RIP for routing.
You need to change to RIP v2
Reason is that RIP is classful only and you have 10.x.x.x on both sides
RIP V2 will let you advertise subnets
Else use EIGRP or OSPF instead of RIP
Else just use static routes:
 2600
 ip route 10.110.2.0 255.255.255.0 172.12.123.2

1700:
 ip route 0.0.0.0 0.0.0.0 172.12.123.1


0
TodosCommented:
Both ethernet interfaces of each routers are using an IP in the same subnet. The router will think it needs to deliver the packet locally:

On the 2600:
interface FastEthernet0/0
 ip address 10.110.1.1 255.255.0.0  (Ip address in network ID 10.110.0.0)

On the 1700:
interface FastEthernet0
 ip address 10.110.2.2 255.255.0.0 (Ip address in network ID 10.110.0.0)

You will need to either change the subnet mask to 255.255.255.0 to create network IDs 10.110.1.0 and 10.110.2.0 or choose another subnet all together for one of the two interfaces.

Also make sure that routing does not advertise the class A subnet 10.0.0.0 but adds the divided subnets in the routing table.

Regards,

Mark



0
lrmooreCommented:
nice catch, Todos!
0
Kgrimm38Author Commented:
Thanks very much to all of you for taking the time to answer my question.My main problem was the fact that I didn't have anything plugged into the ethernet interfaces of the routers. Thanks Mdennis4422. of All your solutions were very helpful and informative. I was pretty much all over the road towards the end and was trying anything. The no ip keepalive statement from kenboonejr and also getting the interfaces on the proper subnet and switching to RIPv2 was a great help. Thanks again!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Broadband

From novice to tech pro — start learning today.