Cisco CME and incoming calls

I can't receive incoming calls on my Cisco CME setup. When someone calls me they get a dialtone- if they enter an extension at that point the phone will ring. How can I make it so all the phones ring? Also I dont think the hunt group is working and that would probably be needed to make them ring I'd assume.

My config for the CME router is attached. I have a feeling it needs an incoming dialpeer and have no clue how to do that..
1760voice#show run
Building configuration...
 
Current configuration : 2943 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 1760voice
!
boot-start-marker
boot system flash:c1700-entservicesk9-mz.124-9.T7.bin
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
clock timezone zone 0
clock summer-time zone recurring
voice-card 2
!
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.0.1 192.168.0.19
!
ip dhcp pool lan
   import all
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.2
   dns-server 4.2.2.2
   option 150 ip 192.168.0.2
   lease 3
!
!
!
!
!
voice service voip
 allow-connections h323 to h323
 allow-connections h323 to sip
 allow-connections sip to h323
 allow-connections sip to sip
!
!
!
!
voice class h323 1
  telephony-service ccm-compatible
  ccm-compatible
!
!
!
!
!
voice hunt-group 1 parallel
 pilot 999
!
!
!
!
!
!
username **** privilege 15 password 0 *****
!
!
!
!
!
interface Ethernet0/0
 ip address 192.168.2.2 255.255.255.0
 half-duplex
!
interface FastEthernet0/0
 description $ETH-LAN$
 ip address 192.168.0.2 255.255.255.0
 speed auto
!
router rip
 version 2
 network 192.168.0.0
 network 192.168.1.0
 network 192.168.2.0
 no auto-summary
!
!
!
ip http server
ip http authentication local
no ip http secure-server
ip http path flash:/gui
!
tftp-server flash:/phone/7940-7960/P0030702T023.sbn
tftp-server flash:/phone/7940-7960/P0030702T023.sbn2
tftp-server flash:/phone/7940-7960/P0030702T023.sb2
tftp-server flash:/phone/7940-7960/P0030702T023.loads
tftp-server flash:phone/7940-7960/P0030702T023.bin
!
control-plane
!
!
!
voice-port 2/0
 echo-cancel coverage 32
 description 2343801147
!
voice-port 2/1
!
ccm-manager music-on-hold bind FastEthernet0/0
!
!
!
!
!
dial-peer voice 100 pots
 description outbound dialpeer 1
 preference 7
 destination-pattern 9...........
 port 2/0
!
dial-peer voice 2 pots
 preference 7
!
dial-peer voice 102 pots
!
!
telephony-service
 load 7960-7940 P0030702T023
 max-ephones 10
 max-dn 2
 ip source-address 192.168.0.2 port 2000
 auto assign 1 to 2
 system message Cisco Unified CME
 max-conferences 4 gain -6
 moh music-on-hold.au
 web admin system name **** password *******
 dn-webedit
 time-webedit
 transfer-system full-consult
 directory entry 1 100 name *****
 directory entry 2 101 name *****
 create cnf-files version-stamp Jan 01 2002 00:00:00
!
!
ephone-dn  1
 number 100
 label gina 7960
 description Gina
 name Gina
!
!
ephone-dn  2
 number 101
 label Kevin7960
 description Kevin
 name Kevin
!
!
ephone  1
 no multicast-moh
 description 7960 on Gina's Desk
 mac-address 0015.FAD6.3FDF
 type 7960
 button  1:1
!
!
!
ephone  2
 no multicast-moh
 mac-address 0015.FAD6.3B1F
 type 7960
 button  1:2
!
!
ephone-hunt 1 sequential
 pilot 199
 list 101, 100
 preference 0 secondary 7
!
!
!
line con 0
line aux 0
line vty 0 4
 login
!
ntp server 192.168.0.1
ntp server 209.51.161.238
end

Open in new window

LVL 1
kevinblackburnAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

dgboydCommented:
On your dial-peer 100 add this line:

incoming called-number .

Make sure it has the '.' (dot) on the end.

Let me know if that helps.
0
dgboydCommented:
My mistake here.  That last post won't fix it.  That would be used if you had a PRI into the router.  Since you are using POTS lines, you will need to set a connection plar under your voice port like this:

voice-port 2/0
 connection plar 8001
 echo-cancel coverage 32
 description 2343801147
!

Where the 8001 is the auto attendant or operator number or where you want the incoming call to terminate.

Let me know if that fixes it.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
kevinblackburnAuthor Commented:
Alright I am going to try that now- can I make all phones ring at once?
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

kevinblackburnAuthor Commented:
Connection plar 101 (to my extension 101 phone) worked just fine. any solution to make them all ring?
0
jjmartineziiiCommented:
what happens if you dial extension 999? If it rings all the phones, do this:

config t
voice-port 2/0
connection plar 999
end
wr
0
dgboydCommented:
I usually make the second button on all the phones the 'Office Lines'.  Setup your ephone-dn like this:

ephone-dn  30 dual-line
 number 155
 label (806) 356-9102
 description -- Main Office Hunt
 huntstop channel
 no huntstop
!
!
ephone-dn  31 dual-line
 number 155
 description -- Main Office Hunt
 preference 1
 huntstop channel
 no huntstop
!
!
ephone-dn  32 dual-line
 number 155
 description -- Main Office Hunt
 preference 2
 huntstop channel
 no huntstop
!

connection plar 155 will hunt through the lines.  Then you add the ephone-dn's to the second button on each phone that you want to ring for incoming calls like this:

ephone  1
 device-security-mode none
 mac-address XXX.XXX.XXX
 type 7961
 button  1:1 2c30,31,32,33
!

Hope this helps.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Voice Over IP

From novice to tech pro — start learning today.