OMA will not work on a SBS 2003

Hey there, I have been racking my head with a client's OMA.

The OWA works perfectly, and I do not have SSL set up (for a reason) until I get the OMA up and going.

When I try to go to http://servername/oma , I get the logon prompt and then the page returns after a few seconds "  A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator.
"

The Error log reads:
Event Type:      Error
Event Source:      MSExchangeOMA
Event Category:      (1000)
Event ID:      1503
Date:            5/25/2009
Time:            1:03:28 AM
User:            N/A
Computer:      SERVER2
Description:
An unknown error occurred while processing the current request:
Message: The remote server returned an error: (501) Not Implemented.
Source: Microsoft.Exchange.OMA.ExchangeDataProvider
Stack trace:
   at Microsoft.Exchange.OMA.ExchangeDataProvider.OmaWebRequest.GetRequestStream()
   at Microsoft.Exchange.OMA.ExchangeDataProvider.ExchangeServices.GetSpecialFolders()
   at Microsoft.Exchange.OMA.ExchangeDataProvider.ExchangeServices..ctor(UserInfo user)

Message: Exception has been thrown by the target of an invocation.
Source: mscorlib
Stack trace:
   at System.Reflection.RuntimeConstructorInfo.InternalInvoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture, Boolean isBinderDefault)
   at System.Reflection.RuntimeConstructorInfo.Invoke(BindingFlags invokeAttr, Binder binder, Object[] parameters, CultureInfo culture)
   at System.RuntimeType.CreateInstanceImpl(BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
   at System.Activator.CreateInstance(Type type, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
   at Microsoft.Exchange.OMA.UserInterface.Global.Session_Start(Object sender, EventArgs e)

Message: Exception of type Microsoft.Exchange.OMA.DataProviderInterface.ProviderException was thrown.
EventMessage:
UserMessage: A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator.
Source: Microsoft.Exchange.OMA.UserInterface
Stack trace:
   at Microsoft.Exchange.OMA.UserInterface.Global.Session_Start(Object sender, EventArgs e)
   at System.Web.SessionState.SessionStateModule.RaiseOnStart(EventArgs e)
   at System.Web.SessionState.SessionStateModule.CompleteAcquireState()
   at System.Web.SessionState.SessionStateModule.BeginAcquireState(Object source, EventArgs e, AsyncCallback cb, Object extraData)
   at System.Web.AsyncEventExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute()
   at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)




I have tried many different fixes from recreating the virtual directory to running the dreaded internet setup wizard ("connect ot the internet" from the management console, I've crunched myself with this one in early versions of SBS 2003, but I did it to try)

I have dug through EE articles about 4 pages deep, and all goes around the same topics, but I cannot seem to fix with any of the solutions.  I have looked at other client systems that are running OMA fine and the IIS seems to be the same.  Is there a file munged somewhere?

Please help!

Running sbs2003 sp2 with exchange update sp2
bcameron70Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MesthaCommented:
First - check that asp.net 2.0 is not enabled on the virtual directories.
Second - reset the virtual directories: http://support.microsoft.com/default.aspx?kbid=883380
Third - run the configure internet and email wizard.

This is SBS, you cannot avoid using the wizards. It is designed to be managed by them and trying to configure an SBS without them will simply cause you further problems. The wizards do an awful lot in the background to ensure that everything is setup correctly. I learnt that lesson a long time ago, and even though I can configure everything manually (I am an Exchange MVP) I do everything with the wizards.

I would also suggest that you get a commercial SSL certificate, I usually use GoDaddy. https://CertificatesForExchange.com because you may well find that the feature fails when you start to use SSL. Furthermore SBS is setup to use SSL everywhere, and undoing that work is again an uphill battle.

Don't try and work against SBS and its wizards, ultimately you will lose and the server will not work correctly.

Simon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
bcameron70Author Commented:
Yes, going against the wizards are bad.

Just as you entered your comments which are all good points, I tried this workaround and things seemed to pick up and run.

http://www.ureader.com/message/47285.aspx

Open registry editor.  In the following registry:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MasSync\Parameters\ExchVDir
-point it back to /Exchange (because SSL is not enabled)

Thank you
0
bcameron70Author Commented:
I found another fix at the same time of this posting, however between all this content, it helped towards my resolution, thank you
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
SBS

From novice to tech pro — start learning today.