outlook wont start on terminal unless user is administrator

I have recently stopped users from being domain admins on a network.
Users log into a terminal server to work.
All apps work ok, users can log in etc
Outlook gives the error "Cannot Start Microsoft Office Outlook" with no events in any logs.
If I "RUN AS" administrator then it works ok.
Outlook works fine on the user's PC.
Environment is SBS2003, exchange, and a second server as a Terminal server.
LVL 20
wolfcamelAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

wolfcamelAuthor Commented:
I should add..
domain users has full access to program files
the specific user has full access to her own profile.
0
wolfcamelAuthor Commented:
also..
if i go into control panel / mail - I get an error about not enough memory or system resources.
I am guessing it is a security issue wih MAPI - however the users has read/excute access to all the folders that contain all the MAPI dlls.
0
ashwynrCommented:
Did you install Terminal Services before installing Outlook?
Was Outlook installed in Application mode or Terminal Services mode?
Have you tried creating a new Windows profile on the TS for the user? Try deleting the existing profile and ask the normal user (not Domain Admin) to login and check if everything works normal.

The memory error could be a red herring, check in the System32 folder to see if a  "MAPISTUB.DLL"  file is present.  If it is not there then either get it from Outlook CD or from the below link
http://www.dlldump.com/download-dll-files_new.php/dllfiles/M/mapistub.dll/1.0.2536.0/download.html

If the file is present, register it.  Go to Start > Run and type regsvr32 MAPISTUB.DLL

#wyn
0
Newly released Acronis True Image 2019

In announcing the release of the 15th Anniversary Edition of Acronis True Image 2019, the company revealed that its artificial intelligence-based anti-ransomware technology – stopped more than 200,000 ransomware attacks on 150,000 customers last year.

wolfcamelAuthor Commented:
ok some updates..
and answers to your questions/suggestions.
terminal services was installed before outlook.
I logged in as another test user that isnt an administrator and had no probs.
the profiles are set to roaming in this domain (which i dnt like but still) - so I disabled the roaming profile for this user, deleted the profile on the Terminal and logged in, with the new profile outlook works fine.
But they want to use the existing profile as their are quite a lot of settings that the user has configured for quite a few apps, and they do also run some apps locally.
If I put it back to roaming profile the problem reoccurs -
Hence - I assumeit is something in the users profile , maybe an outlook addin, or other setting that is stopping this.
I think the admin change was misleading - this particular user has never used outlook on the terminal.
I doubt themapistub issue as no problem for other users.
0
wolfcamelAuthor Commented:
Also - I found this which identically describe my problem - control panel issue and all
http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Server/2003_Server/Q_22138463.html 

I have been through the GPO and cant spot anything abnormal - and i dint need to move the user to 'solve' the problem - i just needed to force it stop using the roaming profile
0
ashwynrCommented:
OK so the issue is definitely with users roaming profile. Try the following:

Copy users roaming profile to the TS
Rename the roaming profile to something else other that what it is now. By doing this the roaming profile path mentioned in the AD will point to a profile which does not exist.
Now ask the user to log onto the TS and see if Outlook works, if it doesn't then ask him to log off. This would copy the profile from the TS to roaming profile location.
Delete the profile from the roaming profile path
Browse to users profile on the TS and rename the Outlook Folders to OutlookOLD

Documents and Settings\%USERNAME%\Local Settings\Application Data\Microsoft\Outlook
Documents and Settings\%USERNAME%\Application Data\Microsoft\Outlook

Ensure that users roaming profile path doe not contain any profile.

Now ask the user to log onto the TS and check is everything is working fine or not.

#wyn
0
wolfcamelAuthor Commented:
tried the above (sort of)
if i use the terminal copy of the profile (after turning off roaming profiles), outllok still doesnt work.
if I then delete/rename the outlook folders - outlook still doesnt work.

Only way it works is with a completely new profile - the problem must be in the registry?
0
ashwynrCommented:
The problem is with the profile and not with registry. Even if you will delete the users GUID key from HKEY_Users, the entries will return after the roaming profile will be loaded.

Hence, I think the only way out is to use a new profile and import application settings from the old one (if possible).
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
wolfcamelAuthor Commented:
IN the end I reinstalled outlook on the server, and this resolved the issue - which doesnt make a lot of sense given others users where ok. Points awarded simply to thank you for your effort.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Server OS

From novice to tech pro — start learning today.