How to configure new 2811 router, to connect to remote 1811 router?

There is a new purchase request on this new 2811 router. This router will link up with a remote 1811 router, located in other country. Other modules, such as, 1 two-port voice interface card - FXS and DID, and 32-channel packet voice/fax DSP module are purchased well. If I were not wrong, the purchase also includes 4HWICs, 2PVDMs, 2AIM. What are they?

I have a discussion with my boss. The remote router 1811 will connect with router 2811 thru one WAN port, voice/fax also piggyback on this router as well. My main concern is how can I configure Voice/fax? If possible, pls provide me a typical scenario configuration.


thanks,
BalackAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nasirshCommented:
This is very simple. Your 2811 router will communicate with the 1811 router via site-to-site vpn and voice can then be transferred between them. Your one wan port will communicate with the other routers wan port via public IP. Secondly you can configure voice easily form. Attached is a sample file from where you can get the idea.

Current configuration : 5850 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ACCARIPORTR01
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
!
!
ip cef
no ip dhcp use vrf connected
!
ip dhcp pool airport
   import all
   network 192.168.12.0 255.255.255.0
   domain-name dgadgdsgsdsfsdfa.cc.ff
   dns-server 192.168.1.1 192.168.10.1
   default-router 192.168.12.222
   option 150 ip 192.168.12.9
   lease infinite
!
!
no ip domain lookup
ip domain name fsdasdf.cc.ff
!
!
!
voice-card 0
 no dspfarm
!
!
!
!
!
!
!
!
voice class dualtone-detect-params 1
 freq-max-deviation 25
!
!
voice class custom-cptone SI
 dualtone disconnect
  frequency 450
  cadence 475 475
!
!
!
!
!
!
!
!
!
!
crypto pki trustpoint TP-self-signed-2468908063
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-2468908063
 revocation-check none
 rsakeypair TP-self-signed-2468908063
!
!
crypto pki certificate chain TP-self-signed-2468908063
 certificate self-signed 01
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXxxxx
XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXx
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx

  quit
username xxx privilege 15 secret 5 $1$QEBdsffdgadsjJ3/pdGYdNzZ8Sj0

!
!
crypto isakmp policy 1
 encr 3des
 authentication pre-share
 group 2
!
crypto isakmp policy 20
 encr 3des
 hash md5
 authentication pre-share
 group 2
 lifetime 28800
!
crypto isakmp policy 60
 encr 3des
 hash md5
 authentication pre-share
 group 2
 lifetime 28800
crypto isakmp key JKAHaadsfsdfsdfsdfsdfsdfs address 10.2.2.11
crypto isakmp key JKAHaadsfsdfsdfsdfsdfsdfs address 10.2.2.12


crypto isakmp keepalive 10
crypto isakmp aggressive-mode disable
!
!
crypto ipsec transform-set ESP-3DES esp-3des esp-sha-hmac
!
crypto ipsec profile VPN-RADIO
 set transform-set ESP-3DES
 set pfs group2

!
interface Tunnel12
 ip address 172.16.12.2 255.255.255.252
 ip broadcast-address 0.0.0.0
 ip mtu 1420
 ip tcp adjust-mss 1320
 tunnel source 10.2.2.122
 tunnel destination 10.2.2.11
 tunnel mode ipsec ipv4
 tunnel protection ipsec profile VPN-RADIO
!
interface FastEthernet0/0
 description MRADIO
 ip address 10.2.2.122 255.255.255.0
 no ip unreachables
 no ip proxy-arp
 duplex half
 speed auto
!
interface FastEthernet0/1
 description AIRPORT LAN
 ip address 192.168.12.222 255.255.255.0
 ip broadcast-address 0.0.0.0
 duplex auto
 speed auto
!
ip route 0.0.0.0 0.0.0.0 10.2.2.222
!
!
no ip http server
ip http secure-server
!
snmp-server community Procredit RO
snmp-server location HO
snmp-server host 192.168.10.3 Procredit
!
!
!
control-plane
!
!
!
ccm-manager mgcp
!        
mgcp      
mgcp call-agent 192.168.12.9 2000 service-type mgcp version 0.1
mgcp dtmf-relay voip codec all mode cisco
mgcp validate domain-name
!
mgcp profile default
!
!
dial-peer voice 1 pots
 destination-pattern 9T
 forward-digits 0
!
dial-peer voice 11 pots
 destination-pattern 9T
!
dial-peer voice 12 pots
 destination-pattern 9T
!
dial-peer voice 13 pots
 destination-pattern 9T
!
dial-peer voice 14 pots
 destination-pattern 9T
!
!
!
call-manager-fallback
 max-conferences 4 gain -6
 transfer-system full-consult
 ip source-address 192.168.12.222 port 2000
 max-ephones 30
 max-dn 30
!
!
line con 0
 login local
line aux 0
line vty 0 4
 login local
 escape-character 27
line vty 5 14
 login local
 escape-character 27
line vty 15
 login local
!
scheduler allocate 20000 1000
!
end
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Anti-Virus Apps

From novice to tech pro — start learning today.